Ubuntu

Notifications overlap the bottom panel.

Reported by Scott Robinson on 2006-05-19
98
This bug affects 4 people
Affects Status Importance Assigned to Milestone
notification-daemon
Fix Released
Unknown
notification-daemon (Ubuntu)
Low
Unassigned

Bug Description

In recent versions, the notifications overlap the bottom panel instead of appearing higher up and thus not on top of it.

Scott Robinson (scott-ubuntu) wrote :

This bug still exists in edgy.

Michael Vogt (mvo) wrote :

Confirmed, can be easily reproduced via:
$ notify-send header "some text"

Changed in notification-daemon:
importance: Medium → Low
status: Unconfirmed → Confirmed
Alexander Jones (alex-weej) wrote :

Still exists in Feisty.

I have no idea how this works, but doesn't gnome-panel somehow "reserve" space so that this kind of thing doesn't happen?

Jonh Wendell (wendell) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://trac.galago-project.org/ticket/109

Jonh Wendell (wendell) wrote :

Fixed on upstream.

Changed in notification-daemon:
status: Confirmed → Fix Committed
Alexander Jones (alex-weej) wrote :

Er, did you update the wrong field? Are you sure the Ubuntu package has this fix?

Alexander Jones (alex-weej) wrote :

(At least, it's not fixed in Gutsy...)

Jonh Wendell (wendell) wrote :

It's not fixed in gutsy because it wasn't released any new version of notification-daemon after the fix.

When the fix is available to Ubuntu, the status of this bug will be 'fix released', instead of 'fix commited'.

Alexander Jones (alex-weej) wrote :

I've changed the bug statuses to reflect this.

Changed in notification-daemon:
status: Unconfirmed → Fix Committed
status: Fix Committed → Confirmed
Murat Gunes (mgunes) wrote :

John, which versions did you mean with "latest versions" in the upstream bug comment? libnotify 0.4.4 and notification-daemon 0.3.7 changelogs (neither upstream nor Ubuntu) don't indicate a fix, and I can't see anything relevant in the trunk revision logs either.

Jonh Wendell (wendell) wrote :

I mean SVN. Try the version on Galago SVN and you'll see this bug fixed.

George Fragos (fragos) wrote :

Still happens with Gutsy RC. This happens consistently with Gedit when you select open. The bottom of the resulting window will be behind the lower applet bar instead of aligned on top of the bar.

Alexander Jones (alex-weej) wrote :

George, that's not a "notification" in the sense that we're talking about. "Notifications" are the little yellow bubbles that pop up now and again.

Murat Gunes (mgunes) wrote :

Would it be a good idea to apply the fix from SVN to the Ubuntu package? There seems to be no upstream release on the horizon.

David Planella (dpm) wrote :

Could anyone point to the SVN revision where this was fixed?

The upstream bug does not offer any useful information in this respect other than that this might be fixed (but how and where is not mentioned).

David Planella (dpm) on 2008-04-17
Changed in notification-daemon:
status: Fix Committed → Unknown
Changed in notification-daemon:
status: Unknown → Fix Released
Murat Gunes (mgunes) wrote :

The only relevant revision I can see looks like revision 2450:

> r2450 | chipx86 | 2006-01-20 10:22:59 +0200 (Fri, 20 Jan 2006) | 2 lines
>
> Respect the user's work area (the area inside the panels and stuff) when displaying notifications.

But that was way before the last release. It should be something else.

The SVN log is at [1] ; if anyone can spot the fix, apply, create a debdiff [2] and do what's needed [3] to get this in before release (for which there's admittedly little chance), I'd appreciate it; unfortunately I don't have any more time to devote to this at the moment.

[1] http://paste.ubuntu-nl.org/63649/
[2] https://wiki.ubuntu.com/PackagingGuide/Recipes/Debdiff
[3] https://wiki.ubuntu.com/FreezeExceptionProcess#head-0779ccd121e4fa5d7f10b6caaefc1f7665943f06

Nick B. (futurepilot) wrote :

I've been looking into this and figured it out that the problem is somewhere in the 03_fix_xinerama_stack_c.patch patch for the notification-daemon. I built packages of the new release of libnotify 0.4.5 and notification-daemon 0.4.0 in my PPA hoping the fix would be in the new release, but after installing them I saw the same problem. I rebuilt notification-daemon without the 03_fix_xinerama_stack_c.patch patch and the notifications don't overlap the panels anymore. It might be better though to figure out where the problem is exactly in the patch instead of removing the entire patch.

Bruce Cowan (bruce89) wrote :

That patch (http://patches.ubuntu.com/n/notification-daemon/extracted/03_fix_xinerama_stack_c.patch) replaces quite a bit of code (including the bit which takes into account the panels) with simply one function (gdk_screen_get_monitor_geometry), which doesn't. Perhaps someone could so something a bit less destructive?

Bruce Cowan (bruce89) wrote :

Escuse my spam, but Bug #31433 was the cause of this patch.

Damiano Dallatana (damidalla) wrote :

Bug is still there, even if "Fixed" upstream, in Intrepid. Is it going to make its way into Jaunty?

Bruce Cowan is correct, the 03_fix_xinerama_stack patch introduces this problem, however upstream still has the problem that that patch is attempting to fix.

I have attached another patch that attempts to solve both problems. It's still not perfect; ideally we would like the default monitor to be the one the notification applet is on, as that way the notifications follow the notification area, which makes sense. Unfortunately this is not easy to determine.

Pedro Villavicencio (pedro) wrote :

Michael, may you have a look to the patch Mark has provided? thanks.

Changed in notification-daemon:
assignee: nobody → mvo
Umang Varma (umang) wrote :

Sorry, I don't know whether this is the same issue that is being discussed here, so please do let me know.
When I unmount a USB drive (Pen drive, thumb drive), I occasionally get a message saying that it is safe to remove the device. Most of the time (95%) I do not get this message no matter how long I wait after unmounting.

Is this the same issue or should I report this elsewhere? (Being the lone tech-savy user of this computer, it is a little important that I fix this issue so that others don't need my help to use USB sticks)

Nicolò Chieffo (yelo3) wrote :

It's a different issue. maybe you should report it to gnome-mount.

Michael Vogt (mvo) on 2011-02-16
Changed in notification-daemon (Ubuntu):
assignee: Michael Vogt (mvo) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.