"Notification Settings" is available but has no effect when Notify OSD is used

Bug #332014 reported by Dave Morley on 2009-02-20
66
This bug affects 9 people
Affects Status Importance Assigned to Milestone
notification-daemon (Ubuntu)
Medium
Martin Pitt
Declined for Jaunty by Martin Pitt

Bug Description

Jaunty includes a "System" > "Preferences" > "Notification Settings" window (/usr/bin/notification-properties) that lets you choose what theme notification-daemon bubbles use, and in which corner of the screen they appear.

When Notify OSD is being used, this settings window is still available, so someone might reasonably expect it still to work, but it has no effect.

Either Notify OSD should obey the settings, or the "Notification Settings" window should not be available when Notify OSD is being used instead of notification-daemon.

See also bug 301766.

Martin Olsson (mnemo) wrote :

Happens on my machine as well (jaunty bits as of feb 20th).

description: updated
James Westby (james-w) on 2009-02-20
Changed in notify-osd:
importance: Undecided → High
status: Confirmed → Triaged
Changed in notify-osd:
assignee: nobody → james-w
James Westby (james-w) wrote :

Since notify-osd doesn't conflict with notification-daemon for

  https://wiki.ubuntu.com/DesktopTeam/Specs/Jaunty/StracciatellaSession

then notification-daemon installs notification-properties. This shows
in the menu whichever service is running, but doesn't have any effect
on notify-osd.

Thanks,

James

Changed in notify-osd:
assignee: james-w → nobody
Martin Pitt (pitti) wrote :

This can't be fixed in stracciatella-session, since that's not even installed by default, and *if* you are running it, then you do want the menu entry.

We currently do not have a way to show/hide menu entries based on $GDMSESSION, and using OnlyShowIn= doesn't work.

One option would be to introduce a new field X-ShowIf: which runs a command which determines whether or not to display it, but that's (a) hackish and (b) won't be accepted upstream probably.

But since neither notification-daemon nor stracciatella-session are installed by default now, I downgrade its importance a bit.

Changed in stracciatella-session:
assignee: nobody → pitti
importance: High → Medium
Martin Pitt (pitti) wrote :

Hm, can we just stop showing this menu item completely? It doesn't seem to be all that useful in the first place, and we could declare it as a feature to remove clutter from the menus. :-)

Dean Loros (autocrosser) wrote :

Is that Gnome--think??? Really--I would like a way to define the theme of the notify--black is getting old..........

description: updated
Matthew Paul Thomas (mpt) wrote :

Martin, notification-daemon is installed by default in 8.10, so when upgraded to 9.04, it will pull in notification-properties automatically, correct? I think it's just as important that a new Ubuntu release is coherent for someone upgrading as for someone doing a fresh install. It would be quite bad if one of the most obvious new things about 9.04 apparently included settings that didn't work at all.

I see a few options here:
1. Return notify-osd to Conflicts:+Replaces: notification-daemon, as it did originally. That would make stracciatella-session impractical.
2. Have notification-daemon not pull in notification-properties by default (as you suggest, and bug 301766 asks for). But that could be seen as unfairly hobbling notification-daemon.
3. Have the Intrepid->Jaunty upgrade script uninstall notification-daemon, without using Conflicts: to do so.

<quote>
Hm, can we just stop showing this menu item completely? It doesn't seem to be all that useful in the first place, and we could declare it as a feature to remove clutter from the menus. :-)
</quote>

I believe at this stage, this is the correct approach. We should do this before UI freeze if at all possible. If we need a more subtle system to sometimes include the menu entry, we can revisit after UIF.

Matthew Paul Thomas [2009-03-01 0:38 -0000]:
> 2. Have notification-daemon not pull in notification-properties by
> default (as you suggest, and bug 301766 asks for). But that could be
> seen as unfairly hobbling notification-daemon.

That's my preferred option as well, and it seems Rick's, too. Thanks
for pointing out bug 301766. Is that okay for you?

Changed in notification-daemon:
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package notification-daemon - 0.4.0-0ubuntu3

---------------
notification-daemon (0.4.0-0ubuntu3) jaunty; urgency=low

  * Add 08_hide_properties_desktop.patch: Do not display
    notification-properties in the menu by default; it's not worth spending a
    menu item for this small thing, users can reenable it with alacarte, and
    it doesn't work for notify-osd at all. (LP: #301766, #332014)

 -- Martin Pitt <email address hidden> Wed, 04 Mar 2009 09:05:13 +0100

Changed in notification-daemon:
status: In Progress → Fix Released
Dave Stroud (bigdavesr) wrote :

I need to get rid of the ugly black bacground in notification. Notification properties no longer works. How can this be changed? thanks

Martin Pitt (pitti) wrote :

Dave Stroud [2009-03-13 17:41 -0000]:
> I need to get rid of the ugly black bacground in notification.
> Notification properties no longer works. How can this be changed? thanks

Uninstall notify-osd and install notification-daemon. Or install
gnome-stracciatella-session and pick "GNOME (without Ubuntu
modifications)" session in gdm.

Christian Rudh (crudh) wrote :

I had the notification-properties menu item in 9.04 and it is still there in 9.10 beta. Is the fix only for new installs so I have to manually hide it on update?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers