notification-daemon crashed with signal 5 in g_logv()

Bug #122637 reported by Duncan Lithgow on 2007-06-27
104
This bug affects 21 people
Affects Status Importance Assigned to Milestone
notification-daemon (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: notification-daemon

The only thing that happened was that the power cord for this laptop briefly came loose. So I think the crash is because the machine wanted to give me some notification popups about the power state change.

ProblemType: Crash
Architecture: i386
Date: Wed Jun 27 19:55:46 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/lib/notification-daemon/notification-daemon
NonfreeKernelModules: cdrom
Package: notification-daemon 0.3.7-1ubuntu2
PackageArchitecture: i386
ProcCmdline: /usr/lib/notification-daemon/notification-daemon
ProcCwd: /
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_DK.UTF-8
 SHELL=/bin/bash
Signal: 5
SourcePackage: notification-daemon
StacktraceTop:
 g_logv () from /usr/lib/libglib-2.0.so.0
 g_log () from /usr/lib/libglib-2.0.so.0
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 ?? ()
Title: notification-daemon crashed with signal 5 in g_logv()
Uname: Linux ubuntu 2.6.22-7-generic #1 SMP Mon Jun 25 17:33:14 GMT 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video

Duncan Lithgow (duncan-lithgow) wrote :

StacktraceTop:IA__g_logv (log_domain=<value optimized out>, log_level=G_LOG_LEVEL_ERROR, format=0xb7a775a0 "%s", args1=0xbfb7760c "`[K\b�")
IA__g_log (log_domain=0xb7a5b0a3 "Gdk", log_level=G_LOG_LEVEL_ERROR, format=0xb7a775a0 "%s") at /build/buildd/glib2.0-2.13.5/glib/gmessages.c:517
gdk_x_error (display=0x8064000, error=0xbfb776b8) at /build/buildd/gtk+2.0-2.11.4/gdk/x11/gdkmain-x11.c:641
_XError (dpy=0x8064000, rep=0xbfb777ac) at ../../src/XlibInt.c:2907
_XReply (dpy=0x8064000, rep=0xbfb777ac, extra=0, discard=0) at ../../src/XlibInt.c:1833

Changed in notification-daemon:
importance: Undecided → Medium
status: New → Triaged
Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a valgrind log following the instructions at https://wiki.ubuntu.com/Valgrind and add the file as an attachment to your bug report. This will greatly help us in tracking down your problem.

Changed in notification-daemon:
assignee: nobody → brian-murray
status: Triaged → Incomplete
C de-Avillez (hggdh2) wrote :

From by backtrace (bug 122909) I see:

(gdb) bt
#0 IA__g_logv (log_domain=0x2ae47c213bd3 "Gdk", log_level=<value optimized out>, format=0x2ae47c230794 "%s", args1=0x7fff2fa06800)
    at /build/buildd/glib2.0-2.13.5/glib/gmessages.c:503
#1 0x00002ae47cdf6693 in IA__g_log (log_domain=0x2ae47d5f3960 "", log_level=10655920, format=0xa29490 "")
    at /build/buildd/glib2.0-2.13.5/glib/gmessages.c:517
#2 0x00002ae47c1fd1d9 in gdk_x_error (display=<value optimized out>, error=0x7fff2fa06980)
    at /build/buildd/gtk+2.0-2.11.4/gdk/x11/gdkmain-x11.c:641
#3 0x00002ae47c6ae8c6 in _XError (dpy=0x6284c0, rep=<value optimized out>) at ../../src/XlibInt.c:2907
#4 0x00002ae47c6b0379 in _XReply (dpy=0x6284c0, rep=0x7fff2fa06af0, extra=0, discard=0) at ../../src/XlibInt.c:1833
#5 0x00002ae47c69430d in XGetWindowProperty (dpy=0x6284c0, w=76, property=442, offset=0, length=9223372036854775807, delete=0,
    req_type=19, actual_type=0x7fff2fa06be8, actual_format=0x7fff2fa06c04, nitems=0x7fff2fa06be0, bytesafter=0x7fff2fa06bd8,
    prop=0x7fff2fa06bd0) at ../../src/GetProp.c:64
#6 0x0000000000403d5e in notify_daemon_notify_handler (daemon=0x631b70, app_name=<value optimized out>, id=0,
    icon=<value optimized out>, summary=<value optimized out>, body=<value optimized out>, actions=0x665700, hints=0x6f6580,
    timeout=-1, context=0xa1f720) at daemon.c:750
#7 0x0000000000404d35 in dbus_glib_marshal_notification_daemon_VOID__STRING_UINT_STRING_STRING_STRING_BOXED_BOXED_INT_POINTER (
    closure=0x7fff2fa06e80, return_value=<value optimized out>, n_param_values=<value optimized out>, param_values=0x6f0170,
    invocation_hint=<value optimized out>, marshal_data=0x403990) at notificationdaemon-dbus-glue.h:100
#8 0x00002ae47b2cc654 in ?? () from /usr/lib/libdbus-glib-1.so.2
#9 0x00002ae47b4fa019 in _dbus_object_tree_dispatch_and_unlock (tree=0x6477b0, message=0x649530) at dbus-object-tree.c:842
#10 0x00002ae47b4edfdb in dbus_connection_dispatch (connection=0x6479e0) at dbus-connection.c:4308
#11 0x00002ae47b2c9495 in ?? () from /usr/lib/libdbus-glib-1.so.2
#12 0x00002ae47cdedfd3 in IA__g_main_context_dispatch (context=0x63b520) at /build/buildd/glib2.0-2.13.5/glib/gmain.c:2061
#13 0x00002ae47cdf12dd in g_main_context_iterate (context=0x63b520, block=1, dispatch=1, self=<value optimized out>)
    at /build/buildd/glib2.0-2.13.5/glib/gmain.c:2694
#14 0x00002ae47cdf15ea in IA__g_main_loop_run (loop=0x64bcf0) at /build/buildd/glib2.0-2.13.5/glib/gmain.c:2898
#15 0x00002ae47bcf5743 in IA__gtk_main () at /build/buildd/gtk+2.0-2.11.4/gtk/gtkmain.c:1144
#16 0x0000000000404a3a in main (argc=1, argv=0x7fff2fa07408) at daemon.c:1122
#17 0x00002ae47d2bf8e4 in __libc_start_main () from /lib/libc.so.6
#18 0x0000000000403209 in _start ()
(gdb)

So glib is SIGTRAPping due to its settings due to what seems to be a X error.

Duncan Lithgow (duncan-lithgow) wrote :

Here's the valgrind logs of gnome-power-manager, I hope that the right program. I'll try again with notification-daemon later

I had trouble reproducing this as the timing of taking the power connection out and in again seems to be quite specific. I'm wondering if it has something to do with the new screen brightness status message which appears when the screen is dimmed and brightened up again.

Duncan Lithgow (duncan-lithgow) wrote :

Can't run Valgrind on notification-daemon

duncan@ubuntu:~$ G_SLICE=always-malloc G_DEBUG=gc-friendly valgrind -v --tool=memcheck --leak-check=full --num-callers=40 --log-file=valgrind.log notification-daemon
valgrind: notification-daemon: command not found
duncan@ubuntu:~$

Sebastien Bacher (seb128) wrote :

You need to use /usr/lib/notification-daemon

Could you install gnome-power-manager-dbgsym and get a new log? There is an error in the log and no detail

Sebastien Bacher (seb128) wrote :

you can attach the valgrind log to a new gnome-power-manager bug, the bug is not a notification-daemon one

Here's what I just got trying to run valgrind and notification-daemon

duncan@ubuntu:~$ G_SLICE=always-malloc G_DEBUG=gc-friendly valgrind -v --tool=memcheck --leak-check=full --num-callers=40 --log-file=valgrind.log /usr/lib/notification-daemon/notification-daemon

***MEMORY-WARNING***: notification-daemon[28739]: GSlice: g_thread_init() must be called before all other GLib functions; memory corruption due to late invocation of g_thread_init() has been detected; this program is likely to crash, leak or unexpectedly abort soon...

Is that bug 116870?

(Have I understood: the error in the log from gnome-power-manager is not connected to this bug and should go to a new bug report?)

Sebastien Bacher (seb128) wrote :

the warning is not likely the cause of the crasher. The gnome-power-manager error should go to a new bug

Sebastien Bacher (seb128) wrote :

ok, those the g_logv function are misleading, the real crash is the gdk_x_error there. Do people having the bug use compiz?

Shirish Agarwal (shirishag75) wrote :

Ok as one of the users whose bug has been marked as a duplicate of this bug, no haven't used compiz.

Bryce Harrington (bryce) wrote :

The gdk_x_error seems to be just another error message logger, the bug seems to lay between notify_daemon_notify_handler and a call to XGetWindowProperty. Perhaps XGetWindowProperty is getting called with an invalid parameter? length=2147483647 looks odd, but could also be an invalid pointer.

Yes, using compiz -- this is right from the very first load after
install + dist-upgrade. Dell D610 (ATI graphics.)

Paul.

Sebastien Bacher wrote:
> ok, those the g_logv function are misleading, the real crash is the
> gdk_x_error there. Do people having the bug use compiz?
>

...and I've seen this bug with and without compiz enabled.

menihtas (menihtas) wrote :

Killed notification-daemon after all, but I already had this warning

***MEMORY-WARNING***: notification-daemon[23571]: GSlice: g_thread_init() must be called before all other GLib functions; memory corruption due to late invocation of g_thread_init() has been detected; this program is likely to crash, leak or unexpectedly abort soon...

Prob appeared on regular desktop pc during apt-get upgrade.

C de-Avillez (hggdh2) wrote :

no compiz, but I will go back into my crash report to find out the most I can about it.

Changed in notification-daemon:
assignee: brian-murray → nobody

I no longer run Ubuntu 7.10 so I can't actively help with this bug. Good luck. (Unsubscribing)

Roy Jamison (xteejx) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Roy Jamison (xteejx) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in notification-daemon (Ubuntu):
status: Incomplete → Invalid
Peter Thor (thor-peter) on 2011-08-30
Changed in notification-daemon (Ubuntu):
status: Invalid → New
Peter Thor (thor-peter) wrote :

Crash after livecd boot.

Peter Thor (thor-peter) wrote :
tags: added: iso-testing
Pedro Villavicencio (pedro) wrote :

please open a new report this was closed ages ago and also is not installed by default in oneiric so no way you get that using the cd.

Changed in notification-daemon (Ubuntu):
status: New → Won't Fix
Julien Lavergne (gilir) wrote :

To add more details, apport point to this bug report when trying to report it automaticly. It's reproductible with Lubuntu ISO 20110830.2. I opened a new bug report (bug 838383) with the details, but maybe apport need to be fixed.

SiscoGarcia (sisco) wrote :

I was starting with a Lubuntu 11.10 beta1 on VirtualBox (3.0.0-9-generic) and I got the bug message.

Murat Uenalan (muenalan) wrote :

Apport brought me here after notification daemon crashed on oneiric ? This bug seems quite old, regression ?

Nicolas Diogo (nicolasdiogo) wrote :

just crashed on 11.10 (oneiric) amd64

yamo (stephane-gregoire) wrote :

Also crashed in lubuntu 11.10.

JohnShep (john-boxrec) wrote :

Crashed 12.04 on boot

jerrylamos (jerrylamos) wrote :

lubuntu precise pangolin Alpha1 updated to 3.2.0-12 on IBM Thinkpad T40

DISTRIB_DESCRIPTION="Ubuntu precise (development branch)"
Linux ThinkPadT40 3.2.0-12-generic #21-Ubuntu SMP Tue Jan 31 18:40:37 UTC 2012 i686 i686 i386 GNU/Linux

Crashed a bit after boot. Just had a terminal session up and wasn't doing anything.

Jerry

Upgrade from Lucid->Precise, not sure what the crash was. Otherwise, upgrade went smoothly.

Hardware: Advent G10 netbook (rebadged MSI Wind)

fatman@jizo-bosatsu:~$ uname -a
Linux jizo-bosatsu 3.2.0-18-generic-pae #28-Ubuntu SMP Fri Mar 2 22:11:12 UTC 2012 i686 i686 i386 GNU/Linux

PHil RUshik (prushik) wrote :

Happens all the time to me in Lubuntu Precise Pangolin. Notification-daemon is worthless. It worked when I first upgraded, but recent updates have broken it, not sure which ones.

karl anliot (kanliot) wrote :

crashed when waking up computer in Lubuntu

Crashes on startup on Precise LiveCD for me. Shows no notifications after restarting it under Valgrind, simply prints
"GdkPixbuf-CRITICAL **: gdk_pixbuf_scale_simple: assertion `dest_width > 0' failed
Killed" after I run "notify-send test" several times.

Valgrind log and GDB output are attached.

Please do something about this bug, notification daemon is completely screwed. Apport redirects all crash reports to this bug which is marked "won't fix".

Also, we can't reopen the bug, we don't seem to have the permissions to do it. All statuses are grayed out for commoners.

here's a more complete gdb output, with a backtrace and debugging symbols installed

raboof (arnouten) wrote :

The last few comments (#22 onwards) seem to refer to another crash entirely - that other crash was reported as bug #931820 , which (IMHO erronously) was marked as a duplicate from this one.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers