Ubuntu

[FFe] Please merge nodejs (0.6.12~dfsg1-1) from Debian unstable

Reported by František Hába on 2011-11-18
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libev (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
libv8 (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
nodejs (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

Rationale:

The version of nodejs in precise is quite old - upstream now consider 0.6.x to be the stable branch.

To support this a sync of libev and libv8 is also required.

0.6.x has been in Debian unstable since January; this merge will require syncs of libev and libv8 as well.

Build test:
libev:
  https://launchpad.net/~james-page/+archive/junk/+build/3322489
  https://launchpad.net/~james-page/+archive/junk/+build/3322490
libv8:
  https://launchpad.net/~james-page/+archive/junk/+build/3322502
  https://launchpad.net/~james-page/+archive/junk/+build/3322503
nodejs:
  https://launchpad.net/~james-page/+archive/junk/+build/3370083
  https://launchpad.net/~james-page/+archive/junk/+build/3370082

Note that amd64 build in PPA still pending - see attached log for local sbuild results.

Install test:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  libv8-3.6.6.14
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/665 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 435542 files and directories currently installed.)
Preparing to replace nodejs 0.6.12~dfsg1-1ubuntu1 (using .../nodejs_0.6.12~dfsg1-1ubuntu1_amd64.deb) ...
Unpacking replacement nodejs ...
Processing triggers for doc-base ...
Processing 1 changed doc-base file...
Registering documents with scrollkeeper...
Processing triggers for man-db ...
Setting up nodejs (0.6.12~dfsg1-1ubuntu1) ...

Testing:
Spun up the latest trunk version of etherpad-lite which works on this version of nodejs - did a basic functionality check - all worked OK.
https://github.com/Pita/etherpad-lite

Upstream changelogs:
libev - http://anonscm.debian.org/gitweb/?p=collab-maint/libev.git;a=blob;f=Changes;h=c66450315a2f97186886ecc15a1cf082dff4c74e;hb=f91d260a339c62a3a54a7e66b07a23dbe6d4d34b
libv8 - http://anonscm.debian.org/gitweb/?p=collab-maint/libv8.git;a=blob;f=ChangeLog;h=4d629810ba3572ff0ced1872d4ab314565fa5ab3;hb=8775c083eec3e0654b00075bacd0642db7ba2d6c
nodejs - http://anonscm.debian.org/gitweb/?p=collab-maint/nodejs.git;a=blob;f=ChangeLog;h=7bb9808d461e0caa5ac600510df89214d7d94503;hb=62cb793d6f208b67d1d3dbf8df832612b4db876f

Impact:
nodejs itself has no dependencies within the precise archive
libv8 is only used by nodejs
libev is used by a few other packages - although the new upstream release is a minor version upgrade it does include one incompatible change:
  INCOMPATIBLE CHANGE: ev_timer_again now clears the pending status, as
  was documented already, but not implemented in the repeating case

This change aligns the code to the documentation so should not cause issues - its not an ABI change.

Original Bug Report:
--------------------
Please, update Node.js package to the latest version (0.6.1).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nodejs (Ubuntu):
status: New → Confirmed
František Hába (w-hello-h) wrote :

Any news? Node.js v0.6.4 is out.

Wichert Akkerman (wichert) wrote :

Node.js 0.6.8 is out by now...

Wichert Akkerman (wichert) wrote :

Version 0.6.8 was just uploaded to Debian, so it should be easy to import into Ubuntu.

kapouer (kapouer) wrote :

Note to ubuntu maintainers : please wait until nodejs 0.6.8 is uploaded to debian/sid, right now it's in experimental.
In particular, we expect a fixed libev4, see http://bugs.debian.org/657080

James Page (james-page) wrote :

nodejs 0.6.8 is now in Debian unstable

To update in Ubuntu will also require a sync of libev and libv8 from unstable as well.

James Page (james-page) on 2012-03-30
summary: - Update Node.js to the latest version (v0.6.1)
+ [FFe] Please merge nodejs (0.6.12~dfsg1-1)from Debian unstable
James Page (james-page) on 2012-03-30
description: updated
Changed in nodejs (Ubuntu):
importance: Undecided → Medium
Changed in libv8 (Ubuntu):
importance: Undecided → Medium
Changed in libev (Ubuntu):
importance: Undecided → Medium
James Page (james-page) on 2012-03-30
description: updated
description: updated
James Page (james-page) on 2012-03-30
description: updated
summary: - [FFe] Please merge nodejs (0.6.12~dfsg1-1)from Debian unstable
+ [FFe] Please merge nodejs (0.6.12~dfsg1-1) from Debian unstable
James Page (james-page) on 2012-03-30
description: updated
James Page (james-page) on 2012-03-30
description: updated
James Page (james-page) wrote :
James Page (james-page) on 2012-03-30
description: updated
Iain Lane (laney) wrote :

What testing have you done? libv8 looks OK but have you checked that the incompatible change in libev wasn't being relied on anywhere?

Changed in nodejs (Ubuntu Precise):
status: Confirmed → New
James Page (james-page) wrote :

The following reverse-depends of libev4 use the function (ev_timer_again) which has the behavioural change:

awesome
dvbstreamer

Looking at the codebase for these two projects they do not make use of the ev_timer pending status indicator so I don't believe they will be impacted by this change.

I have not tested these two packages (or any of the other reverse-depends of libev4):

i3-wm
lwt
multiwatch
obus
ocsigen
stud

Iain Lane (laney) wrote :

If you give at least those two packages a quick smoke test when built against the new libev4 (try to exercise the affected code path if you can) and can confirm that you've done a bit of testing of nodejs iteself then I'll approve thie FFe.

Thanks for your work :-).

kapouer (kapouer) wrote :

FYI nodejs 0.6.14 / libv8 3.8 are coming (so it's worth waiting a few days).

James Page (james-page) wrote :

@Iain

I've installed and tested awesome - an interesting window manager - LGTM from a functional perspective.

However dvbstreamer I can install but I can't test - it requires a Digital Video Broadcast adapter to be installed (it streams DVB to files) and I don't have one handy so I can't test this effectively.

I'm pretty happy with nodejs - I tested it with etherpad-lite and it worked a treat.

@kapouer

I'd like to get the most up-to-date versions of both nodejs and libv8 into precise but we are getting pretty close to Final Freeze!

Iain Lane (laney) wrote :

FFes approved. I suggest you upload these versions and then we can look again at the newer releases if they pan out.

Changed in libev (Ubuntu Precise):
status: New → Triaged
Changed in libv8 (Ubuntu Precise):
status: New → Triaged
Changed in nodejs (Ubuntu Precise):
status: New → Triaged
James Page (james-page) wrote :

This bug was fixed in the package libv8 - 3.7.12.22-3

---------------
libv8 (3.7.12.22-3) unstable; urgency=low

  * Fix mipsel build, allow test debug-step-3 to fail (non-crucial)

 -- Jérémy Lal <email address hidden> Mon, 20 Feb 2012 14:08:17 +0100

libv8 (3.7.12.22-2) unstable; urgency=low

  * Adjust tests timeout from 120 to 180 seconds because build server
    can be busy sometimes.
  * Fix failing "make check" for mips arch in:
    + debian/patches/0015_enable_mips_tests.patch

 -- Jérémy Lal <email address hidden> Sun, 19 Feb 2012 18:18:57 +0100

libv8 (3.7.12.22-1) unstable; urgency=low

  * New upstream release.

  [ Jérémy Lal ]
  * Enable mipsel arch.
  * Refresh patches. Remove unnecessary patches:
    + 0010_fix_arm_bug.patch (applied upstream).
    + 0012_make_check_testsuites.patch (uses TESTFLAGS, not TESTSUITES).
    + 0013_enable_soname.patch (applied upstream).
    + 0015_hash-collision-fix-v8-3.6.patch (applied upstream.
  * Fix tabs and whitespaces in debian/samples.gyp.
  * Stop setting v8_can_use_unaligned_accesses=false during build: works
    without it - and it even may be triggering an alignment bug.

  [ Jonas Smedegaard ]
  * Update copyright file:
    + Extend (and shorten) some copyright years.
    + Fix paths of a few files.
    + Rewrap comments at 72 chars.

 -- Jonas Smedegaard <email address hidden> Mon, 13 Feb 2012 20:18:39 +0100

Changed in libv8 (Ubuntu):
status: Triaged → Fix Released
James Page (james-page) wrote :

This bug was fixed in the package libev - 1:4.11-1

---------------
libev (1:4.11-1) unstable; urgency=low

  * New upstream release. (Closes: #657080)
  * Taking over package maintenance. Adding DM-Upload-Allowed: yes.
  * Bump Standards-Version to 3.9.2
  * Removed patch applied to master branch, applied upstream. (Closes: #643186)
  * debian/rules: remove unneeded overrides :
    + Makefile has a rule for ev.3: ev.pod and calls pod2man when needed.
    + Use dh-autoreconf
  * debian/control: add Vcs-* fields, move git repository to collab-maint.
  * debian/copyright: convert to DEP-5 format.

 -- Jérémy Lal <email address hidden> Sat, 11 Feb 2012 02:00:25 +0100

Changed in libev (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package nodejs - 0.6.12~dfsg1-1ubuntu1

---------------
nodejs (0.6.12~dfsg1-1ubuntu1) precise; urgency=low

  * Merge from Debian unstable (LP: #892034), remaining changes:
    - This package is x86/arm only. Update control to match
    - d/patches/2009_increase_test_timeout.patch: Increased default test
      timeout from 60 to 120 seconds to support reliable execution of all
      tests on armhf/armel architectures.
    - d/patches/2005_expected_failing_tests.patch:
      - Allow racey tests to fail: test-cluster-kill-workers,
        test-child-process-fork2
      - Allow test-fs-watch to fail as LP buildd's don't support
        inotify.
      - Revert all other Ubuntu changes as no longer required.

nodejs (0.6.12~dfsg1-1) unstable; urgency=low

  * Update Standards-Version to 3.9.3.
  * Patch wscript to enable build on mipsel arch, libv8 being available.
    Upstream does not support that arch, failure expected.
  * test-cluster-kill-workers is expected to fail on armhf,
    Bug#660802 will be closed when test pass.
  * test-buffer is expected to fail on armel,
    Bug#660800 will be closed when test pass.
  * Add epoch to dependency on libev >= 1:4.11. Closes: bug#658441.
  * Remove tools/doc because node-doc-generator has no license for now.
  * Add copyright for doc/sh* files (shjs).
  * source.lintian-overrides : source-contains-waf-binary tools/node-waf
    it is simply not the case here.

nodejs (0.6.11~dfsg1-2) unstable; urgency=low

  * test-stream-pipe-multi expected to timeout sometimes on busy builds.

nodejs (0.6.11~dfsg1-1) unstable; urgency=low

  * New upstream release.
  * Remove upstream patches.
  * test-dgram-pingpong expected to timeout, the test itself is buggy.
  * test-buffer expected to fail on armel, allow building package to make
    it easier to find the cause of the failure.
    Closes: bug#639636.

nodejs (0.6.10~dfsg2-2) unstable; urgency=low

  [ Jérémy Lal ]
  * Expect tests dgram-multicast and broadcast to fail.
    debian/patches/2005_expected_failing_tests.patch

  [ Jonas Smedegaard ]
  * Drop dpkg-source local-options: Defaults since dpkg-source 1.16.1.

nodejs (0.6.10~dfsg2-1) unstable; urgency=low

  * New upstream release.
  * Depend on libev-dev 4.11, see bug#657080.
  * Bump dependency on openssl to 1.0.0g.
  * Remove useless uv_loop_refcount from libuv,
    refreshed 2009_fix_shared_ev.patch.
  * Apply to upstream patches landed after 0.6.10 release,
    to fix debugger repl and http client.

nodejs (0.6.8~dfsg1-1) experimental; urgency=low

  * New upstream release. Closes:bug#650661
  * Repackage to remove non-dfsg font files ./deps/npm/html/*/*.ttf
  * Remove unneeded bundled dependencies: lighter tarball,
    debian/copyright is easier to maintain.
  * Drop unneeded build-dependency on scons.
  * Depend on zlib1g, libc-ares, libev.
    Patches done to support building with those shared libs.
  * Fix DEB_UPSTREAM_URL in debian/rules, and debian/watch.
  * nodejs.pc file for pkgconfig is no more available.
  * Build-depend on procps package, a test is using /bin/ps.
  * Refreshed debian/patches/2005_expected_failing_tests.patch,
    only for tests that need networki...

Read more...

Changed in nodejs (Ubuntu Precise):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.