Installing "node" (audio application) removes nodejs

Bug #1030421 reported by Hai Phaikawl
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
node (Ubuntu)
Undecided
Unassigned
nodejs (Debian)
Fix Released
Unknown
nodejs (Ubuntu)
Undecided
Unassigned

Bug Description

The "node" package is Amateur Packet Radio Node program, as described on http://packages.ubuntu.com/precise/node.
As I could see, it isn't related in any ways to node.js (the nodejs package).
But installing "node" via apt-get just removes nodejs and all related things for no reason o_o.
Bug?

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: node (not installed)
ProcVersionSignature: Ubuntu 3.2.0-27.43-generic 3.2.21
Uname: Linux 3.2.0-27-generic i686
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Sun Jul 29 08:54:41 2012
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm-256color
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: node
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in node (Ubuntu):
status: New → Confirmed
Revision history for this message
Logan Rosen (logan) wrote :

There is a debate going on upstream about how to handle this conflict, as node.js and node share the same binary name, which is why they are conflicting. I have added a watch for the Debian bug.

Changed in node (Ubuntu):
status: Confirmed → Invalid
Changed in nodejs (Ubuntu):
status: New → Confirmed
Changed in nodejs (Debian):
status: Unknown → Fix Released
Logan Rosen (logan)
Changed in nodejs (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.