module 'time' has no attribute 'clock'

Bug #1877433 reported by Rūdolfs Mazurs on 2020-05-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nml (Debian)
Fix Released
Unknown
nml (Ubuntu)
Undecided
Unassigned

Bug Description

Module calls function "clock" which has been deprecated and removed from python3.

Example of error message:

nmlc ERROR: nmlc: An internal error has occurred:
nmlc-version: 0.4.5
Error: (AttributeError) "module 'time' has no attribute 'clock'".
Command: ['/usr/bin/nmlc', "<<<sensitive and irrelevant info>>>"]
Location: File "/usr/lib/python3/dist-packages/nml/generic.py", line 332, in print_progress

Similar error in the same file, line 327.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: nml 0.4.5-2 [modified: usr/lib/python3/dist-packages/nml/generic.py]
ProcVersionSignature: Ubuntu 5.4.0-29.33-generic 5.4.30
Uname: Linux 5.4.0-29-generic x86_64
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: GNOME
Date: Thu May 7 21:14:08 2020
InstallationDate: Installed on 2020-03-20 (48 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=lv_LV.UTF-8
 SHELL=/bin/bash
SourcePackage: nml
UpgradeStatus: Upgraded to focal on 2020-04-02 (35 days ago)

Hans Joachim Desserud (hjd) wrote :

Thanks for reporting.

Marking confirmed based on the corresponding Debian bug report.

Changed in nml (Ubuntu):
status: New → Confirmed
Changed in nml (Debian):
status: Unknown → New
Changed in nml (Debian):
status: New → Fix Released

This is fixed in version (0.5.1-1), which is included in the Groovy 20.10 release. Only Focal 20.04 is still affected, since earlier versions had older versions of Python that did not remove the deprecated module yet.

Considering this bug completely prevents this package from working and 20.04 is an LTS, it might make sense to backport this fix. However, since this package is primarily a build-dep for other packages (not used by itself so much) and since there is no backported patch ready to cherry-pick from Debian (In Debian I just updated to a new upstream version), this would need to be cherry-picked from upstream, so I won't be investing the time for that, I think.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.