nmap only recognizes IPv6 resolvers by specifying "--system-dns"

Bug #727114 reported by dnmvisser on 2011-03-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nmap (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: nmap

I recently configured our 10.04 LTS systems to use only IPv6 resolvers:

root@cajones:~# cat /etc/resolv.conf
nameserver 2001:610:148:dead::4
nameserver 2001:610:158:98d::42
domain terena.org

nmap complains since:

root@cajones:~# nmap -sP putin.terena.org

Starting Nmap 5.00 ( http://nmap.org ) at 2011-03-01 12:43 CET
mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
Host 192.87.38.10 is up (0.00032s latency).
Nmap done: 1 IP address (1 host up) scanned in 0.32 seconds

If I use --system-dns no complaints:

root@cajones:~# nmap --system-dns -sP putin.terena.org

Starting Nmap 5.00 ( http://nmap.org ) at 2011-03-01 12:43 CET
Host putin.terena.org (192.87.38.10) is up (0.00025s latency).
Nmap done: 1 IP address (1 host up) scanned in 0.37 seconds

Manually specifying the resolvers however does not seem to work either:

root@cajones:~# nmap --dns-servers 2001:610:148:dead::4,2001:610:158:98d::42 -sP putin.terena.org

Starting Nmap 5.00 ( http://nmap.org ) at 2011-03-01 12:46 CET
mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
Host 192.87.38.10 is up (0.00028s latency).
Nmap done: 1 IP address (1 host up) scanned in 0.36 seconds

Andres Rodriguez (andreserl) wrote :

Hi there,

Thank you for reporting bugs and trying to make Ubuntu better.

The manpage in the --system-dns section mentions the following:

"--system-dns (Use system DNS resolver) .
[........................................................] The system
           resolver is always used for IPv6 scans."

Please, correct me if I'm wrong but this leads me to believe that in fact, when using IPv6 resolvers the "--system-dns" parameter should be specified. I'm marking this bug report as incomplete for now. If you have further information or you believe that this is not the case, please provide further information to help us determine the issue more in depth.

Please also note that when doing IPv6 scanning you should use the "-6" parameter. see [1] and the manpage for more information.

[1]: http://nmap.org/book/man-misc-options.html

Changed in nmap (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for nmap (Ubuntu) because there has been no activity for 60 days.]

Changed in nmap (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers