nitrogen crashes on startup

Bug #386786 reported by paledread on 2009-06-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nitrogen (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: nitrogen

Just installed nitrogen on Ubuntu Jaunty running openbox-session as window manager.

When I start nitrogen from the command line I get

>> nitrogen /home/media/icons\:wallpaper\:screen\:grafix/wallpaper/

(nitrogen:12540): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.

(nitrogen:12540): atk-bridge-WARNING **: IOR not set.

(nitrogen:12540): atk-bridge-WARNING **: Could not locate registry

GThread-ERROR **: GThread system may only be initialized once.
aborting...
Aborted

Odd really because its seems to run ok on another box with an almost identical set up.

paledread (chris-dunnz) wrote :

In fact this seems even stranger.

I've rebooted since reporting the bug, so this is out of the equation.

Still seeing the failure to start, but another user on the same box running very similar apps can run nitrogen without any problem.

??????

paledread (chris-dunnz) wrote :

Having spent many hours on this I've found that the problem is not with Nitrogen, so please terminate this bug report.

The difficulty seems to result from some malfunction with gnome-settings-daemon and gnome-terminal in my openbox autostart files. Whatever I do I cannot consistently get g-s-d and gnome-terminal to run from the openbox autostart files.

In view of the inconsistency, it is very difficult to file a g-s-d and/or gnome-terminal bug report, but if anyone is interested I'd be happy to run tests to try and overcome the problem. A pity really, because I was quite attached to gnome-terminal.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers