[regression] systemd-logind crashed with SIGABRT in __libc_connect() from __GI_clnttcp_create() from __GI___libc_rpc_getport() from __GI_pmap_getport() from __GI_clnttcp_create()

Bug #1745664 reported by joe mammino on 2018-01-26
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
nis (Ubuntu)
Medium
Unassigned
systemd (Ubuntu)
Medium
Unassigned

Bug Description

https://errors.ubuntu.com/problem/54968dedd418de647365aa3f0127906ca9adbfe3

---

configured system to use nis. seems to be crashing when I attempt to use a NIS user account

ProblemType: Crash
DistroRelease: Ubuntu 18.04
Package: systemd 235-3ubuntu3
ProcVersionSignature: Ubuntu 4.13.0-25.29-generic 4.13.13
Uname: Linux 4.13.0-25-generic x86_64
ApportVersion: 2.20.8-0ubuntu6
Architecture: amd64
Date: Fri Jan 26 13:45:06 2018
ExecutablePath: /lib/systemd/systemd-logind
InstallationDate: Installed on 2018-01-26 (0 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180126)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 04b3:3025 IBM Corp. NetVista Full Width Keyboard
 Bus 001 Device 002: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Gigabyte Technology Co., Ltd. Z370 HD3
ProcCmdline: /lib/systemd/systemd-logind
ProcEnviron:
 LANG=en_US.UTF-8
 PATH=(custom, no user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-25-generic root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
Signal: 6
SourcePackage: systemd
StacktraceTop:
 __libc_connect (fd=39, addr=addr@entry=..., len=len@entry=16) at ../sysdeps/unix/sysv/linux/connect.c:26
 __GI_clnttcp_create (raddr=raddr@entry=0x7ffc27302060, prog=prog@entry=100000, vers=vers@entry=2, sockp=sockp@entry=0x7ffc27301efc, sendsz=sendsz@entry=400, recvsz=recvsz@entry=400) at clnt_tcp.c:153
 __GI___libc_rpc_getport (tottimeout_sec=60, timeout_sec=5, protocol=6, version=2, program=100007, address=0x7ffc27302060) at pm_getport.c:106
 __GI_pmap_getport (address=address@entry=0x7ffc27302060, program=program@entry=100007, version=version@entry=2, protocol=protocol@entry=6) at pm_getport.c:154
 __GI_clnttcp_create (raddr=raddr@entry=0x7ffc27302060, prog=prog@entry=100007, vers=vers@entry=2, sockp=sockp@entry=0x7ffc27302050, sendsz=sendsz@entry=0, recvsz=recvsz@entry=0) at clnt_tcp.c:136
SystemdDelta:
 [EXTENDED] /lib/systemd/system/rc-local.service → /lib/systemd/system/rc-local.service.d/debian.conf
 [EXTENDED] /lib/systemd/system/user@.service → /lib/systemd/system/user@.service.d/timeout.conf

 2 overridden configuration files found.
Title: systemd-logind crashed with SIGABRT in __libc_connect()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: Software adm bin daemon lp mail nuucp root scswebadmin sys sysdesign tty uucp
dmi.bios.date: 09/22/2017
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: F4
dmi.board.asset.tag: Default string
dmi.board.name: Z370 HD3-CF
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: Default string
dmi.chassis.version: Default string
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrF4:bd09/22/2017:svnGigabyteTechnologyCo.,Ltd.:pnZ370HD3:pvrDefaultstring:rvnGigabyteTechnologyCo.,Ltd.:rnZ370HD3-CF:rvrx.x:cvnDefaultstring:ct3:cvrDefaultstring:
dmi.product.family: Default string
dmi.product.name: Z370 HD3
dmi.product.version: Default string
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Revision history for this message
joe mammino (joseph-mammino) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 __libc_connect (fd=39, addr=addr@entry=..., len=len@entry=16) at ../sysdeps/unix/sysv/linux/connect.c:26
 __GI_clnttcp_create (raddr=raddr@entry=0x7ffc27302060, prog=prog@entry=100000, vers=vers@entry=2, sockp=sockp@entry=0x7ffc27301efc, sendsz=sendsz@entry=400, recvsz=recvsz@entry=400) at clnt_tcp.c:153
 __GI___libc_rpc_getport (tottimeout_sec=60, timeout_sec=5, protocol=6, version=2, program=100007, address=0x7ffc27302060) at pm_getport.c:106
 __GI_pmap_getport (address=address@entry=0x7ffc27302060, program=program@entry=100007, version=version@entry=2, protocol=protocol@entry=6) at pm_getport.c:154
 __GI_clnttcp_create (raddr=raddr@entry=0x7ffc27302060, prog=prog@entry=100007, vers=vers@entry=2, sockp=sockp@entry=0x7ffc27302050, sendsz=sendsz@entry=0, recvsz=recvsz@entry=0) at clnt_tcp.c:136

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in systemd (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
Revision history for this message
Launchpad Janitor (janitor) wrote : Re: systemd-logind crashed with SIGABRT in __libc_connect()

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed
Revision history for this message
Jonathan (jjcf89) wrote :

I am getting this crash report pretty consistently. A lot of my problems have been clumped under this bug https://bugs.launchpad.net/ubuntu/+source/gdm3/+bug/1770238?comments=all as it was the first one I ran into.

I am running an i7-7820X on a msi x299 sli plus motherboard with a nvidia gtx 1050 card.

So far this occurs without much warning. Usually my system will lock up and reboot on its own. Then the following boot, I will be using various applications and the desktop will go away and I'll be returned to the login screen. Then the ubuntu bug report will report this crash and an xorg crash. Sometimes these crashes happen soon after first boot and sometimes after I've been using the computer most of the day.

This morning I booted the computer, launched firefox and chrome and a couple minutes later computer rebooted and after logging in again gui crashed similar to my description above.

I do have nis setup but my main login is a sort of mixed nis login. My user account was created on my local machine to match the uuid of my server account so I'm technically logging in locally. Not sure how much nis is activating. Is there a way to tell?

Error reports:

systemd:
https://errors.ubuntu.com/oops/9a5971bc-5869-11e8-ac5b-fa163e30221b
https://errors.ubuntu.com/oops/22fde306-594e-11e8-9113-fa163e171d9b
https://errors.ubuntu.com/oops/d9d2bcf0-5ae3-11e8-b7bb-fa163ed44aae
https://errors.ubuntu.com/oops/ca27a03c-5cf9-11e8-89fe-fa163e192766

xserver-xorg-core
https://errors.ubuntu.com/oops/ace611be-5869-11e8-9c14-fa163ef911dc
https://errors.ubuntu.com/oops/43232196-594e-11e8-bc40-fa163e839e11
https://errors.ubuntu.com/oops/df54164c-5ae3-11e8-bb2e-fa163e839e11
https://errors.ubuntu.com/oops/19aa1018-5cfa-11e8-9065-fa163e839e11

Revision history for this message
Jonathan (jjcf89) wrote :

A second one of our systems is having the __libc_connect crashes.

AMD Ryzen 7 1800X
Nvida GT 710

Revision history for this message
Jonathan (jjcf89) wrote :

Neither of my systems crash when logging into a nis account.

Revision history for this message
Daniel van Vugt (vanvugt) wrote : Re: systemd-logind crashed with SIGABRT in __libc_connect() from __GI_clnttcp_create() from __GI___libc_rpc_getport() from __GI_pmap_getport() from __GI_clnttcp_create()
summary: - systemd-logind crashed with SIGABRT in __libc_connect()
+ systemd-logind crashed with SIGABRT in __libc_connect() from
+ __GI_clnttcp_create() from __GI___libc_rpc_getport() from
+ __GI_pmap_getport() from __GI_clnttcp_create()
description: updated
Revision history for this message
Jonathan (jjcf89) wrote :

My computer continues to crash on a daily basis. It locks up and reboots. And this error report pops up. I've no idea how to track this down.

I tried enabling kdump-tools but couldn't get it to work. System would not reboot into kdump kernel when I manually triggered the test crash.

Revision history for this message
Jonathan (jjcf89) wrote :

Installed ubuntu 17.10 and so far no crashes (almost a week). Really wish someone would help determine whats going wrong in 18.04.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

The error report (comment #10) confirms this crash only occurs in Ubuntu 18.04. However it's also not that common (only 137 reports globally). It's pretty unlucky if this is blocking you :(

summary: - systemd-logind crashed with SIGABRT in __libc_connect() from
- __GI_clnttcp_create() from __GI___libc_rpc_getport() from
+ [regression] systemd-logind crashed with SIGABRT in __libc_connect()
+ from __GI_clnttcp_create() from __GI___libc_rpc_getport() from
__GI_pmap_getport() from __GI_clnttcp_create()
tags: added: regression-release
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

All,

If this bug is affecting you, please help to get it fixed by reporting it to the systemd developers here:

  https://github.com/systemd/systemd/issues

When done, please tell us the ID of the new issue.

Revision history for this message
Jonathan (jjcf89) wrote :

Daniel, Thanks for the response. I'm struggling to track down this issue since it locks up my machine and no logs or errors appear to be created.

I'll see about posting on systemd github. Thanks for the link.

Revision history for this message
Jonathan (jjcf89) wrote :
Changed in systemd:
status: Unknown → Fix Released
no longer affects: systemd
Revision history for this message
joe mammino (joseph-mammino) wrote :

Daniel - please explain what was done to resolve.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Nothing was done. The comment:

  Changed in systemd:
  status: Unknown → Fix Released

is an unfortunate bug in Launchpad. It was briefly tracking:

  https://github.com/systemd/systemd/issues/9431

which is now closed so Launchpad thought that means "fixed".

If you scroll up you will find this bug is now correctly showing as not fixed.

Revision history for this message
Jonathan (jjcf89) wrote :

Joe, Could you try the recommendation posted on the github link? I'm going to try to find time to test on my system as well.

Revision history for this message
Jonathan (jjcf89) wrote :

One user on the github issue has reported that setting IPAddressDeny= for systemd-login fixed these crashes. I did the following steps and am waiting to see if the crashes stop.

$ sudo cp /lib/systemd/system/systemd-logind.service /etc/systemd/system/
$ sudo vim /etc/systemd/system/systemd-logind.service
$ diff /lib/systemd/system/systemd-logind.service /etc/systemd/system/systemd-logind.service
37c37
< IPAddressDeny=any
---
> IPAddressDeny=
$ sudo systemctl daemon-reload
$ sudo systemctl restart systemd-logind.service

Revision history for this message
joe mammino (joseph-mammino) wrote : RE: [Bug 1745664] Re: [regression] systemd-logind crashed with SIGABRT in __libc_connect() from __GI_clnttcp_create() from __GI___libc_rpc_getport() from __GI_pmap_getport() from __GI_clnttcp_create()

Sorry I did not respond earlier.

The work around resolved the bug we are seeing with NIS

Joe

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Jonathan
Sent: Friday, August 10, 2018 4:28 PM
To: Mammino, Joseph P <email address hidden>
Subject: [Bug 1745664] Re: [regression] systemd-logind crashed with SIGABRT in __libc_connect() from __GI_clnttcp_create() from __GI___libc_rpc_getport() from __GI_pmap_getport() from __GI_clnttcp_create()

One user on the github issue has reported that setting IPAddressDeny= for systemd-login fixed these crashes. I did the following steps and am waiting to see if the crashes stop.

$ sudo cp /lib/systemd/system/systemd-logind.service /etc/systemd/system/ $ sudo vim /etc/systemd/system/systemd-logind.service
$ diff /lib/systemd/system/systemd-logind.service /etc/systemd/system/systemd-logind.service
37c37
< IPAddressDeny=any
---
> IPAddressDeny=
$ sudo systemctl daemon-reload
$ sudo systemctl restart systemd-logind.service

--
You received this bug notification because you are subscribed to the bug report.
https://bugs.launchpad.net/bugs/1745664

Title:
  [regression] systemd-logind crashed with SIGABRT in __libc_connect()
  from __GI_clnttcp_create() from __GI___libc_rpc_getport() from
  __GI_pmap_getport() from __GI_clnttcp_create()

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1745664/+subscriptions

Revision history for this message
Jonathan (jjcf89) wrote :

Some one else responded that installing ncsd (nis caching service) also solved the problem.

https://github.com/systemd/systemd/issues/7074#issuecomment-338384997

Revision history for this message
Jonathan (jjcf89) wrote :

Woops nscd

Revision history for this message
Jonathan (jjcf89) wrote :

Apparently a note was added to the systemd NEWS notes, noting this incompatibility and asking distro maintainers to either override IPAddressDeny or install ncsd.

https://github.com/systemd/systemd/pull/7343

Note in this pull request someone also mentioned seeing crashes in systemd-udevd because of this same issue. It seems like installing ncsd might be the better solution as it prevents other as of yet undiscovered services from hitting this new firewall feature of theirs...

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nis (Ubuntu):
status: New → Confirmed
Revision history for this message
Jonathan (jjcf89) wrote :
affects: systemd → nis (Ubuntu)
Changed in nis (Ubuntu):
status: New → Confirmed
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

It's not that clear to me. I would prefer to keep this bug open at least. Not just because it's older but also because it's much better documented with a stack trace and link to errors.ubuntu.com.

Revision history for this message
Jonathan (jjcf89) wrote :

Agreed. I don't know if it technically qualifies as a duplicate. But I suspect its caused by the same systemd change.

Revision history for this message
Nate Metheny (sfi-nate) wrote :

Can confirm that NSCD installation eliminated lag, reference comment #22.

Revision history for this message
Robie Basak (racb) wrote :

Importance -> Medium as there is a workaround available.

Changed in nis (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Andreas Hasenack (ahasenack) wrote :
Revision history for this message
joe mammino (joseph-mammino) wrote :

In /etc/systemd/system/systemd-logind.service comment out IPAddressDeny=Any

this work around has been working for us for about a 10 months now

Revision history for this message
Jonathan (jjcf89) wrote :

Installing ncsd worked well for me as well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.