NIS cannot handle non-ascii characters in gecos field

Bug #162183 reported by Morten Kjeldgaard on 2007-11-12
2
Affects Status Importance Assigned to Milestone
glibc (Ubuntu)
Undecided
Unassigned
nis (Ubuntu)
Undecided
Unassigned

Bug Description

We are using NIS to serve the passwd file in a distributed computing environment. If a user's full name contains a non-ASCII character, for example is the name contains the acute accent, that entry is ignored by Ubuntu 7.10 machines and the user cannot login. When the full name of the user is edited to contain only ASCII characters, the login problem goes away.

We have the yp server running on a CentOS system, and do not have the same problem on CentOS clients.

Mark Brown (broonie) wrote :

What does the relevant passwd entry look like in the output of ypcat passwd? Does the entry for the user look OK?

Morten Kjeldgaard (mok0) wrote :

The entry looks fine, and works on the CentOS systems. I had to change non-ASCII letters (é, æ, ø, å etc.) in the gecos field to their ASCII equivalents to get them to work under Ubuntu (gutsy).

Mark Brown (broonie) wrote :

If you re-add non-ASCII characters does it still look fine?

Adding glibc - this looks like an issue there since it is glibc which is responsible for reading and parsing passwd entries.

Morten Kjeldgaard (mok0) wrote :

I investigated the issue once more. Unfortunately, our setup has changed, so the master NIS server is no longer on a CentOS system, but rather Ubuntu JeOS (2.6.22-14-virtual).

The good news is that the problem has gone away. The bad news is that I can't say why. I created a password entry:

ans:xxx:1221:1221:æ ø å é:/u/ans:/bin/bash

on the NIS master, and the user ans can now log in on both gutsy and hardy machines. Before, the user could not log in, and was silently rejected.

On hardy, the funny characters in the name show up correctly in applications (e.g. "finger ans"), but in a gutsy machine, they did not, each character is displayed as two, indicating some kind of unicode problem. I did not investigate this further.

Morten Kjeldgaard (mok0) wrote :

Since I cannot reproduce the problem I reported, I am satisfied that the bug has been fixed, although I can not say how or when. I hereby close the bug.

Changed in nis:
status: New → Fix Released
Morten Kjeldgaard (mok0) wrote :

closed in glibc too

Changed in glibc:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers