ufw rules not available

Bug #825349 reported by Jérémy Subtil on 2011-08-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nginx (Ubuntu)
Undecided
Unassigned

Bug Description

In Ubuntu Natty, the NginX profiles are not displayed while running `ufw app list`.

This is certainly due to the profile path, which is `/etc/ufw/applications.d/nginx/ufw.profile` instead of `/etc/ufw/applications.d/nginx`.

Tags: ufw Edit Tag help

This has been fixed in the latest commit in Debian.

Index: nginx-common.preinst
===================================================================
--- nginx-common.preinst (revision 19547)
+++ nginx-common.preinst (working copy)
@@ -11,9 +11,17 @@
     rm -f /etc/logrotate.d/nginx-common
     ;;

- upgrade|abort-upgrade)
+ upgrade)
+ # If this is an upgrade, then they might have the UFW profile in the wrong spot.
+ if [ -d /etc/ufw/applications.d/nginx ]; then
+ rm -f /etc/ufw/applications.d/nginx/ufw.profile
+ rmdir /etc/ufw/applications.d/nginx
+ fi
     ;;

+ abort-upgrade)
+ ;;
+
   *)
     echo "preinst called with unknown argument \`$1'" >&2
     exit 1
Index: changelog
===================================================================
--- changelog (revision 19547)
+++ changelog (working copy)
@@ -1,3 +1,13 @@
+nginx (1.1.8-1ubuntu1) precise; urgency=low
+
+ * debian/nginx-common.install:
+ + Changed ufw profile installation (LP: #825349)
+ - debian/ufw.profile -> debian/ufw/nginx
+ * debian/nginx-common.preinst:
+ + Cleanup of moved nginx profile.
+
+ -- Michael Lustfield <email address hidden> Tue, 15 Nov 2011 01:51:17 +0000
+
 nginx (1.1.8-1) UNRELEASED; urgency=low

   [Cyril Lavier]
Index: ufw.profile
===================================================================
--- ufw.profile (revision 19547)
+++ ufw.profile (working copy)
@@ -1,14 +0,0 @@
-[Nginx HTTP]
-title=Web Server (Nginx, HTTP)
-description=Small, but very powerful and efficient web server
-ports=80/tcp
-
-[Nginx HTTPS]
-title=Web Server (Nginx, HTTPS)
-description=Small, but very powerful and efficient web server
-ports=443/tcp
-
-[Nginx Full]
-title=Web Server (Nginx, HTTP + HTTPS)
-description=Small, but very powerful and efficient web server
-ports=80,443/tcp
Index: nginx-common.install
===================================================================
--- nginx-common.install (revision 19547)
+++ nginx-common.install (working copy)
@@ -1,3 +1,3 @@
 debian/conf/* etc/nginx
-debian/ufw.profile etc/ufw/applications.d/nginx
+debian/ufw/nginx etc/ufw/applications.d
 html/* usr/share/nginx/www/

Sending debian/changelog
Sending debian/nginx-common.install
Sending debian/nginx-common.preinst
Adding debian/ufw
Adding debian/ufw/nginx
Deleting debian/ufw.profile

If I have time, I'll see about creating a debdiff for the ubuntu guys to check out. Otherwise, you can feel free to do it. :)

Changed in nginx (Ubuntu):
status: New → Confirmed
status: Confirmed → Fix Committed

I marked this as Fix Committed since it has been committed in upstream which will sooner or later be imported into ubuntu.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nginx - 1.1.8-1

---------------
nginx (1.1.8-1) unstable; urgency=low

  [Kartik Mistry]
  * New upstream release.
  * debian/modules/chunkin-nginx-module:
    + Removed as of now, as it breaks with Perl 5.14 (Closes: #649061)

  [Michael Lustfield]
  * debian/control:
    + Added Map module to nginx-light modules list.
  * debian/rules:
    + Removed --without-http_map_module form nginx-light.
  * debian/nginx-common.install:
    + Changed ufw profile installation (LP: #825349).
      - debian/ufw.profile -> debian/ufw/nginx.
  * debian/nginx-common.preinst:
    + Cleanup of moved nginx profile.
  * debian/conf/nginx.conf:
    + Added a default map for $server_https (on|off).
  * debian/conf/fastcgi_params:
    + Pass HTTPS so $_SERVER['HTTPS'] is set (LP: #857831).
  * debian/conf/mime.types:
    + Added json type (LP: #883440).
  * debian/conf/sites-available/default:
    + Added notes about PHP (Closes: #642995).
    + Changed location /doc from root to alias.
    + Changed location /doc to /doc/ for people that don't bother reading or
      learning anything about Nginx configuration files (LP: #840358).

 -- Kartik Mistry <email address hidden> Fri, 18 Nov 2011 23:44:00 +0530

Changed in nginx (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers