FFe: Sync nginx 0.8.54-4 (universe) from Debian unstable

Bug #729691 reported by Michael Lustfield on 2011-03-05
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nginx (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: nginx

The latest release of Nginx in Debian unstable (0.8.54-4) fixes the following bugs that exist in the version that Ubuntu 11.04 currently provides (0.8.53-2).

Please consider passing this through the freeze. A few features were made but most of the changes were bug fixes.

Debian bugs:
#610946
#609343
#608983
#610289
#610290
#609797
#610983
#612832
#613175
#613355
#613851
#614987
#614980
#609254
#609134
#609411
#608633
#607418
#606094
#598461

Launchpad bugs:
#699736
#694456

Most of these were minor. However, a few cause significant usability issues.

The difference between the two versions of Nginx consist mostly of bug fixes (only only small feature).
    *) Change: now nginx uses a default listen backlog value -1 on
       Linux.
    *) Feature: the "utf8" parameter of "geoip_country" and "geoip_city"
       directives.
    *) Bugfix: in a default "proxy_redirect" directive if "proxy_pass"
       directive has no URI part.
    *) Bugfix: an "error_page" directive did not work with nonstandard
       error codes; the bug had appeared in 0.8.53.

When installing this version new or upgrading from an old version it's just basic information and no errrors. I don't have a system I can use at the moment to test it.

Also.. PPA of what is in that exact version can be viewed here: https://launchpad.net/~nginx/+archive/stable
Please ignore that the past version numbers were wrong. I spaced once and have to deal with it until -5 comes out.

On Sat, 2011-03-05 at 16:01 +0000, Launchpad Bug Tracker wrote:
> You have been subscribed to a public bug by Michael Lustfield (mtecknology):
>
> Binary package hint: nginx
>
> The latest release of Nginx in Debian unstable (0.8.54-4) fixes the
> following bugs that exist in the version that Ubuntu 11.04 currently
> provides (0.8.53-2).
>
> Please consider passing this through the freeze. A few features were
> made but most of the changes were bug fixes.
>
> Debian bugs:
> #610946
> #609343
> #608983
> #610289
> #610290
> #609797
> #610983
> #612832
> #613175
> #613355
> #613851
> #614987
> #614980
> #609254
> #609134
> #609411
> #608633
> #607418
> #606094
> #598461
>
> Launchpad bugs:What about the rdepends? Are those affected by this upgrade of nginx? Are there any risks of regressions?

If the reverse depends are not affected, then syncing 0.8.54-4 from
Debian makes perfect sense. I don't think that the rdepends are
affected but I would like to be sure of this before approving.
> #699736
> #694456
>
> Most of these were minor. However, a few cause significant usability
> issues.
>
> The difference between the two versions of Nginx consist mostly of bug fixes (only only small feature).
> *) Change: now nginx uses a default listen backlog value -1 on
> Linux.
> *) Feature: the "utf8" parameter of "geoip_country" and "geoip_city"
> directives.
> *) Bugfix: in a default "proxy_redirect" directive if "proxy_pass"
> directive has no URI part.
> *) Bugfix: an "error_page" directive did not work with nonstandard
> error codes; the bug had appeared in 0.8.53.
>
> When installing this version new or upgrading from an old version it's
> just basic information and no errrors. I don't have a system I can use
> at the moment to test it.
>
> ** Affects: nginx (Ubuntu)
> Importance: Undecided
> Status: New
>

What about the rdepends? Are those affected by this upgrade of nginx?
Are there any risks of regressions?

If the reverse depends are not affected, then syncing 0.8.54-4 from
Debian makes perfect sense. Even though I don't think that the rdepends
are affected, I still want to be sure of this before approving.

On Sat, 05 Mar 2011 19:46:59 -0000
Iulian Udrea <email address hidden> wrote:

> What about the rdepends? Are those affected by this upgrade of nginx?
> Are there any risks of regressions?
>
> If the reverse depends are not affected, then syncing 0.8.54-4 from
> Debian makes perfect sense. Even though I don't think that the rdepends
> are affected, I still want to be sure of this before approving.

As far as I can test, no rdepends are affected by the change. The parts I'm not
able to test I couldn't imagine caring about a different binary as long as it's
installed in the correct location.

OK. Looks good to me. Approved.

Changed in nginx (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
summary: - Freeze Exception Request: nginx-0.8.54-4
+ FFe: Sync nginx 0.8.54-4 (universe) from Debian unstable
Micah Gersten (micahg) wrote :

MOTU ACK, builds on amd64 and upgrades

Colin Watson (cjwatson) wrote :

[Updating] nginx (0.8.53-2 [Ubuntu] < 0.8.54-4 [Debian])
 * Trying to add nginx...
2011-03-22 10:59:00 INFO - <nginx_0.8.54-4.debian.tar.gz: downloading from http://ftp.debian.org/debian/>
2011-03-22 10:59:00 INFO - <nginx_0.8.54-4.dsc: downloading from http://ftp.debian.org/debian/>
2011-03-22 10:59:00 INFO - <nginx_0.8.54.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
I: nginx [universe] -> nginx_0.8.53-2 [universe].
I: nginx [universe] -> nginx-doc_0.8.53-2 [universe].

Changed in nginx (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments