[FFe Needed] Please update NGINX to 1.15.9 in Ubuntu Disco

Bug #1817750 reported by Thomas Ward on 2019-02-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nginx (Ubuntu)
Wishlist
Thomas Ward

Bug Description

Hello.

NGINX 1.15.9 was released today, and has a few bugfixes and one additional feature. The following is the upstream changelog for 1.15.9:

Changes with nginx 1.15.9 26 Feb 2019

    *) Feature: variables support in the "ssl_certificate" and
       "ssl_certificate_key" directives.

    *) Feature: the "poll" method is now available on Windows when using
       Windows Vista or newer.

    *) Bugfix: if the "select" method was used on Windows and an error
       occurred while establishing a backend connection, nginx waited for
       the connection establishment timeout to expire.

    *) Bugfix: the "proxy_upload_rate" and "proxy_download_rate" directives
       in the stream module worked incorrectly when proxying UDP datagrams.

Of these, the one bugfix that is not Windows related is relevant, as is the new feature with variables support in the certificate directives. Those who are proxying UDP (and there are some) will not be able to ratelimit the proxying of UDP without the bugfix, and those using dynamic wildcard hosts will now be able to use variables when defining the SSL certificates (dynamic certs) to serve.

Because of the new features, this will need an FFe for inclusion.

Thomas Ward (teward) wrote :

Builds currently running in https://launchpad.net/~teward/+archive/ubuntu/nginx-build-tests

Once builds are present, I'll run install and runtime tests.

Thomas Ward (teward) wrote :

Builds confirmed successful, and installed in a Disco container for testing.

Screenshots showing installed version attached, as well as the NGINX landing page (default site page) and the NGINX reported version as well in front of it to show it does work out of the box with a standard static page.

Thomas Ward (teward) wrote :
summary: - Please update NGINX to 1.15.9 in Ubuntu Disco
+ [FFe Needed] Please update NGINX to 1.15.9 in Ubuntu Disco
Steve Langasek (vorlon) wrote :

FFe granted.

Changed in nginx (Ubuntu):
status: New → Triaged
Thomas Ward (teward) wrote :

Package has been uploaded to the repositories and is building now.

Changed in nginx (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nginx - 1.15.9-0ubuntu1

---------------
nginx (1.15.9-0ubuntu1) disco; urgency=medium

  * New upstream release (1.15.9) - full changelog available from
    http://nginx.org/en/CHANGES (LP: #1817750)
  * Remaining Ubuntu-specific changes:
    - debian/patches/ubuntu-branding.patch: add Ubuntu branding (refreshed)
    - d/{control,rules,nginx-core.*}: add new binary package for main,
      nginx-core, which contains only source-tarball-included modules
      and no third-party modules.
    - debian/tests/control: add nginx-core test.
    - debian/apport/source_nginx.py: Add apport hooks for additional bug
      information gathering.
    - debian/nginx-common.install: Add install rule for apport hooks.
    - d/nginx-{core,light,full,extras}.postinst: Add checks for whether
      port 80 is in use or not to determine whether or not to attempt
      starting of the NGINX service during install/upgrade
    - d/control: Add dependencies to nginx-{core,light,full,extras} on
      `iproute2` as the postinst scripts now use `ss` to determine if
      Port 80 is open or not.
    - d/rules: Enable --with-compat build option for all nginx package
      flavors

 -- Thomas Ward <email address hidden> Tue, 26 Feb 2019 11:15:07 -0500

Changed in nginx (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers