package nginx-core (not installed) failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1747825 reported by Manoj Kashyap on 2018-02-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nginx (Ubuntu)
Undecided
Unassigned

Bug Description

Please help to solve the issue

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: nginx-core (not installed)
ProcVersionSignature: Ubuntu 4.13.0-32.35~16.04.1-generic 4.13.13
Uname: Linux 4.13.0-32-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
Date: Tue Feb 6 11:44:58 2018
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2018-01-22 (15 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.3
 apt 1.2.24
SourcePackage: nginx
Title: package nginx-core (not installed) failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Manoj Kashyap (manojrkashyap) wrote :
tags: removed: need-duplicate-check
Joshua Powers (powersj) wrote :

From terminal log:

Feb 06 11:44:57 kashyap nginx[15033]: nginx: [emerg] bind() to [::]:80 fail...e)
Feb 06 11:44:57 kashyap nginx[15033]: nginx: [emerg] bind() to 0.0.0.0:80 f...e)
Feb 06 11:44:57 kashyap nginx[15033]: nginx: [emerg] bind() to [::]:80 fail...e)
Feb 06 11:44:58 kashyap nginx[15033]: nginx: [emerg] bind() to 0.0.0.0:80 f...e)
Feb 06 11:44:58 kashyap nginx[15033]: nginx: [emerg] bind() to [::]:80 fail...e)
Feb 06 11:44:58 kashyap nginx[15033]: nginx: [emerg] still could not bind()
Feb 06 11:44:58 kashyap systemd[1]: nginx.service: Control process exited, ...=1
Feb 06 11:44:58 kashyap systemd[1]: Failed to start A high performance web ...r.
Feb 06 11:44:58 kashyap systemd[1]: nginx.service: Unit entered failed state.
Feb 06 11:44:58 kashyap systemd[1]: nginx.service: Failed with result 'exit...'.

Joshua Powers (powersj) wrote :

Thank you for taking the time to file a bug report.

The attached logs indicate that nginx is not able to bind to the IP and port
specified by your configuration files. Usually, this is due to some other
piece of software on your system already being bound to the port, which makes
this a local system issue, and not a bug in the package.

Since this is most likely the case, I am marking this bug as 'Invalid'.

However, if you believe that this is really a bug in Ubuntu, then we would
be grateful if you would provide a more complete description of the problem
with steps to reproduce, explaining why you believe this is a bug in Ubuntu
rather than a problem specific to your system. Depending on the information
provided, the status will either be set to "Confirmed" if we can reproduce
the issue reported, or we will leave the status as "Invalid" and explain why
this is the case.

For local system issues, you can find assistance here:
http://www.ubuntu.com/support/community

Changed in nginx (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers