Please merge nginx 1.10.1-1 (main) from Debian Unstable (main)

Bug #1580252 reported by Thomas Ward on 2016-05-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nginx (Ubuntu)
Wishlist
Thomas Ward

Bug Description

NGINX 1.10.0 in Debian has multiple packaging changes, including introduction of dh_nginx for the nginx-specific builds (not yet in its own packaging) and Dynamic Module introduction.

NGINX 1.10.1 in both Debian and Ubuntu include a security fix. NGINX 1.10.0 packaging changes are being merged here, though.

------

The dynamic modules in NGINX are not complete, therefore some are dynamic and some are not. This introduces a sort of 'hybrid' between static-compiled modules and dynamic-compiled-and-included modules; this 'hybrid' requires the various NGINX flavors to still be compiled with most of the static compiled modules compiled in, but introduces some support for some of the more dynamically-included modules as well.

Some third-party modules are converted to Dynamic, but not all; Lua module is one such module.

------

This is a messy merge - neither Merge-O-Matic, nor rbasak's git merge workflow have produced usable builds, so it may be a case of 'starting over' with a Debian package, and applying the nginx delta we have now manually. Once that is completed, future merges should not be anywhere near as painful or messy.

------

This will eventually be tested after everything related to this is figured out.

------

NOTES:

These packages continue to exist, and have not been removed (they also need no changes to sections, to my knowledge):
Package (Main): nginx
* Package (Main): nginx-doc
* Package (Main): nginx-common
* Package (Main): nginx-core
* Package (Main): nginx-core-dbg
* Package (Universe): nginx-full
* Package (Universe): nginx-full-dbg
* Package (Universe): nginx-light
* Package (Universe): nginx-light-dbg
* Package (Universe): nginx-extras
* Package (Universe): nginx-extras-dbg

These packages are brand new, and some need to be in Main, while others need to be in Universe:
* Package (Main, new nginx-core dependency): libnginx-mod-http-geoip
* Package (Main, new nginx-core dependency): libnginx-mod-http-image-filter
* Package (Main, new nginx-core dependency): libnginx-mod-http-xslt-filter
* Package (Main, new nginx-core dependency): libnginx-mod-mail
* Package (Main, new nginx-core dependency): libnginx-mod-stream
* Package (Universe): libnginx-mod-http-perl
* Package (Universe): libnginx-mod-http-auth-pam
* Package (Universe): libnginx-mod-http-lua
* Package (Universe): libnginx-mod-http-ndk

Thomas Ward (teward) wrote :

Preliminary debdiff, for the difference between 1.10.0-0ubuntu1 (Ubuntu) and 1.10.0-1ubuntu1 (merge from Debian), version 1 of the debdiff, for this merge.

This is not going to be uploaded to the repositories without additional spot-checks.

Thomas Ward (teward) wrote :

Preliminary Debdiff (v2) for NGINX, version 1.10.0-0ubuntu1 to 1.10.1-1ubuntu1. Forgot to include this bug number in here.

tags: added: patch
Thomas Ward (teward) wrote :

Version 3 of the preliminary debdiff. This time, I forgot to update the dependencies of the various binary packages (that is, the Conflicts lines of nginx-{core,light,full,extras} and nginx-{core,light,full,extras}-dbg).

Also added nginx-core to 'nginx' metapackage.

description: updated
Thomas Ward (teward) wrote :

Version 4 of debdiff. Thanks to Seth Arnold for helping me catch I forgot to link back to this bug in the changelog.

Thomas Ward (teward) wrote :

Preliminary Debdiff v5. This is undergoing testing now.

Commas are important, for the parsing of dependencies. They were missing for nginx-core being added, which triggered fail-to-build issues. That's been resolved, and packages 'build' now without issue.

Thomas Ward (teward) wrote :

Work on this merge is temporarily blocked, details to come at a later time.

Thomas Ward (teward) wrote :

The preliminary debdiff is now obsolete, thanks to the nginx 1.10.1 update which came out for security purposes, and will need redone with those changes in mind.

Changed in nginx (Ubuntu):
status: In Progress → Triaged
Thomas Ward (teward) wrote :

This merge is on hold - important fixes will be cherrypicked, but Debain is not confident in the dynamic modules support ("It's still experimental" on recent bugs) so it is not going to be merged at this time.

Thomas Ward (teward) wrote :

This merge has been superseded by other items.

Changed in nginx (Ubuntu):
status: Triaged → Won't Fix
Thomas Ward (teward) on 2016-07-19
Changed in nginx (Ubuntu):
status: Won't Fix → In Progress
Thomas Ward (teward) wrote :

I've reopened this - this is a prerequisite for another issue.

Thomas Ward (teward) wrote :

Preliminary Debdiff comparing Ubuntu Yakkety current to the Merge, Round 2, Version 1.

Thomas Ward (teward) wrote :

Debdiff for NGINX, version 1.10.1-1 in Debian to 1.10.1-1ubuntu1 (Round 2, Version 1)

summary: - Please merge nginx 1.10.0-1 (main) from Debian Unstable (main)
+ Please merge nginx 1.10.1-1 (main) from Debian Unstable (main)
description: updated
Thomas Ward (teward) wrote :

Setting this back to "Triaged" because this is on the radar for a later series, after Yakkety release.

Changed in nginx (Ubuntu):
status: In Progress → Triaged
Thomas Ward (teward) wrote :

I'm going to close this bug here as "Won't Fix", and upload a separate merge request, as there's a bit more to consider now that there's several things we've implemented from Debian in the package. We will have a new merge ticket within the next week with updated information.

Changed in nginx (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers