package nginx (not installed) (from nginx.org upstream repository) failed to install/upgrade: trying to overwrite '/etc/default/nginx', which is also in package nginx-common 1.4.6-1ubuntu3.2

Bug #1440363 reported by neptuneray on 2015-04-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nginx (Ubuntu)
Undecided
Unassigned

Bug Description

Trying to upgrade Nginx to at least v1.6 (1.7 is current stable) because of problems with the 1.4 firewall Naxsi, the only solution being to upgrade both packages. I am stuck ... can't install or uninstall.

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: nginx (not installed)
ProcVersionSignature: Ubuntu 3.13.0-48.80-generic 3.13.11-ckt16
Uname: Linux 3.13.0-48-generic i686
ApportVersion: 2.14.1-0ubuntu3.8
AptOrdering:
 nginx: Install
 nginx: Configure
Architecture: i386
Date: Thu Apr 2 08:57:25 2015
DpkgTerminalLog:
 Preparing to unpack .../nginx_1.6.2-1~trusty_i386.deb ...
 Unpacking nginx (1.6.2-1~trusty) over (1.4.6-1ubuntu3.2) ...
 dpkg: error processing archive /var/cache/apt/archives/nginx_1.6.2-1~trusty_i386.deb (--unpack):
  trying to overwrite '/etc/default/nginx', which is also in package nginx-common 1.4.6-1ubuntu3.2
DuplicateSignature: package:nginx:(not installed):trying to overwrite '/etc/default/nginx', which is also in package nginx-common 1.4.6-1ubuntu3.2
ErrorMessage: trying to overwrite '/etc/default/nginx', which is also in package nginx-common 1.4.6-1ubuntu3.2
SourcePackage: nginx
Title: package nginx (not installed) failed to install/upgrade: trying to overwrite '/etc/default/nginx', which is also in package nginx-common 1.4.6-1ubuntu3.2
UpgradeStatus: No upgrade log present (probably fresh install)

neptuneray (neptuneray) wrote :
tags: removed: need-duplicate-check
Thomas Ward (teward) wrote :

Corrections needed. For upstream nginx, 1.7.x is mainline; 1.6.x is stable. 1.7.x has newer features than Stable does, but may not be as stable.

------

(If this seems like a lot to read, and you don't want to read the lots of information I put here for background and explanation, skip down to the next section where I say "This bug is a two part problem" and summarize.)

Now, onto the actual issue here. Based on the versioning string of the package you're trying to actually install, I assume that you are trying to use the upstream repository, which is from nginx.org, and not the PPA. That's a repository not controlled or maintained by myself or anyone in Ubuntu. They do not separate out 'common configuration files' from the actual packaging containing the binary, because they only ship one 'flavor' of NGINX. Because of this, everything's in the 'nginx' package in the upstream repository - in Debian, Ubuntu, and the PPAs, the 'nginx' package is a metapackage that calls upon one of the packages that has the actual binaries for the given flavor in it. (Read the answer I wrote here for a breakdown of the 'flavors' I refer to: http://askubuntu.com/questions/553937/what-is-the-difference-between-the-core-full-extras-and-light-packages-for-ngi/556382#556382)

Because of the varying packaging differences between Debian/Ubuntu/PPAs and the Upstream repository from nginx.org, they are incompatible with each other.

They also won't have NAXSI, because it's not supported by them. The naxsi module is a third party plugin. It was part of the Debian package (and the PPA packages I maintain, and Ubuntu's packaging) up until its removal relatively recently. It was dropped from Debian with https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=746199 and dropped in 1.6.2-2 there (and in the PPAs, and in subsequent versions in Ubuntu). It was never part of upstream's code and will not exist in the upstream code either.

------

This bug is a two part problem, of which neither are fixable in Ubuntu:

(1) This is not a bug fixable in Ubuntu - upstream nginx needs to update their packaging to meet the same standards as Debian and/or the PPAs, which won't happen based on my communication with them there. I am marking this "Invalid" as such here as this is not an Ubuntu bug nor an issue fixable here in Ubuntu.

(2) NAXSI is no longer supported in nginx in Ubuntu or Debian, and has never had support from upstream nginx.org. Therefore, you will not be able to get 'naxsi' working the way you want/need it to without manually compiling the software yourself, using nginx.org's tarballs and the naxsi module code, following the naxsi upstream developers' guides to building the software.

Changed in nginx (Ubuntu):
status: New → Invalid
status: Invalid → New
status: New → Invalid
summary: - package nginx (not installed) failed to install/upgrade: trying to
- overwrite '/etc/default/nginx', which is also in package nginx-common
- 1.4.6-1ubuntu3.2
+ package nginx (not installed) (from nginx.org upstream repository)
+ failed to install/upgrade: trying to overwrite '/etc/default/nginx',
+ which is also in package nginx-common 1.4.6-1ubuntu3.2
Thomas Ward (teward) on 2015-04-04
tags: added: third-party-packages
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.