nginx-full

Bug #1402137 reported by Navid Paya on 2014-12-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nginx (Ubuntu)
Undecided
Unassigned

Bug Description

I'm running Ubuntu 14.04 on Vagrant using the "ubuntu/trusty64" image from vagrantcloud. When I try to install nginx-full, I face a version mismatch issue. I did a bit of digging. The issue is nginx-full depends on nginx common. Now:

vagrant@sandbox:~$ aptitude show nginx-full
Package: nginx-full
State: not installed
Version: 1.4.6-1ubuntu3
Priority: optional
Section: universe/httpd
Maintainer: Ubuntu Developers <email address hidden>
Architecture: amd64
Uncompressed Size: 1,030 k
Depends: nginx-common (= 1.4.6-1ubuntu3), libc6 (>= 2.14), libexpat1 (>= 2.0.1), libgd3 (>= 2.1.0~alpha~), libgeoip1, libpam0g (>= 0.99.7.1), libpcre3, libssl1.0.0 (>= 1.0.1),
         libxml2 (>= 2.7.4), libxslt1.1 (>= 1.1.25), zlib1g (>= 1:1.2.0)
Suggests: nginx-doc (= 1.4.6-1ubuntu3)

While:

vagrant@sandbox:~$ aptitude show nginx-common
Package: nginx-common
State: not installed
Version: 1.4.6-1ubuntu3.1

So nginx-full is 1.4.6-1ubuntu3 and it depends on nginx-common 1.4.6-1ubuntu3 while there's newer version of nginx-common (1.4.6-1ubuntu3.1) in the repo. I think that needs to be updated ASAP since nginx is a very common package.

Thomas Ward (teward) wrote :

It sounds to me like your repositories aren't fully updated - can you run an 'apt-get update' and try again? I've just checked the repositories, and all the NGINX packages in Trusty are -3ubuntu1 if you have -updates and/or -security enabled.

Changed in nginx (Ubuntu):
status: New → Incomplete

Hi Thomas
Apologies. Just after opening this ticket I realized I haven't added all the universe repos. Sorry for the false alarm.

Thomas Ward (teward) wrote :

No problem, thanks for checking!

Changed in nginx (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers