Nginx - typo in default config file (13.04)

Bug #1164966 reported by Daniel Davies on 2013-04-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nginx (Ubuntu)
High
Unassigned

Bug Description

Description: Ubuntu Raring Ringtail (development branch)
Release: 13.04

nginx:
  Installed: 1.2.6-1ubuntu1

Expected:

Default nginx install should dispaly the "Welcome to nginx!" page upon starting the service.

Result:

nginx failed to start upon starting the service.
checking the log at /var/log/nginx/error shows:
[emerg] 3748#0: invalid parameter "ipv6_only=on" in /etc/nginx/sites-enabled/default:22

Line 22 of /etc/nginx/sites-available has a typo preventing nginx starting with a default configuration.

the line in question has a typo in the parameter "ipv6_only" the actual name of the parameter is "ipv6only" with no underscore.

Correcting this typo resolves the issue.

Thomas Ward (teward) wrote :

Importance set to high since this causes a usability problem.

Once I confirm in my VM, or another person confirms this, I will get a patch out for this and included in the package.

------
Thomas

Changed in nginx (Ubuntu):
assignee: nobody → Thomas Ward (teward)
importance: Undecided → High
Thomas Ward (teward) wrote :

This bug and Bug 1162177 seem to be the same bug. Therefore, I am marking this bug as a duplicate of 1162177, the fix for both bugs is the same regardless.

Changed in nginx (Ubuntu):
assignee: Thomas Ward (teward) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers