rpc.gssd memory leak

Bug #988055 reported by Steve Atwell on 2012-04-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nfs-utils (Ubuntu)
High
Adam Stokes
Lucid
High
Dimitri John Ledkov

Bug Description

rpc.gssd appears to be leaking a small amount of memory every time it's used to authenticate a kerberized nFS mount. I can reproduce by running:

while sleep 1; do mount -o sec=krb5 nfsserver:/remotepath /mnt; umount /mnt; done

While running this in a loop, you can observe from rpc.gssd's /proc/<pid>/status file that its VmRSS grows indefinitely, generally by about 4 kB per mount request. On some of our servers that have a high turn-over rate of kerberized NFS mounts, we've seen the rpc.gssd process grow to more than 600 MB!

This happens on lucid with nfs-common 1:1.2.0-4ubuntu4.2.

I haven't been able to reproduce on precise with nfs-common 1:1.2.5-3ubuntu3, but this is still an important bug for lucid.

Jose Plans (jplans) on 2012-06-06
Changed in nfs-utils (Ubuntu):
status: New → Incomplete
status: Incomplete → Opinion
status: Opinion → Invalid
status: Invalid → Won't Fix
status: Won't Fix → Confirmed
Adam Stokes (adam-stokes) wrote :

Hi,

I am still looking into the root cause of the problem. Thank you for your patience.

Adam

Changed in nfs-utils (Ubuntu):
importance: Undecided → High
assignee: nobody → Adam Stokes (adam-stokes)
Steve Langasek (vorlon) on 2012-11-15
Changed in nfs-utils (Ubuntu):
status: Confirmed → Fix Released
Changed in nfs-utils (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Adam Stokes (adam-stokes)
Steve Langasek (vorlon) on 2012-11-15
Changed in nfs-utils (Ubuntu Lucid):
assignee: Adam Stokes (adam-stokes) → Dmitrijs Ledkovs (xnox)
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in nfs-utils (Ubuntu Lucid):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers