package nfs-common 1:1.2.0-2ubuntu1 failed to install/upgrade:

Bug #441055 reported by Michael
74
This bug affects 14 people
Affects Status Importance Assigned to Milestone
nfs-utils (Ubuntu)
High
Steve Langasek

Bug Description

Getting this after today's update.

ProblemType: Package
Architecture: i386
Date: Fri Oct 2 20:59:07 2009
DistroRelease: Ubuntu 9.10
ErrorMessage:
 ErrorMessage: subprocess installed post-installation script returned error exit status 1
NonfreeKernelModules: nvidia
Package: nfs-common 1:1.2.0-2ubuntu1
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SourcePackage: nfs-utils
Title: package nfs-common 1:1.2.0-2ubuntu1 failed to install/upgrade:
Uname: Linux 2.6.31-11-generic i686

Revision history for this message
Michael (mike984) wrote :
Revision history for this message
Steve Langasek (vorlon) wrote :

Thank you for taking the time to report this bug and help to improve Ubuntu.

The log shows the following error:

Setting up nfs-common (1:1.2.0-2ubuntu1) ...
 * Stopping NFS common utilities
   ...done.
 Removing any system startup links for /etc/init.d/nfs-common ...
   /etc/rc0.d/K20nfs-common
   /etc/rc1.d/K20nfs-common
   /etc/rc2.d/S20nfs-common
   /etc/rc3.d/S20nfs-common
   /etc/rc4.d/S20nfs-common
   /etc/rc5.d/S20nfs-common
   /etc/rc6.d/K20nfs-common
   /etc/rcS.d/S44nfs-common
statd start/running, process 19984
start: Job failed to start
invoke-rc.d: initscript gssd, action "restart" failed.
dpkg: error processing nfs-common (--configure):
 subprocess installed post-installation script returned error exit status 1

What do you see if you run 'sudo start gssd' manually from a console?

What is the output of 'ps awx | grep gssd'?

Revision history for this message
Sergei Genchev (sgenchev) wrote :

 nfs-common definitely fails to install for me:
invoke-rc.d: initscript gssd, action "start" failed.
dpkg: error processing nfs-common (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 nfs-common
E: Sub-process /usr/bin/dpkg returned an error code (1)
 gssd was converted to upstart but the nfs-common package is trying to start it the old way.

Revision history for this message
hikaricore (hikaricore) wrote :

Having the exact same issue here.

Even tried to install it with dpkg.

Setting up nfs-common (1:1.2.0-2ubuntu1) ...
 * Stopping NFS common utilities [ OK ]
 Removing any system startup links for /etc/init.d/nfs-common ...
statd start/running, process 22131
start: Job failed to start
invoke-rc.d: initscript gssd, action "restart" failed.
dpkg: error processing nfs-common (--install):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 nfs-common

Revision history for this message
Steve Langasek (vorlon) wrote :

Ok, got it; we need to handle the gssd start script failing in the case that gssd isn't supposed to start at all. Sorry, will have this fixed in the next upload.

Changed in nfs-utils (Ubuntu):
assignee: nobody → Steve Langasek (vorlon)
importance: Undecided → High
status: New → Incomplete
status: Incomplete → In Progress
Revision history for this message
hikaricore (hikaricore) wrote :

We love you ^_^

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nfs-utils - 1:1.2.0-2ubuntu2

---------------
nfs-utils (1:1.2.0-2ubuntu2) karmic; urgency=low

  * Configure gssd and idmapd upstart jobs to stop on runlevels 0 and 6; this
    is consistent with previous initscript-based behavior, and spares upstart
    trying to restart the jobs repeatedly when sendsigs runs.
  * When autodetecting gssd, handle the case of 'sec=krb5' being embedded in
    the middle of the options list in /etc/fstab. LP: #364861.
  * Fix transition idempotency error when stopping old nfs-common init
    script, in case the postinst fails to finish afterwards (e.g., failure to
    restart the daemons).
  * Fix statd upstart job to properly honor NEED_STATD=no and not get stuck
    respawning indefinitely.
  * Ignore failures to start the daemons on upgrade, since if they aren't
    needed we don't *want* them to start. LP: #441055.
  * Fix up the rpc_pipefs job, the wrong version of the file slipped into
    the previous upload.

 -- Steve Langasek <email address hidden> Sat, 03 Oct 2009 01:52:21 +0000

Changed in nfs-utils (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Elfy (elfy) wrote :

Another update today - still gettting this as it tries to install

Setting up nfs-common (1:1.2.0-2ubuntu4) ...
Installing new version of config file /etc/init/rpc_pipefs.conf ...
Installing new version of config file /etc/init/gssd.conf ...
Installing new version of config file /etc/init/idmapd.conf ...
statd start/running, process 21809
start: Job failed to start
invoke-rc.d: initscript gssd, action "restart" failed.
start: Job failed to start
invoke-rc.d: initscript idmapd, action "restart" failed.

Revision history for this message
Steve Langasek (vorlon) wrote : Re: [Bug 441055] Re: package nfs-common 1:1.2.0-2ubuntu1 failed to install/upgrade:

On Tue, Oct 06, 2009 at 07:33:55AM -0000, forestpixie wrote:
> Another update today - still gettting this as it tries to install

> Setting up nfs-common (1:1.2.0-2ubuntu4) ...
> Installing new version of config file /etc/init/rpc_pipefs.conf ...
> Installing new version of config file /etc/init/gssd.conf ...
> Installing new version of config file /etc/init/idmapd.conf ...
> statd start/running, process 21809
> start: Job failed to start
> invoke-rc.d: initscript gssd, action "restart" failed.
> start: Job failed to start
> invoke-rc.d: initscript idmapd, action "restart" failed.

Yes, that's the expected output - it tries to start the jobs and will report
if it can't. The difference is whether this results in a failure of the
package to configure, which (as expected) doesn't seem to have been a
problem for you here.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Revision history for this message
Elfy (elfy) wrote :

aah ok then - so at the moment still have to mount them myself after I get to the desktop - I assume that is not expected behaviour though.

Thanks for reply :)

Revision history for this message
Steve Langasek (vorlon) wrote :

If you're having to manually mount your nfs filesystems, that's another matter entirely. Can you post the nfs lines from your /etc/fstab?

Revision history for this message
Elfy (elfy) wrote :

192.168.0.2:/mnt/data /mnt/data nfs rsize=8192,wsize=8192,noexec,nosuid
192.168.0.2:/mnt/media /mnt/media nfs rsize=8192,wsize=8192,noexec,nosuid
192.168.0.2:/mnt/music /mnt/music nfs rsize=8192,wsize=8192,noexec,nosuid
192.168.0.2:/mnt/10Gb /mnt/10Gb nfs rsize=8192,wsize=8192,noexec,nosuid
192.168.0.2:/mnt/12Gb /mnt/12Gb nfs rsize=8192,wsize=8192,noexec,nosuid

Revision history for this message
Steve Langasek (vorlon) wrote :

Ok, these appear to be NFSv3 mounts, so there's no need for idmapd to be running, and I don't see any evidence from the mount options that you would need gssd running either. So the install-time failure messages are unrelated to any problems you're having getting these filesystems mounted at boot time.

If the problem of filesystems not being mounted at boot persists, can you please open a new bug report, and post:

- your /etc/fstab contents (for reference)
- any error messages you see at boot time about mounting when booting without the 'splash' option
- the results of 'sudo killall -USR1 mountall && mount', run on your system after boot when the network is up but without having mounted the filesystems by hand
- the output of 'sudo status statd'

Revision history for this message
Elfy (elfy) wrote :

Ok I can do all of that tomorrow as I doubt if I will see any change - what would I need to file the bug against - linux, ubuntu?

The bug system confuses me at the best of times as to what to file the bug against :)

Revision history for this message
Steve Langasek (vorlon) wrote :

Running 'ubuntu-bug nfs-common' should get you where you need to be for filing a new bug on this package.

Revision history for this message
Elfy (elfy) wrote :

ok - I will do that later and add the things you suggested above.

Thanks for your help :)

Revision history for this message
Elfy (elfy) wrote :
Revision history for this message
Boris Devouge (bdevouge) wrote :

Hi,

Not sure which bug to comment, but seeing the exact same issue here with nfs-common 1:1.2.2-1ubuntu1.1 on Ubuntu 10.10. Was this bug re-introduced somehow?

Setting up nfs-common (1:1.2.2-1ubuntu1.1) ...
statd start/running, process 15149
start: Unknown job: gssd
invoke-rc.d: initscript gssd, action "restart" failed.
dpkg: error processing nfs-common (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 nfs-common

"sudo start gssd" gives me a 'start: Unknown job: gssd'

Machine is fully up2date, stock ubuntu maverick repos.

Thank you.

Revision history for this message
Steve Langasek (vorlon) wrote :

Hi Boris,

You have a different error then - the original bug was about the gssd job not starting and that we didn't handle this failure, the error you're getting shows that upstart doesn't recognize the 'gssd' job name at all. Is /etc/init/gssd.conf is missing from the system? Or has it been edited so that it's no longer a valid job file?

Revision history for this message
Boris Devouge (bdevouge) wrote :

Hi Steve,

Thanks for the quick answer. /etc/init/gssd.conf is present and untouched as far as I am aware.

wc -l /etc/init/gssd.conf
70 /etc/init/gssd.conf

md5sum /etc/init/gssd.conf
6288ac6f6eaec52634a00d3390c87627 /etc/init/gssd.conf

I use nfs V3 mounts on this machine (client) but it does not serves any nfs shares, never used nfs V4 auth mounts, and never had to edit / change any of the services related to it. This issue happened few days back on its own right. Sorry for the noise on resolved bugs, let me know if I should open something new.

Thank you.

Revision history for this message
Boris Devouge (bdevouge) wrote :

Steve,

 Forget it, start on and stop on were commented, removed the comments and a "sudo dpkg --configure -a" sorted the machine. Sorry for the noise, "fix released" it is ;-)

Thanks again !

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers