Ubuntu

not automount by fstab in Jaunty

Reported by Alexander Dorofeev on 2009-04-27
10
Affects Status Importance Assigned to Milestone
nfs-utils (Ubuntu)
Undecided
Unassigned

Bug Description

I have some workstations on ubuntu. On this workstations some network paths is mounted by NFS. But after upgrade to Jaunty I have one problem: NFS mounts in fstab not mounted automatically at startup. Strange thing: NFS paths mounts successfully by command "mount -a".

/etc/fstab:
proc /proc proc defaults 0 0
UUID=6718dc6d-85e8-4d04-8f7b-8aaecb4da9b0 / ext4 relatime,errors=remount-ro 0 1
UUID=9262692e-49e7-4efc-836d-fc7f2a70a363 none swap sw 0 0
192.168.0.40:/export/drop /home/locadmin/drop nfs defaults 0 0

On Intrepid all works good. There I'm wrong?

Problem solved with add "ASYNCMOUNTNFS=no" to /etc/defaults/rcS

description: updated
description: updated
Changed in nfs-utils (Ubuntu):
status: New → Incomplete
status: Incomplete → Confirmed

i have the same issue on my laptop where Jaunty was update from intrepid.I am still trying to locate that nfs from the terminal using the SUDO command.Thus far nothing has worked.The only Thing that seems to work is the workaround,which is:

sudo modprobe floppy

what I have managed to get was that i would have to add to /etc/modules. I will have to do it with the SUDO command because for some reason,i could not get my root terminal up.

Bill Kendall (bkendall3) wrote :

I have the same issue. Added some log messages to /etc/network/if-up.d/mountnfs script and discovered that the script was exiting in exit_unless_last_interface. That function reads /etc/network/interfaces and exits if not all of the "auto" interfaces are currently up.

My /etc/network/interfaces file had several "auto" interfaces that do not even exist on my system (eth1, eth2, ath0, wlan0), so this function is guaranteed to fail with my config. I removed the non-existent interfaces from /etc/network/interfaces and now nfs filesystems are mounted at boot time.

Not sure how those non-existent interfaces were added to the interfaces file. Perhaps just left over from an earlier upgrade. The last fresh install on this system was way back on hoary.

Steve Langasek (vorlon) wrote :

With Ubuntu 9.10, this bug does not exist.

Changed in nfs-utils (Ubuntu):
status: Confirmed → Fix Released
unixnewbie (darfsten) wrote :

steve,
yes it does exist. i am running karmic upgraded all the way back from hardy heron and my nfs mounts not longer auto mount. here are my fstab entries

192.168.0.5:/var/lib/mythtv /var/lib/mythtv nfs rsize=8192,wsize=8192,timeo=14,intr
192.168.0.5:/media/500gb /media/500gb nfs rsize=8192,wsize=8192,timeo=14,intr
192.168.0.5:/media/500gb1 /media/500gb1 nfs rsize=8192,wsize=8192,timeo=14,intr

although from reading above i noticed that my interfaces file may be jacked up. this is what it looks like

auto lo
iface lo inet loopback

# The primary network interface

iface eth0 inet static
address 192.168.0.3
netmask 255.255.255.0
gateway 192.168.0.1
dns-nameservers 208.67.222.222 208.67.220.220

iface bnep0 inet dhcp

auto eth0

i changed it to look like this
auto lo
iface lo inet loopback

# The primary network interface

auto eth0
iface eth0 inet static
address 192.168.0.3
netmask 255.255.255.0
gateway 192.168.0.1
dns-nameservers 208.67.222.222 208.67.220.220

#iface bnep0 inet dhcp

#auto eth0

so the next reboot i hope they automount. either way i'll be back to let everyone know

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers