in Jaunty, mount.nfs fails with "mount(2): Input/output error"

Bug #365772 reported by Ryan Ritterson on 2009-04-23
This bug affects 3 people
Affects Status Importance Assigned to Milestone
nfs-utils (Ubuntu)

Bug Description

Binary package hint: nfs-common

For some time I was affected by bug #213444, preventing me from mounting an NFS share since Ubuntu 8.04 (Heron). That bug appears to have been fixed (for a short time i was able to mount successfully), but now I get an additional series of errors in Jaunty when trying to mount an NFS share:

call: sudo mount -t nfs -o nolock -vvvv fileserver:/remoteMount localmount
which returns:
mount.nfs: mount(2): Input/output error


mount.nfs: mount system call failed.

We have a number of other linux systems around, running different distributions, mostly CentOS, which have no problem mounting the server.

Of interest may be a link dumped into the system logs:

muscat kernel: [ 979.924016] rpcbind: server fileserver not responding, timed out

However, I think that's probably a red herring, as mount typically responds with a different error message on time out, and other computers are able to reach the NFS server without difficulty.

iptables has no rules set up, and portmapper is running. I have also tried -o nolock (as you can see), but it appears I am affected by a different problem than bug #306016.

Package is version 1:1.1.4-1ubuntu1

description: updated
flo-54321 (flo-54321) wrote :

I am also affected by this error since the upgrade to Jaunty.

Kaustubh Srikanth (houndbee) wrote :

Same for me.

But the strange thing is that I had it working on the same box which it fails now on until about a couple of days ago, and nothing has changed since AFAIK.

To add to that, I've got another identical machine running Jaunty, which doesn't see this error and mounts and accesses the share with no problems.

:~# sudo mount -t nfs -o nolock -vvvv /v/drupal/storage
mount: fstab path: "/etc/fstab"
mount: mtab path: "/etc/mtab"
mount: lock path: "/etc/mtab~"
mount: temp path: "/etc/mtab.tmp"
mount: spec: ""
mount: node: "/var/drupal/storage"
mount: types: "nfs"
mount: opts: "nolock"
mount: external mount: argv[0] = "/sbin/mount.nfs"
mount: external mount: argv[1] = ""
mount: external mount: argv[2] = "/var/drupal/storage"
mount: external mount: argv[3] = "-v"
mount: external mount: argv[4] = "-o"
mount: external mount: argv[5] = "rw,nolock"
mount.nfs: timeout set for Fri May 15 16:25:42 2009
mount.nfs: text-based options: 'nolock,addr='
mount.nfs: mount(2): Input/output error
mount.nfs: mount system call failed

:~# uname -svr
Linux 2.6.24-23-xen #1 SMP Mon Jan 26 03:09:12 UTC 2009 (on both boxes)

Ryan Ritterson (rrpublic) wrote :

If I run the command as Kaustubh Srikanth runs, replacing the relevant entries with my server and share, I get identical output.

Results of the uname are:
Linux 2.6.28-12-generic #43-Ubuntu SMP Fri May 1 19:31:32 UTC 2009

Ryan Ritterson (rrpublic) wrote :

Multiple persons comment having identical problems, so changing from new to confirmed.

Changed in nfs-utils (Ubuntu):
status: New → Confirmed
Ryan Ritterson (rrpublic) wrote :

I tried connecting to the same file server with the same command on another box with a fresh install of Jaunty x64 and the command works with no issues. I am going to attempt to reformat this box and see if that fixes the problem.

Ryan Ritterson (rrpublic) wrote :

In my case, the bug appears to be due to a firewall change on the server banning this specific client's IP from connecting that happened coincidentally while upgrading to Jaunty. I am marking the bug as invalid, as it's not really a bug.

Changed in nfs-utils (Ubuntu):
status: Confirmed → Invalid
flo-54321 (flo-54321) wrote :

In my case it was a firewall problem too.

yorgabr (yorgabr-gmail) wrote :

I confirm this bug too, at same conditions and error messages Mr. Ritterson reported.

yorgabr (yorgabr-gmail) wrote :

I forgot to say, I have no firewall problems, my two computers are connected by a router without firewalling enabled.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers