byobu-config crashed with ImportError in /usr/lib/python2.7/dist-packages/snack.py: /usr/lib/python2.7/dist-packages/_snack.so: undefined symbol: _Py_RefTotal

Bug #1097922 reported by Chris Johnston on 2013-01-09
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
byobu (Ubuntu)
High
Unassigned
Raring
High
Unassigned
newt (Ubuntu)
High
Barry Warsaw
Raring
High
Barry Warsaw

Bug Description

Hit F9 to go to menu, got a crash

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: byobu 5.24-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-21.32-generic 3.5.7.1
Uname: Linux 3.5.0-21-generic x86_64
ApportVersion: 2.8-0ubuntu1
Architecture: amd64
Date: Wed Jan 9 15:11:55 2013
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/byobu-config
InstallationDate: Installed on 2012-06-09 (213 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
InterpreterPath: /usr/bin/python2.7
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/byobu-config
ProcEnviron:
 TERM=screen
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 XDG_RUNTIME_DIR=<set>
PythonArgs: ['/usr/bin/byobu-config']
ScreenRC:

SourcePackage: byobu
Title: byobu-config crashed with ImportError in /usr/lib/python2.7/dist-packages/snack.py: /usr/lib/python2.7/dist-packages/_snack.so: undefined symbol: _Py_RefTotal
UpgradeStatus: Upgraded to raring on 2012-12-21 (19 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Chris Johnston (cjohnston) wrote :
tags: removed: need-duplicate-check
Changed in byobu (Ubuntu):
importance: Undecided → Medium
Changed in byobu (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 5.27-0ubuntu1

---------------
byobu (5.27-0ubuntu1) raring; urgency=low

  * usr/bin/byobu-config: LP: #1097922, #1098102
    - ensure byobu-config works even if ~/.profile doesn't exist
  * usr/bin/byobu-ctrl-a: LP: #1098229
    - fix typo that breaks ctrl-a selection behavior
  * usr/bin/byobu: LP: #1026595
    - fix readlink detection; we were using BYOBU_TEST before it was defined
    - instead, try to greadlink -f .; operationally the same
  * usr/lib/byobu/include/dirs: LP: #1025998
    - more XDG annoyances
    - use $HOME/.config/byobu as BYOBU_CONFIG_DIR if it exists
  * === added symlink usr/bin/byobu-screen, === added symlink
    usr/bin/byobu-tmux, === target is byobu: LP: #1022882
    - add symlinks to repo, makes it easier to use byobu straight out of
      bzr
  * usr/bin/byobu-select-profile: LP: #946112
    - fix byobu interactive color selection in tmux
  * usr/lib/byobu/distro, usr/lib/byobu/release: LP: #1004722
    - use sw_vers utility on Mac to determine distro and release
 -- Dustin Kirkland <email address hidden> Thu, 10 Jan 2013 16:36:23 -0600

Changed in byobu (Ubuntu):
status: In Progress → Fix Released
Chris Johnston (cjohnston) wrote :

I just got this error again. This is my installed version:

chris@aries:~$ aptitude show byobu
Package: byobu
State: installed
Automatically installed: no
Version: 5.27-0ubuntu1

Changed in byobu (Ubuntu):
status: Fix Released → New
Dustin Kirkland  (kirkland) wrote :

This is unfortunately a bug in python-newt.

information type: Private → Public
affects: byobu (Ubuntu) → newt (Ubuntu)
Changed in byobu (Ubuntu):
status: New → Invalid
importance: Undecided → High
Changed in newt (Ubuntu):
importance: Medium → High
status: New → Confirmed
Barry Warsaw (barry) on 2013-02-13
Changed in newt (Ubuntu Raring):
assignee: nobody → Barry Warsaw (barry)
Barry Warsaw (barry) wrote :

Looks like the packages get the .so's backwards. _snack.so is the debug version and _snack_d.so is the non-debug version. Now I just have to figure out why that happens.

Barry Warsaw (barry) wrote :

Okay, so the d/p/python3.patch mixed up -z and -n for the [ command.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package newt - 0.52.14-11ubuntu6

---------------
newt (0.52.14-11ubuntu6) raring; urgency=low

  * debian/patches/python3.patch: Fix the $$variant tests in Makefile.in.
    -z means to check for zero length (-n is for non-zero length). This
    got the order of the _snack{,_d}.so files reversed. (LP: #1097922)
 -- Barry Warsaw <email address hidden> Wed, 13 Feb 2013 15:16:35 -0500

Changed in newt (Ubuntu Raring):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers