[SRU] Revert fix for bug 1752838 regression

Bug #1758411 reported by Corey Bryant on 2018-03-23
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Critical
Unassigned
Mitaka
Critical
Unassigned
Newton
Critical
Unassigned
Ocata
Critical
Unassigned
Pike
Critical
Unassigned
Queens
Critical
Unassigned
neutron (Ubuntu)
Critical
Unassigned
Xenial
Critical
Unassigned
Artful
Critical
Unassigned
Bionic
Critical
Unassigned

Bug Description

[Impact]

The fix for the following bug was found to cause a regression/race with neutron-ovs-cleanup and neutron-openvswitch-agent where ports/flows get deleted and do not get restored.

https://bugs.launchpad.net/ubuntu/+source/neutron/+bug/1752838

[Test Case]
* Deploy OpenStack Mitaka with one compute, one gateway and gre overlay
* Create instance on gre overlay network
* Add FIP to instance
* Start a ping to FIP
* juju ssh nova-compute/0
* Check 'ovs-ofctl dump-flows br-tun' and observe table=20 egress flows for qdhcp and qrouter
* systemctl restart openvswitch-switch
* Check that flows re-added to br-tun (this takes a few seconds for neutron-openvswitch-agent to re-add them)
* Check that ping still running

[Regression Potential]

There should be none as long as the code is reverted to what it was before the SRU for 1752838.

Changed in neutron (Ubuntu Xenial):
status: New → Triaged
Changed in neutron (Ubuntu Artful):
status: New → Triaged
Changed in neutron (Ubuntu Bionic):
status: New → Triaged
Changed in neutron (Ubuntu Xenial):
importance: Undecided → Critical
Changed in neutron (Ubuntu Artful):
importance: Undecided → Critical
Changed in neutron (Ubuntu Bionic):
importance: Undecided → Critical
description: updated
description: updated

Hello Corey, or anyone else affected,

Accepted neutron into ocata-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:ocata-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-ocata-needed to verification-ocata-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-ocata-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-ocata-needed
Corey Bryant (corey.bryant) wrote :

Hello Corey, or anyone else affected,

Accepted neutron into newton-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:newton-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-newton-needed to verification-newton-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-newton-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-newton-needed
Corey Bryant (corey.bryant) wrote :

Hello Corey, or anyone else affected,

Accepted neutron into queens-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:queens-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-queens-needed to verification-queens-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-queens-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-queens-needed
Brian Murray (brian-murray) wrote :

Hello Corey, or anyone else affected,

Accepted neutron into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/neutron/2:11.0.3-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in neutron (Ubuntu Artful):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-artful
Changed in neutron (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Corey, or anyone else affected,

Accepted neutron into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/neutron/2:8.4.0-0ubuntu7.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron - 2:12.0.0-0ubuntu1.3

---------------
neutron (2:12.0.0-0ubuntu1.3) bionic; urgency=medium

  * d/neutron-openvswitch-agent.neutron-ovs-cleanup.service.in:
    Revert changes made for LP:#1752838 due to regression (LP: #1758411).

 -- Corey Bryant <email address hidden> Fri, 23 Mar 2018 14:41:23 -0400

Changed in neutron (Ubuntu Bionic):
status: Triaged → Fix Released
Corey Bryant (corey.bryant) wrote :

Hello Corey, or anyone else affected,

Accepted neutron into pike-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:pike-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-pike-needed to verification-pike-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-pike-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-pike-needed
Corey Bryant (corey.bryant) wrote :

Hello Corey, or anyone else affected,

Accepted neutron into mitaka-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:mitaka-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-mitaka-needed to verification-mitaka-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-mitaka-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-mitaka-needed
Corey Bryant (corey.bryant) wrote :

verified successfully on ocata-proposed using test case from bug description.

tags: added: verification-ocata-done
removed: verification-mitaka-needed verification-ocata-needed
Corey Bryant (corey.bryant) wrote :

verified successfully on newton-proposed using test case from bug description.

tags: added: verification-newton-done
removed: verification-newton-needed
Corey Bryant (corey.bryant) wrote :

verified successfully on pike-proposed using test case from bug description.

Corey Bryant (corey.bryant) wrote :

xenial-pike before restarting openvswitch-switch

Corey Bryant (corey.bryant) wrote :

xenial-pike-proposed after restarting openvswitch-switch

tags: added: verification-pike-done
removed: verification-pike-needed
Corey Bryant (corey.bryant) wrote :

verified successfully on xenial-proposed using test case from bug description.

Corey Bryant (corey.bryant) wrote :

xenial-proposed before restarting openvswitch-switch

Corey Bryant (corey.bryant) wrote :

xenial-proposed after restarting openvswitch-switch

tags: added: verification-done-xenial
removed: verification-needed-xenial
Corey Bryant (corey.bryant) wrote :

verified successfully on mitaka-proposed using test case from bug description.

tags: added: verification-mitaka-done
Corey Bryant (corey.bryant) wrote :

mitaka-proposed before restarting openvswitch-switch

Corey Bryant (corey.bryant) wrote :

mitaka-proposed after restarting openvswitch-switch

Corey Bryant (corey.bryant) wrote :

verified successfully on artful-proposed using test case from bug description.

tags: added: verification-done-artful
removed: verification-needed-artful
Corey Bryant (corey.bryant) wrote :

artful-proposed before restarting openvswitch-switch

Corey Bryant (corey.bryant) wrote :

artful-proposed after restarting openvswitch-switch

Corey Bryant (corey.bryant) wrote :

verified successfully on queens-proposed using test case from bug description.

tags: added: verification-queens-done
removed: verification-queens-needed
Corey Bryant (corey.bryant) wrote :

queens-proposed before restarting openvswitch-switch

Corey Bryant (corey.bryant) wrote :

queens-proposed after restarting openvswitch-switch

The verification of the Stable Release Update for neutron has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package neutron - 2:12.0.0-0ubuntu1.3~cloud0
---------------

 neutron (2:12.0.0-0ubuntu1.3~cloud0) xenial-queens; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 neutron (2:12.0.0-0ubuntu1.3) bionic; urgency=medium
 .
   * d/neutron-openvswitch-agent.neutron-ovs-cleanup.service.in:
     Revert changes made for LP:#1752838 due to regression (LP: #1758411).

Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for neutron has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package neutron - 2:11.0.3-0ubuntu1.1~cloud0
---------------

 neutron (2:11.0.3-0ubuntu1.1~cloud0) xenial-pike; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 neutron (2:11.0.3-0ubuntu1.1) artful; urgency=medium
 .
   * New upstream version.
   * d/p/call-update_all_ha_network_port_statuses-on-agent-start.patch:
     Dropped. Fixed in new upstream version.
   * New stable point release for OpenStack Pike (LP: #1758046).
   * d/neutron-openvswitch-agent.service.in,
     d/neutron-openvswitch-agent.neutron-ovs-cleanup.service.in:
     Revert changes made for LP:#1752838 due to regression (LP: #1758411).

Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for neutron has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package neutron - 2:10.0.4-0ubuntu2~cloud1.2
---------------

 neutron (2:10.0.4-0ubuntu2~cloud1.2) xenial-ocata; urgency=medium
 .
   * d/neutron-openvswitch-agent.service.in,
     d/neutron-openvswitch-agent.neutron-ovs-cleanup.service.in:
     Revert changes made for LP:#1752838 due to regression (LP: #1758411).

Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for neutron has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package neutron - 2:9.4.1-0ubuntu1~cloud2.2
---------------

 neutron (2:9.4.1-0ubuntu1~cloud2.2) xenial-newton; urgency=medium
 .
   * d/neutron-openvswitch-agent.service.in,
     d/neutron-openvswitch-agent.neutron-ovs-cleanup.service.in:
     Revert changes made for LP:#1752838 due to regression (LP: #1758411).

Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for neutron has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package neutron - 2:8.4.0-0ubuntu7.2~cloud0
---------------

 neutron (2:8.4.0-0ubuntu7.2~cloud0) trusty-mitaka; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 neutron (2:8.4.0-0ubuntu7.2) xenial; urgency=medium
 .
   * d/neutron-openvswitch-agent.service.in,
     d/neutron-openvswitch-agent.neutron-ovs-cleanup.service.in:
     Revert changes made for LP:#1752838 due to regression (LP: #1758411).

tags: added: verification-done
removed: verification-needed
Robie Basak (racb) on 2018-03-28
tags: added: regression-update
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron - 2:8.4.0-0ubuntu7.2

---------------
neutron (2:8.4.0-0ubuntu7.2) xenial; urgency=medium

  * d/neutron-openvswitch-agent.service.in,
    d/neutron-openvswitch-agent.neutron-ovs-cleanup.service.in:
    Revert changes made for LP:#1752838 due to regression (LP: #1758411).

 -- Corey Bryant <email address hidden> Fri, 23 Mar 2018 15:19:07 -0400

Changed in neutron (Ubuntu Xenial):
status: Fix Committed → Fix Released
Robie Basak (racb) wrote :

Accepted an early release request from coreycb on IRC for Xenial. Declined for Artful as the SRU also bundles other changes that are not suitable for early release.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron - 2:11.0.3-0ubuntu1.1

---------------
neutron (2:11.0.3-0ubuntu1.1) artful; urgency=medium

  * New upstream version.
  * d/p/call-update_all_ha_network_port_statuses-on-agent-start.patch:
    Dropped. Fixed in new upstream version.
  * New stable point release for OpenStack Pike (LP: #1758046).
  * d/neutron-openvswitch-agent.service.in,
    d/neutron-openvswitch-agent.neutron-ovs-cleanup.service.in:
    Revert changes made for LP:#1752838 due to regression (LP: #1758411).

 -- Corey Bryant <email address hidden> Thu, 22 Mar 2018 08:44:14 -0400

Changed in neutron (Ubuntu Artful):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers