Open vSwitch and Linux bridge agent dependencies

Bug #1527005 reported by Matt Kassawara
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
neutron (Ubuntu)
Fix Released
Medium
James Page

Bug Description

In Liberty, the Open vSwitch and Linux bridge agents use the following separate configuration files:

/etc/neutron/plugins/ml2/openvswitch_agent.ini
/etc/neutron/plugins/ml2/linuxbridge_agent.ini

The neutron-plugin-openvswitch-agent and neutron-plugin-linuxbridge-agent packages depend on the neutron-plugin-ml2 package that contains these files. However, only the neutron-server component (typically on the controller node) actually uses the ML2 plug-in and loads ML2 configuration from the ml2_conf.ini file. Other neutron components should not use the ml2_conf.ini file, yet the init scripts for the Open vSwitch and Linux bridge agents load it in addition to their separate configuration files. The neutron-plugin-openvswitch-agent and neutron-plugin-linuxbridge-agent packages should probably include their separate configuration files instead of the neutron-plugin-ml2 package.

Also, on a somewhat similar note, the neutron-plugin-ml2 package seems to only contain configuration files for the ML2 plug-in. The python-neutron package (a dependency of the neutron-common package) includes the actual code for it which means all installations of neutron include the ML2 plug-in even if they don't use it.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in neutron (Ubuntu):
status: New → Confirmed
James Page (james-page)
Changed in neutron (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
assignee: nobody → James Page (james-page)
status: Triaged → In Progress
James Page (james-page)
Changed in neutron (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron - 2:8.0.0~b2-0ubuntu5

---------------
neutron (2:8.0.0~b2-0ubuntu5) xenial; urgency=medium

  * d/control,neutron-plugin-openvswitch-agent.*: Add transitional package for
    upgrades, ensure that old init and upstart configurations are removed
    (LP: #1548242).
  * d/*.default,neutron-server.init.in: Revert commits which mistakenly
    tied ovs or linuxbridge agents to the neutron-server package (LP: #1548245).
  * d/control,neutron-{plugin-}linuxbridge-agent.*: Rename
    neutron-plugin-linuxbridge-agent -> neutron-linuxbridge-agent inline with
    other agent packages (LP: #1548244).
  * d/control: Add dependency on conntrack for openvswitch and linuxbridge
    packages (LP: #1514731).
  * d/control,*.install,*.init.in,*.service.in,*.update.in: Re-jig locations
    of ml2 plugin and associated agent files so that openvswitch, linuxbridge
    and sriov agents no longer need to include ml2_conf.ini (LP: #1527005).
  * d/control,neutron-{plugin-}sriov-agent.*: Rename
    neutron-plugin-sriov-agent -> neutron-sriov-agent inline with
    other agent packages (LP: #1548244).
  * d/tests/*: Refactor and reduce tests; ML2 is the only plugin now in neutron
    core, so no need to continue to carry infrastructure for testing other
    plugins.
  * d/control: Drop old Breaks/Replaces on quantum-* packages.

 -- James Page <email address hidden> Mon, 22 Feb 2016 13:47:02 +0000

Changed in neutron (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers