VPN agent dependencies are foobar

Bug #1303876 reported by James Page on 2014-04-07
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
High
Unassigned
Havana
High
Unassigned
neutron (Ubuntu)
High
James Page
Saucy
High
Unassigned
Trusty
High
James Page

Bug Description

The VPN agent is a superset of the l3agent; but it should not depend on it.

I'm discussing this with the upstream developer to see how best to handle this.

Related branches

James Page (james-page) on 2014-04-07
Changed in neutron (Ubuntu Trusty):
importance: Undecided → High
assignee: nobody → James Page (james-page)
status: New → In Progress
James Page (james-page) wrote :

At a minimum the vpnaas.filters file is missing - this might be causing problems.

James Page (james-page) on 2014-04-07
Changed in neutron (Ubuntu Trusty):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron - 1:2014.1~rc2-0ubuntu1

---------------
neutron (1:2014.1~rc2-0ubuntu1) trusty; urgency=medium

  [ James Page ]
  * d/neutron-plugin-oneconvergence-agent.upstart: Rename upstart
    configuration to match package name (LP: #1301957).
  * d/neutron-vpn-agent.install: Install missing vpnaas.filters for
    rootwrap (LP: #1303876).

  [ Chuck Short ]
  * New upstream release candidate (LP: #1288245).
 -- Chuck Short <email address hidden> Wed, 09 Apr 2014 08:51:40 -0400

Changed in neutron (Ubuntu Trusty):
status: Fix Committed → Fix Released
James Page (james-page) wrote :

Re-opening - l3 and vpn agents shared alot in common but must conflict with each other as the function overlaps.

Changed in neutron (Ubuntu Trusty):
status: Fix Released → In Progress
James Page (james-page) on 2014-04-11
Changed in neutron (Ubuntu Saucy):
status: New → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron - 1:2014.1~rc2-0ubuntu3

---------------
neutron (1:2014.1~rc2-0ubuntu3) trusty; urgency=medium

  * Fix the Breaks/Replaces from the previous version, as they were
    accidentally added to the wrong package (and with the wrong versioning).

neutron (1:2014.1~rc2-0ubuntu2) trusty; urgency=medium

  * Ensure that VPN and L3 agents are not installed together (LP: #1303876):
    - d/control: Add Conflicts on neutron-l3-agent to neutron-vpn-agent,
      drop dependency from neutron-vpn-agent -> neutron-l3-agent.
    - d/neutron-{common,vpn-agent,l3-agent}.install: Move configuration and
      rootwrap filters to -common package for use by both agent types.
    - d/control: Add appropriate Breaks/Replaces for config file moves.
    - d/neutron-vpn-agent.upstart: Include fwaas_driver.ini on config file
      path inline with l3-agent configuration.
    - d/control: Align Depends of neutron-vpn-agent with neutron-l3-agent.
 -- Steve Langasek <email address hidden> Thu, 10 Apr 2014 23:36:09 +0000

Changed in neutron (Ubuntu Trusty):
status: In Progress → Fix Released
Tom Verdaat (tom-verdaat) wrote :

Unlike the l3 agent package the vpn agent package is lacking the /etc/init/neutron-l3-agent.conf file required to start the l3 agent.

Does the vpn agent provide a superset of functionality which means that if you're already running the vpn agent you don't need to separately run the l3 agent? Or is this a mistake which means this bug needs to be reopened?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

On 01/05/14 02:01, Tom Verdaat wrote:
> Does the vpn agent provide a superset of functionality which means
> that if you're already running the vpn agent you don't need to
> separately run the l3 agent? Or is this a mistake which means this
> bug needs to be reopened?

That's correct - if you try to run both at the same time they end up
confusing each other.

- --
James Page
Ubuntu and Debian Developer
<email address hidden>
<email address hidden>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJTZsT9AAoJEL/srsug59jDv5oQANLLsoI3bD3TlajjAqvqlKHp
mzWJaiPOLwkh+i2ndXX60vgICDM6VFLBIhwXevXGwAF5yZXdoKUJS3NHOQ296g2i
JdyEFO4sP0kPSl2d3V3yAT/EDEkTwyFhP74aCxke8XhMCS1bx46IoEGWRnHkCZmq
WhwDLjQKXRcRR1A97/IMfvLKG0zI46HcL7m8yvigUl1R8EddhxfNI/2yxBTg8xu9
t0sqzJkQvSIZHOG+VtpyMfPXHg4acF3heeTvMBVQuHateuS4Ldqrt8AJGIsGxmTT
DjwZdRpF7dq9ujh4pG6EdoFFGV+0hKYh2am3FbnoCXakWxxs/3DMx/M90N61Kwqr
cxzAVG7gL12PA/07V1ECwKWx0ITZSrmI873xFKzaD3QuwtUy1ITF09SUaveyL7YD
wx3lUYYdAfjiLTVFfriAzcX7ycF7a/bkpPbDckXLLprT3dNMUz2tdd+bRzfns5Z5
nlq19L3XeUigEyYJNKRD5Gm1gLLV4FBtt4l4bIN4NDhfsNiiBLAIKAJsx3c4ThxJ
fHaaD18S9ytG+TfjBntNuR1P1sTFYdIQDd126qhqdYEF2o+8XlAxgp1Aojl0zOGH
sNeXYhW2GSi5osfkEXly42rzRIVvlCK1i7c1KVnxRjPPf6lsISVd5TufOjB1r2Lx
BJfRCMz+KThKguiYeVhT
=7p0Y
-----END PGP SIGNATURE-----

Rolf Leggewie (r0lf) wrote :

saucy has seen the end of its life and is no longer receiving any updates. Marking the saucy task for this ticket as "Won't Fix".

Changed in neutron (Ubuntu Saucy):
status: Triaged → Won't Fix
James Page (james-page) on 2015-03-24
Changed in cloud-archive:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers