lbaas haproxy "backend has no server available" spamming terminal via systemd

Bug #1738122 reported by Drew Freiberger on 2017-12-14
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenStack neutron-api charm
Undecided
Unassigned
OpenStack neutron-gateway charm
Undecided
Unassigned
neutron-lbaas (Ubuntu)
Low
Unassigned

Bug Description

We are finding the haproxy for lbaas agents that are in a state of not having instances related to them on the backend are spamming user ssh terminals.

This should be sufficient to be in haproxy logs. It makes it very difficult to work on the units.

Settings in n-gw charm are

jujumanage@cmg01z00infr001:~$ juju config neutron-gateway debug
true
jujumanage@cmg01z00infr001:~$ juju config neutron-gateway verbose
false

I wonder if debug is sending to STDERR as well as the log. Even so, I'd rather systemd be configured to not forward that on to terminals.

Please see http://pastebin.ubuntu.com/26180641/ for details of related processes running and messages from systemd-journald.

Running on xenial
python-neutron-lbaas 2:10.0.1-0ubuntu1~cloud0
haproxy 1.6.3-1ubuntu0.1

17.08 charms

James Page (james-page) on 2018-01-04
Changed in charm-neutron-gateway:
status: New → Invalid
Changed in charm-neutron-api:
status: New → Invalid
Changed in neutron (Ubuntu):
status: New → Triaged
importance: Undecided → Low
affects: neutron (Ubuntu) → neutron-lbaas (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers