neutron-lbaas-agent package does not provide neutron_lbaas.conf file

Bug #1460228 reported by Colleen Murphy on 2015-05-29
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Undecided
Unassigned
Kilo
Undecided
David Della Vecchia
neutron-lbaas (Ubuntu)
High
James Page
Vivid
High
Unassigned
Wily
High
James Page

Bug Description

Description of the problem:

The neutron release notes for OpenStack Kilo (https://wiki.openstack.org/wiki/ReleaseNotes/Kilo) indicate that individual neutron plugin packages are supposed to provide their own /etc/neutron/neutron_*.conf files, and each will specify their own service_provider options. The neutron-vpn-agent package provides /etc/neutron/neutron_vpnaas.conf, as expected. The neutron-lbaas-agent package does not provide /etc/neutron/neutron_lbaas.conf or anything similar.

Impact:

Attempting to use the lbaas plugin by specifying lbaas as one of the DEFAULT/service_plugins values results in neutron-server being unable to start correctly, with the following error in the log:

ERROR neutron.services.service_base [-] No providers specified for 'LOADBALANCER' service, exiting

The workaround is to add /etc/neutron/neutron_lbaas.conf with the content

[service_providers]
service_provider=LOADBALANCER:Haproxy:neutron_lbaas.services.loadbalancer.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default

An alternative workaround is to add this section to /etc/neutron/neutron.conf, but then this also requires moving the analogous parameter from /etc/neutron/neutron_vpnaas.conf into /etc/neutron/neutron.conf, or neutron fails with a different error about the VPN service.

Expected behavior:

/etc/neutron/neutron_lbaas.conf exists, contains default content:

[service_providers]
service_provider=LOADBALANCER:Haproxy:neutron_lbaas.services.loadbalancer.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default

Actual behavior:

/etc/neutron/neutron_lbaas.conf does not exist, and neutron-server won't start if lbaas is specified as a service_plugin.

Steps to reproduce:

1) Install neutron-server
2) Install neutron-lbaas-agent
3) Add 'lbaas' as one of the values for the parameter DEFAULT/service_plugins in /etc/neutron/neutron.conf
4) Restart neutron-server

System information:

# lsb_release -rd
Description: Ubuntu 14.04.2 LTS
Release: 14.04

# apt-cache policy neutron-lbaas-agent
neutron-lbaas-agent:
  Installed: 1:2015.1.0-0ubuntu1~cloud0

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in neutron-lbaas (Ubuntu):
status: New → Confirmed
cooldharma06 (cooldharma06) wrote :

i tried openstack with puppet-openstack in current github. i facing the same error.

James Page (james-page) on 2015-07-24
Changed in neutron-lbaas (Ubuntu):
importance: Undecided → High
status: Confirmed → In Progress
assignee: nobody → James Page (james-page)
Changed in neutron-lbaas (Ubuntu Vivid):
importance: Undecided → High
status: New → Triaged
James Page (james-page) wrote :

I've added the missing configuration files to the agent package; however, this would not normally be installed on the same server as the neutron-server daemon, so I'm not sure that this is a complete fix.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron-lbaas - 2:7.0.0~b1-0ubuntu4

---------------
neutron-lbaas (2:7.0.0~b1-0ubuntu4) wily; urgency=medium

  * d/neutron-lbaas-agent.install: Install missing configuration files
    (LP: #1460228).

 -- James Page <email address hidden> Fri, 24 Jul 2015 12:18:34 +0100

Changed in neutron-lbaas (Ubuntu Wily):
status: In Progress → Fix Released
Simon Leinen (simon-leinen) wrote :

Any chance to get this backported to the Ubuntu Cloud Archive (Kilo version) for trusty?

Simon Leinen (simon-leinen) wrote :

This also concerns the Ubuntu Cloud Archive (Kilo version)

Changed in cloud-archive:
status: New → Invalid
Changed in neutron-lbaas (Ubuntu Vivid):
status: Triaged → Won't Fix

Hello Colleen, or anyone else affected,

Accepted neutron-lbaas into kilo-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:kilo-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-kilo-needed to verification-kilo-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-kilo-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-kilo-needed
tags: added: verification-kilo-done
removed: verification-kilo-needed

The verification of the Stable Release Update for neutron-lbaas has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) wrote :

This bug was fixed in the package neutron-lbaas - 1:2015.1.4-0ubuntu2
---------------

 neutron-lbaas (1:2015.1.4-0ubuntu2) trusty-kilo; urgency=medium
 .
   * d/neutron-lbaas-agent.install: Install missing configuration files
     (LP: #1460228).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers