Activity log for bug #1842690

Date Who What changed Old value New value Message
2019-09-04 15:50:50 James Page bug added bug
2019-09-04 15:51:00 James Page nominated for series Ubuntu Eoan
2019-09-04 15:51:00 James Page bug task added networking-mlnx (Ubuntu Eoan)
2019-09-04 15:51:00 James Page nominated for series Ubuntu Disco
2019-09-04 15:51:00 James Page bug task added networking-mlnx (Ubuntu Disco)
2019-09-05 07:16:38 James Page description networking-mlnx provides a neutron mechanism driver for the neutron ML2 plugin as part of OpenStack networking. The versioning of this project tracks that of neutron i.e. they need to be major version aligned. Due to the fact that this package has been a sync from Debian for the last N releases, its always been one major release behind the version of Neutron shipped in the same Ubuntu release. The Mellanox team have requested that we update to correct this misalignment. networking-mlnx provides a neutron mechanism driver for the neutron ML2 plugin as part of OpenStack networking. The versioning of this project tracks that of neutron i.e. they need to be major version aligned. Due to the fact that this package has been a sync from Debian for the last N releases, its always been one major release behind the version of Neutron shipped in the same Ubuntu release. The Mellanox team have requested that we update to correct this misalignment. disco: 14.0.0 eoan: 15.0.0~ (snapshot)
2019-09-05 07:17:55 James Page bug task added cloud-archive
2019-09-05 07:18:03 James Page nominated for series cloud-archive/stein
2019-09-05 07:18:03 James Page bug task added cloud-archive/stein
2019-09-05 07:18:03 James Page nominated for series cloud-archive/train
2019-09-05 07:18:03 James Page bug task added cloud-archive/train
2019-09-05 08:24:54 James Page nominated for series cloud-archive/rocky
2019-09-05 08:24:54 James Page bug task added cloud-archive/rocky
2019-09-05 08:30:32 James Page description networking-mlnx provides a neutron mechanism driver for the neutron ML2 plugin as part of OpenStack networking. The versioning of this project tracks that of neutron i.e. they need to be major version aligned. Due to the fact that this package has been a sync from Debian for the last N releases, its always been one major release behind the version of Neutron shipped in the same Ubuntu release. The Mellanox team have requested that we update to correct this misalignment. disco: 14.0.0 eoan: 15.0.0~ (snapshot) networking-mlnx provides a neutron mechanism driver for the neutron ML2 plugin as part of OpenStack networking. The versioning of this project tracks that of neutron i.e. they need to be major version aligned. Due to the fact that this package has been a sync from Debian for the last N releases, its always been one major release behind the version of Neutron shipped in the same Ubuntu release. The Mellanox team have requested that we update to correct this misalignment. bionic/queens: 12.1.0 rocky: 13.1.0 disco/stein: 14.0.0 eoan/train: 15.0.0~ (snapshot)
2019-09-05 08:48:09 Launchpad Janitor networking-mlnx (Ubuntu Eoan): status New Fix Released
2019-09-06 10:52:05 James Page nominated for series Ubuntu Bionic
2019-09-06 10:52:05 James Page bug task added networking-mlnx (Ubuntu Bionic)
2019-09-06 10:52:13 James Page networking-mlnx (Ubuntu Bionic): status New Triaged
2019-09-06 10:52:15 James Page networking-mlnx (Ubuntu Disco): status New Triaged
2019-09-06 10:52:17 James Page cloud-archive/stein: status New Triaged
2019-09-06 10:52:19 James Page cloud-archive/rocky: status New Triaged
2019-09-06 10:52:27 James Page cloud-archive/train: status New Triaged
2019-09-06 10:52:31 James Page networking-mlnx (Ubuntu Eoan): importance Undecided High
2019-09-06 10:52:32 James Page networking-mlnx (Ubuntu Disco): importance Undecided High
2019-09-06 10:52:34 James Page networking-mlnx (Ubuntu Bionic): importance Undecided Wishlist
2019-09-06 10:52:38 James Page cloud-archive/rocky: importance Undecided Wishlist
2019-09-06 10:52:40 James Page cloud-archive/stein: importance Undecided High
2019-09-06 10:52:42 James Page cloud-archive/train: importance Undecided High
2019-09-06 10:52:54 James Page description networking-mlnx provides a neutron mechanism driver for the neutron ML2 plugin as part of OpenStack networking. The versioning of this project tracks that of neutron i.e. they need to be major version aligned. Due to the fact that this package has been a sync from Debian for the last N releases, its always been one major release behind the version of Neutron shipped in the same Ubuntu release. The Mellanox team have requested that we update to correct this misalignment. bionic/queens: 12.1.0 rocky: 13.1.0 disco/stein: 14.0.0 eoan/train: 15.0.0~ (snapshot) networking-mlnx provides a neutron mechanism driver for the neutron ML2 plugin as part of OpenStack networking. The versioning of this project tracks that of neutron i.e. they need to be major version aligned. Due to the fact that this package has been a sync from Debian for the last N releases, its always been one major release behind the version of Neutron shipped in the same Ubuntu release. The Mellanox team have requested that we update to correct this misalignment. bionic/queens: 12.3.0 rocky: 13.2.0 disco/stein: 14.0.0 eoan/train: 15.0.0~ (snapshot)
2019-09-06 10:53:10 James Page summary [SRU] version misaligned with OpenStack Release [SRU] networking-mlnx version misaligned with OpenStack Release
2019-09-06 10:55:18 James Page networking-mlnx (Ubuntu Eoan): assignee James Page (james-page)
2019-09-06 10:55:20 James Page networking-mlnx (Ubuntu Disco): assignee James Page (james-page)
2019-09-06 10:55:21 James Page networking-mlnx (Ubuntu Bionic): assignee James Page (james-page)
2019-09-06 10:55:23 James Page cloud-archive/train: assignee James Page (james-page)
2019-09-06 10:55:25 James Page cloud-archive/stein: assignee James Page (james-page)
2019-09-06 10:55:26 James Page cloud-archive/rocky: assignee James Page (james-page)
2019-09-12 08:40:10 James Page description networking-mlnx provides a neutron mechanism driver for the neutron ML2 plugin as part of OpenStack networking. The versioning of this project tracks that of neutron i.e. they need to be major version aligned. Due to the fact that this package has been a sync from Debian for the last N releases, its always been one major release behind the version of Neutron shipped in the same Ubuntu release. The Mellanox team have requested that we update to correct this misalignment. bionic/queens: 12.3.0 rocky: 13.2.0 disco/stein: 14.0.0 eoan/train: 15.0.0~ (snapshot) networking-mlnx provides a neutron mechanism driver for the neutron ML2 plugin as part of OpenStack networking. The versioning of this project tracks that of neutron i.e. they need to be major version aligned. Due to the fact that this package has been a sync from Debian for the last N releases, its always been one major release behind the version of Neutron shipped in the same Ubuntu release. The Mellanox team have requested that we update to correct this misalignment. bionic/queens: 12.4.0 rocky: 13.3.0 disco/stein: 14.0.1 eoan/train: 15.0.0~ (snapshot)
2019-09-16 13:47:52 James Page description networking-mlnx provides a neutron mechanism driver for the neutron ML2 plugin as part of OpenStack networking. The versioning of this project tracks that of neutron i.e. they need to be major version aligned. Due to the fact that this package has been a sync from Debian for the last N releases, its always been one major release behind the version of Neutron shipped in the same Ubuntu release. The Mellanox team have requested that we update to correct this misalignment. bionic/queens: 12.4.0 rocky: 13.3.0 disco/stein: 14.0.1 eoan/train: 15.0.0~ (snapshot) [Impact] Mellanox networking plugin for Neutron is not installable or has mismatched versions on several Ubuntu and UCA releases [Test Case] sudo apt install python{3}-networking-mlnx [no installation candidate] [Regression Potential] Low; package was removed from bionic and disco so is not currently installable; Upstream release versions have been verified by upstream development team. [Original Bug Report] networking-mlnx provides a neutron mechanism driver for the neutron ML2 plugin as part of OpenStack networking. The versioning of this project tracks that of neutron i.e. they need to be major version aligned. Due to the fact that this package has been a sync from Debian for the last N releases, its always been one major release behind the version of Neutron shipped in the same Ubuntu release. The Mellanox team have requested that we update to correct this misalignment. bionic/queens: 12.4.0 rocky: 13.3.0 disco/stein: 14.0.1 eoan/train: 15.0.0~ (snapshot)
2019-09-16 13:52:10 James Page bug added subscriber Ubuntu Stable Release Updates Team
2019-09-27 22:21:17 Steve Langasek networking-mlnx (Ubuntu Disco): status Triaged Incomplete
2019-10-07 13:18:24 James Page attachment added MellanoxTestPlanForUbuntu_v1.0.pdf https://bugs.launchpad.net/ubuntu/+source/networking-mlnx/+bug/1842690/+attachment/5295140/+files/MellanoxTestPlanForUbuntu_v1.0.pdf
2019-10-07 13:18:53 James Page description [Impact] Mellanox networking plugin for Neutron is not installable or has mismatched versions on several Ubuntu and UCA releases [Test Case] sudo apt install python{3}-networking-mlnx [no installation candidate] [Regression Potential] Low; package was removed from bionic and disco so is not currently installable; Upstream release versions have been verified by upstream development team. [Original Bug Report] networking-mlnx provides a neutron mechanism driver for the neutron ML2 plugin as part of OpenStack networking. The versioning of this project tracks that of neutron i.e. they need to be major version aligned. Due to the fact that this package has been a sync from Debian for the last N releases, its always been one major release behind the version of Neutron shipped in the same Ubuntu release. The Mellanox team have requested that we update to correct this misalignment. bionic/queens: 12.4.0 rocky: 13.3.0 disco/stein: 14.0.1 eoan/train: 15.0.0~ (snapshot) [Impact] Mellanox networking plugin for Neutron is not installable or has mismatched versions on several Ubuntu and UCA releases [Test Case] See attachment for test plan provided by Mellanox team. [Regression Potential] Low; package was removed from bionic and disco so is not currently installable; Upstream release versions have been verified by upstream development team. [Original Bug Report] networking-mlnx provides a neutron mechanism driver for the neutron ML2 plugin as part of OpenStack networking. The versioning of this project tracks that of neutron i.e. they need to be major version aligned. Due to the fact that this package has been a sync from Debian for the last N releases, its always been one major release behind the version of Neutron shipped in the same Ubuntu release. The Mellanox team have requested that we update to correct this misalignment. bionic/queens: 12.4.0 rocky: 13.3.0 disco/stein: 14.0.1 eoan/train: 15.0.0~ (snapshot)
2019-10-11 16:46:16 James Page cloud-archive: status Triaged Fix Committed
2019-10-11 16:46:41 James Page cloud-archive/train: status Triaged Fix Committed
2019-10-11 20:43:46 James Page cloud-archive/train: status Fix Committed Fix Released
2019-10-11 20:43:51 James Page networking-mlnx (Ubuntu Disco): status Incomplete Triaged
2019-10-11 20:44:04 James Page cloud-archive/stein: status Fix Committed Triaged
2019-11-04 09:19:17 James Page cloud-archive: status Triaged Fix Released
2019-11-22 11:07:12 Timo Aaltonen networking-mlnx (Ubuntu Disco): status Triaged Fix Committed
2019-11-22 11:07:15 Timo Aaltonen bug added subscriber SRU Verification
2019-11-22 11:07:19 Timo Aaltonen tags verification-needed verification-needed-disco
2019-11-25 12:52:55 James Page cloud-archive/stein: status Triaged Fix Committed
2019-11-25 12:52:58 James Page tags verification-needed verification-needed-disco verification-needed verification-needed-disco verification-stein-needed
2019-11-25 15:51:23 James Page cloud-archive/rocky: status Triaged Fix Committed
2019-11-25 15:51:25 James Page tags verification-needed verification-needed-disco verification-stein-needed verification-needed verification-needed-disco verification-rocky-needed verification-stein-needed