[SRU] Update to networking-l2gw 11.0.0 for Pike

Bug #1737040 reported by Corey Bryant
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Undecided
Unassigned
Pike
Medium
Unassigned
networking-l2gw (Ubuntu)
Undecided
Unassigned
Artful
Medium
Unassigned

Bug Description

[Impact]
Update networking-l2gw in Artful to the correct version for Pike.
This turns out to be a very minor update to d/control dependencies and officially get the package to version 11.0.0. We have customers asking for this. The prior version was a git snapshot on top of 10.1.0.a2, which was actually very close to 11.0.0.

[Test Case]
The following SRU process was followed:
https://wiki.ubuntu.com/OpenStackUpdates

In order to avoid regression of existing consumers, the OpenStack team will run their continuous integration test against the packages that are in -proposed. A successful run of all available tests will be required before the proposed packages can be let into -updates.

The OpenStack team will be in charge of attaching the output summary of the executed tests. The OpenStack team members will not mark ‘verification-done’ until this has happened.

[Regression Potential]
In order to mitigate the regression potential, the results of the
aforementioned tests are attached to this bug.

[Discussion]

description: updated
description: updated
description: updated
no longer affects: networking-l2gw
Changed in networking-l2gw (Ubuntu):
status: New → Invalid
no longer affects: networking-l2gw
description: updated
description: updated
Changed in cloud-archive:
status: New → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package networking-l2gw - 1:11.0.0-0ubuntu3

---------------
networking-l2gw (1:11.0.0-0ubuntu3) bionic; urgency=medium

  * d/rules, d/control: Switch to using stestr to run tests.
  * d/p/replace-deprecated-self.is_agent_down.patch: Cherry-pick patch from
    upstream master to replace deprecated self.is_agent_down.

 -- Corey Bryant <email address hidden> Thu, 07 Dec 2017 18:03:13 -0500

Changed in networking-l2gw (Ubuntu):
status: Invalid → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in networking-l2gw (Ubuntu Artful):
status: New → Confirmed
Revision history for this message
Corey Bryant (corey.bryant) wrote :

This has been uploaded to the unapproved queue for artful and is awaiting SRU team review: https://launchpad.net/ubuntu/artful/+queue?queue_state=1&queue_text=

Changed in networking-l2gw (Ubuntu Artful):
importance: Undecided → Medium
status: Confirmed → Triaged
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Corey, or anyone else affected,

Accepted networking-l2gw into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/networking-l2gw/1:11.0.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in networking-l2gw (Ubuntu Artful):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-artful
Revision history for this message
Corey Bryant (corey.bryant) wrote :

Hello Corey, or anyone else affected,

Accepted networking-l2gw into pike-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:pike-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-pike-needed to verification-pike-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-pike-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-pike-needed
Revision history for this message
Billy Olsen (billy-olsen) wrote :

I have received confirmation from users affected that the version of the package in the -proposed repositories work and function as expected.

tags: added: verification-done verification-needed-done verification-pike-done
removed: verification-needed verification-needed-artful verification-pike-needed
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote : Reminder of SRU verification policy change

Thank you for taking the time to verify this stable release fix. We have noticed that you have used the verification-done tag for marking the bug as verified and would like to point out that due to a recent change in SRU bug verification policy fixes now have to be marked with per-release tags (i.e. verification-done-$RELEASE). Please remove the verification-done tag and add one for the release you have tested the package in. Thank you!

https://wiki.ubuntu.com/StableReleaseUpdates#Verification

tags: added: sts verification-artful-done
removed: verification-done verification-needed-done
tags: added: verification-done-artful verification-done-pike
removed: verification-artful-done verification-pike-done
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package networking-l2gw - 1:11.0.0-0ubuntu1

---------------
networking-l2gw (1:11.0.0-0ubuntu1) artful; urgency=medium

  * d/gbp.conf: Create stable/pike branch.
  * New upstream release for OpenStack Pike (LP: #1737040).
  * d/control: Align (Build-)Depends with upstream.

 -- Corey Bryant <email address hidden> Thu, 07 Dec 2017 09:55:32 -0500

Changed in networking-l2gw (Ubuntu Artful):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for networking-l2gw has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for networking-l2gw has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package networking-l2gw - 1:11.0.0-0ubuntu1~cloud0
---------------

 networking-l2gw (1:11.0.0-0ubuntu1~cloud0) xenial-pike; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 networking-l2gw (1:11.0.0-0ubuntu1) artful; urgency=medium
 .
   * d/gbp.conf: Create stable/pike branch.
   * New upstream release for OpenStack Pike (LP: #1737040).
   * d/control: Align (Build-)Depends with upstream.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers