[SRU] Fix unit tests mtu failure for ussuri

Bug #1895059 reported by Corey Bryant
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
networking-arista (Ubuntu)
Undecided
Unassigned
Focal
High
Unassigned

Bug Description

[Impact]
Unit tests executed by the package build will fail for stable/ussuri due to a missing mtu patch that has landed in the upstream stable/ussuri branch but hasn't yet been included in a stable point release.

[Test Case]
Building the package will execute unit tests and they will not be successful unless this patch is applied.

[Regression Potential]
There is no potential of this causing a regression to the run-time code for this package as the patch only touches unit test code.

Changed in networking-arista (Ubuntu Focal):
importance: Undecided → High
status: New → Triaged
Changed in networking-arista (Ubuntu):
status: New → Invalid
status: Invalid → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Corey, or anyone else affected,

Accepted networking-arista into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/networking-arista/2019.2.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in networking-arista (Ubuntu Focal):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
Corey Bryant (corey.bryant) wrote :
tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package networking-arista - 2019.2.3-0ubuntu1

---------------
networking-arista (2019.2.3-0ubuntu1) focal; urgency=medium

  * d/gbp.conf: Create stable/ussuri branch.
  * d/watch: Update path to pypi artifact.
  * d/p/fix-attribute-error-on-select-poll.patch: Fix AttributeError on
    select.poll() (LP: #1889396).
  * New stable point release for OpenStack Ussuri (LP: #1888693).
  * d/p/update-create-network-test-wrapper-to-set-mtu-as-145.patch:
    Fix unit tests failing due to requested MTU too big (LP: #1895059).

 -- Corey Bryant <email address hidden> Wed, 09 Sep 2020 16:50:32 -0400

Changed in networking-arista (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for networking-arista has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers