[SRU] networking-arista version re-alignment

Bug #1888693 reported by James Page
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Undecided
Unassigned
Queens
High
Unassigned
Stein
High
Unassigned
Train
High
Unassigned
Ussuri
High
Unassigned
Victoria
Undecided
Unassigned
networking-arista (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Focal
High
Unassigned
Groovy
Undecided
Unassigned

Bug Description

[Impact]
The versions of networking-arista in Ubuntu releases are not aligned to the associated OpenStack Release:

bionic: Queens - 2018.1.16
focal: Ussuri - no release tag but stable/ussuri branch exists
groovy: Victoria - snapshot required

and for the UCA

bionic/stein: 2019.1.9
bionic/train: 2019.2.3
bionic/ussuri: 2019.2.3 (this is still the latest tagged release)

[Test Case]
charm-neutron-api-plugin-arista's Zaza tests: https://opendev.org/openstack/charm-neutron-api-plugin-arista/src/branch/master/src/tests

These tests deploy OpenStack with networking-arista for all supported Ubuntu series and OpenStack releases, and validate that when creating/deleting Neutron networks, they also appear/disappear on the associated Arista test fixture.

[Regression Potential]
This update essentially only includes the following updates:
 - [df37db8] Reduce info level logging output
 - [5ea0b08] Fix handling of ERROR ports and '' device_id
 - [5843ba4] Test routes are not deleted on sync

df37db8 shouldn't have much of an effect, of course an error in any of the logs could result in an unhandled python exception occurring
5ea0b08 changes logic around when ports get deleted, it looks correct but a regression in this code could result in a network port getting deleted when it shouldn't have
5843ba4 is only updating tests

Revision history for this message
James Page (james-page) wrote :

groovy had a snapshot at the start of July - however depending on the version tag for stable/ussuri we made need to revision this up to 2020.2.0~git

networking-arista (2019.2.4~git2020070613.c35fef5-0ubuntu1) groovy; urgency=medium

  * New upstream snapshot for OpenStack Victoria.
  * d/control: Align (Build-)Depends with upstream.
  * d/control: Update Vcs-* and Homepage.
  * d/control, d/compat: Switch to debhelper compat 12.
  * d/control: Update Standards-Version to 4.5.0.

 -- Corey Bryant <email address hidden> Mon, 06 Jul 2020 13:49:22 -0400

Revision history for this message
Corey Bryant (corey.bryant) wrote :

For ussuri, the latest upstream tag is 2019.2.3. That includes everything from stable/ussuri except for the following (note that we're going to pick up 8bc04050 via LP: #1889396:

commit 8bc04050a8ca06d2930076d0955e771bed27dae3 (HEAD -> stable/ussuri, origin/stable/ussuri)
Author: Aurelien Lourot <email address hidden>
Date: Wed Jul 29 13:52:44 2020 +0200

    Fix AttributeError on select.poll()

    Change-Id: Iefcae89cdedd13535c3135ca7227362f1cf9abc8
    Closes-Bug: #1889396
    Co-Authored-By: Mitchell Jameson <email address hidden>

commit 108842d962eeb344bcd523f4502a1c825cd5c419
Author: Mitchell Jameson <email address hidden>
Date: Wed Aug 12 16:28:32 2020 -0700

    Encode special characters in CVX username and password

    Change-Id: I2f147ab44e7124675dd31a1a5b780ac00f51dc54
    (cherry picked from commit 58eadd002e95a2102be174675aed81514f9e624c)

Revision history for this message
Corey Bryant (corey.bryant) wrote :

I've reached out to the upstream maintainer to see if he can cut some new stable releases and to ask him if he can time a victoria release with the openstack victoria final release.

description: updated
description: updated
description: updated
Revision history for this message
Corey Bryant (corey.bryant) wrote :

Uploaded to focal unapproved queue, train-staging and stein-staging.

Changed in networking-arista (Ubuntu Groovy):
status: New → Fix Released
Changed in networking-arista (Ubuntu Focal):
importance: Undecided → High
status: New → Triaged
Changed in networking-arista (Ubuntu Bionic):
status: New → Won't Fix
description: updated
description: updated
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello James, or anyone else affected,

Accepted networking-arista into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/networking-arista/2019.2.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in networking-arista (Ubuntu Focal):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
Corey Bryant (corey.bryant) wrote :

Hello James, or anyone else affected,

Accepted networking-arista into ussuri-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:ussuri-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-ussuri-needed to verification-ussuri-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-ussuri-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-ussuri-needed
Revision history for this message
Corey Bryant (corey.bryant) wrote :

Hello James, or anyone else affected,

Accepted networking-arista into train-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:train-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-train-needed to verification-train-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-train-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-train-needed
Revision history for this message
Corey Bryant (corey.bryant) wrote :

Hello James, or anyone else affected,

Accepted networking-arista into stein-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:stein-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-stein-needed to verification-stein-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-stein-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-stein-needed
Revision history for this message
Aurelien Lourot (aurelien-lourot) wrote :

I confirm that what's currently in focal-proposed, ussuri-proposed, train-proposed and stein-proposed fixes the bug.

Validated with https://github.com/openstack-charmers/zaza-openstack-tests/blob/master/zaza/openstack/charm_tests/neutron_arista/tests.py , which is a test deploying an OpenStack (including Neutron with this plugin), creating/deleting networks and verifying that the networks appear/disappear on the Arista eAPI.

Removing the need for my PPAs in our Zaza tests: https://review.opendev.org/752379

tags: added: verification-done verification-done-focal verification-done-needed
removed: verification-needed verification-needed-focal verification-stein-needed verification-train-needed verification-ussuri-needed
tags: added: verification-done-stein verification-done-train verification-done-ussuri
removed: verification-done-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package networking-arista - 2019.2.3-0ubuntu1

---------------
networking-arista (2019.2.3-0ubuntu1) focal; urgency=medium

  * d/gbp.conf: Create stable/ussuri branch.
  * d/watch: Update path to pypi artifact.
  * d/p/fix-attribute-error-on-select-poll.patch: Fix AttributeError on
    select.poll() (LP: #1889396).
  * New stable point release for OpenStack Ussuri (LP: #1888693).
  * d/p/update-create-network-test-wrapper-to-set-mtu-as-145.patch:
    Fix unit tests failing due to requested MTU too big (LP: #1895059).

 -- Corey Bryant <email address hidden> Wed, 09 Sep 2020 16:50:32 -0400

Changed in networking-arista (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for networking-arista has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for networking-arista has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package networking-arista - 2019.2.3-0ubuntu0.19.10.1~cloud0
---------------

 networking-arista (2019.2.3-0ubuntu0.19.10.1~cloud0) bionic-train; urgency=medium
 .
   * d/gbp.conf: Create stable/train branch.
   * d/watch: Update path to pypi artifact.
   * d/p/fix-attribute-error-on-select-poll.patch: Fix AttributeError on
     select.poll() (LP: #1889396).
   * New stable point release for OpenStack Train (LP: #1888693).
   * d/control: Align (Build-)Depends with upstream.

Revision history for this message
Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for networking-arista has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package networking-arista - 2019.1.9-0ubuntu1~cloud0
---------------

 networking-arista (2019.1.9-0ubuntu1~cloud0) bionic-stein; urgency=medium
 .
   * d/gbp.conf: Create stable/stein branch and align with standard openstack gbp.conf.
   * d/watch: Update path to pypi artifact.
   * d/p/fix-attribute-error-on-select-poll.patch: Fix AttributeError on
     select.poll() (LP: #1889396).
   * New stable point release for OpenStack Stein (LP: #1888693).
   * d/control: Align (Build-)Depends with upstream.
   * d/p/skip-tests.patch: Skip tests that are failing in Ubuntu builds until
     upstream bug is resolved (LP: #1848239)

Revision history for this message
Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for networking-arista has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package networking-arista - 2019.2.3-0ubuntu1~cloud0
---------------

 networking-arista (2019.2.3-0ubuntu1~cloud0) bionic-ussuri; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 networking-arista (2019.2.3-0ubuntu1) focal; urgency=medium
 .
   * d/gbp.conf: Create stable/ussuri branch.
   * d/watch: Update path to pypi artifact.
   * d/p/fix-attribute-error-on-select-poll.patch: Fix AttributeError on
     select.poll() (LP: #1889396).
   * New stable point release for OpenStack Ussuri (LP: #1888693).
   * d/p/update-create-network-test-wrapper-to-set-mtu-as-145.patch:
     Fix unit tests failing due to requested MTU too big (LP: #1895059).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers