NM cannot connect to internet over 3G-modem; wvdial can -- ZTE MF190J

Bug #994651 reported by moma on 2012-05-04
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
NetworkManager
Expired
High
Usb Modeswitch Data
Fix Committed
Undecided
Unassigned
network-manager (Ubuntu)
Undecided
Unassigned
usb-modeswitch-data (Ubuntu)
Undecided
Unassigned

Bug Description

I have a 3G BroadBand modem from the Portuguese TMN.
Ref: http://tinyurl.com/7v6yvh9

Its modem type is ZTE MF190J.

I need to use it in my Ubuntu 12.04 laptop.

I have created a definition in the "Mobile Broadband". The definition is done by a wizard where I select "Portugal" and "TMN" and where I enter a PIN-code. Please see the picture.

The pen indicates a green light, but still, I cannot access the internet. And the network-applet icon switches off.

The config looks like this
http://bildr.no/view/1170463
and
http://bildr.no/view/1172725

One thing I noticed that Ubuntu first thinks that this USB-pin is a storage device (like a cdrom) and it mounts it to /media/ZTEMODEM. I have to "Eject" this mount point first, then Linux seemingly continues to load the driver. The light on the USB-pin turns red, then after 5 secs to green. The network applet says "Registered to your home network", then immediate after that "Modem network.. disconnected".

I know there is usb-modeswitch commmands that can disable the auto-mounting.

I have tested this same USB-pin (3G modem) on Windows and it work perfectly well.
I also used its Windows application to disabled the PIN code (just for testing).

Listing of:

$ lsusb
Bus 001 Device 004: ID 19d2:1542 ZTE WCDMA Technologies MSM
...

usb-devices listing before Eject / umount
$ usb-devices
T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 7 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=19d2 ProdID=1542 Rev=00.01
S: Manufacturer=ZTE
S: Product=MF190J
S: SerialNumber=9BB27BAF013DFB85103C397DCB576195 <snip>
C: #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage

usb-devices listing after Eject / umount.
§ usb-devices
T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 8 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=02(commc) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=19d2 ProdID=1544 Rev=00.01
S: Manufacturer=ZTE
S: Product=MF190J
S: SerialNumber=9BB27BAF013DFB85103C397DCB576195D <snip>
C: #Ifs= 7 Cfg#= 1 Atr=80 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 0 Cls=00(>ifc ) Sub=08 Prot=00 Driver=(none)
I: If#= 1 Alt= 0 #EPs= 1 Cls=02(commc) Sub=02 Prot=01 Driver=cdc_acm
I: If#= 2 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm
I: If#= 3 Alt= 0 #EPs= 1 Cls=02(commc) Sub=02 Prot=01 Driver=cdc_acm
I: If#= 4 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm
I: If#= 5 Alt= 0 #EPs= 1 Cls=02(commc) Sub=02 Prot=01 Driver=cdc_acm
I: If#= 6 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm

See also:
https://lists.ubuntu.com/archives/ubuntu-pt/2012-May/009503.html

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: network-manager 0.9.4.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
ApportVersion: 2.0.1-0ubuntu5
Architecture: i386
Date: Fri May 4 16:11:23 2012
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
IpRoute:
 default via 172.16.255.254 dev wlan0 proto static
 169.254.0.0/16 dev wlan0 scope link metric 1000
 172.16.255.0/24 dev wlan0 proto kernel scope link src 172.16.255.156 metric 2
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT READONLY DBUS-PATH
 Wired connection 1 2447729f-f59e-4bee-a65b-c802b62fd002 802-3-ethernet 1336140324 Fri 04 May 2012 03:05:24 PM WEST yes no /org/freedesktop/NetworkManager/Settings/2
 TMN Tmn Internet a33306a6-5465-464e-a642-415c82a4df00 gsm 0 never yes no /org/freedesktop/NetworkManager/Settings/1
 RCBP-PABL-WIFI 7bcd00e1-dcb7-48bd-b3d7-0ea8af39b60a 802-11-wireless 1336144265 Fri 04 May 2012 04:11:05 PM WEST yes no /org/freedesktop/NetworkManager/Settings/0
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 ttyACM1 gsm disconnected /org/freedesktop/NetworkManager/Devices/3
 eth0 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/1
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.4.0 connected enabled enabled enabled enabled enabled

moma (osmoma) wrote :
moma (osmoma) wrote :

Re-hello,
I have at least a partial or temporary solution.

This 3G-modem (ZTE MF190J) works now in Ubuntu-Linux.
It does not work with the ordinary network-manager, but it works fine with the "wvdial" command that I start from the command line.

Details in this thread:
http://ubuntuforums.org/showpost.php?p=11934679&postcount=16Ubuntu-

Notice:Ubuntu-
I had re-enabled the PIN-code in Windows, but still, the AT+CPIN command seems to fail.
# Init2 = AT+CPIN=1234
I do not know why.

Anyway, I have internet connection over this 3G-pen and that's the most important thing at the moment. Of course this matter needs more investigation till it works out-of-the-box in Linux. Just tell me how to help!

moma (osmoma) wrote :

An addition.
It also works with gnome-ppp (front-end to wvdial) and pppd. Pppd requires configuration. Afater that this 3G-modem (ZTE MF190J.) works perfectly well. But still, Ubuntu's network manager (or modem manager) cannot make connection.
Please see details in : http://ubuntuforums.org/showthread.php?p=11946543#post11946543

Thomas Hood (jdthood) wrote :

Hi. The ZTE MF190J isn't listed as supported by NetworkManager. Please submit a request for support to the upstream bug tracker.

    https://bugzilla.gnome.org/browse.cgi?product=NetworkManager

summary: - Cannot connect to internet over 3G-modem (ZTE MF190J)
+ NM cannot connect to internet over 3G-modem; wvdial can -- ZTE MF190J
Changed in network-manager (Ubuntu):
status: New → Invalid
moma (osmoma) wrote :

Ok, I did my best and added a bug-report to bugzilla.gnome.org:
https://bugzilla.gnome.org/show_bug.cgi?id=680545

Thomas Hood (jdthood) on 2012-07-24
Changed in network-manager (Ubuntu):
status: Invalid → New
Changed in network-manager:
importance: Unknown → High
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
moma (osmoma) wrote :

A small update.
This 3G-modem (ZTE MF190J) works well Ubuntu 12.10 (Quantal Quetzal). Only one thing needs manual intervention. I have to unmount (eject) it manually from the file manager or Ubuntu-icon. After that it connects well.

Step 2 of this thread shows how to prevent auto-mount.
http://ubuntuforums.org/showpost.php?p=11934679&postcount=16

Configuration with default values is sufficient.
http://bildr.no/view/1290763

Marius B. Kotsbak (mariusko) wrote :

Could you please discuss the switching of the modem here:

www.draisberghof.de/usb_modeswitch/bb/

Changed in usb-modeswitch-data (Ubuntu):
status: New → Confirmed
Marius B. Kotsbak (mariusko) wrote :

Could someone please raise this issue in the usb-modeswitch forum, it seems like config file for this device is missing:

http://www.draisberghof.de/usb_modeswitch/bb/

Hello,
I sent an issue to usb-modeswitch forum.
Ref:
http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?f=4&t=1100&p=7109

// Osmo Antero

On Tue, Oct 30, 2012 at 11:35 AM, Marius Kotsbak
<email address hidden>wrote:

> Could someone please raise this issue in the usb-modeswitch forum, it
> seems like config file for this device is missing:
>
> http://www.draisberghof.de/usb_modeswitch/bb/
>
>

Changed in usb-modeswitch-data:
status: New → Fix Committed
Changed in network-manager:
status: New → Incomplete
Changed in network-manager:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.