Ubuntu

Network Manager not reusing Wireless connections

Reported by Luis Alvarado on 2012-05-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

When I create a new wireless connection, for example "shared". After rebooting the shared connection does not appear in any of the wireless cards and I have to create it again. When I do create it again, in the wireless settings it appears as "Shared 1" and the first shared also appears there but does not appear when trying to create a new wireless connection again and it does not appear in any of the 2 wireless cards I have for quick selection.

Network Manager is not reusing the already created wireless connection.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: network-manager 0.9.4.0-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-24.38-generic-pae 3.2.16
Uname: Linux 3.2.0-24-generic-pae i686
NonfreeKernelModules: nvidia wl
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Thu May 3 22:45:48 2012
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
IpRoute:
 default via 186.93.224.1 dev eth1 proto static
 10.42.0.0/24 dev eth2 proto kernel scope link src 10.42.0.1 metric 2
 169.254.0.0/16 dev eth1 scope link metric 1000
 186.93.224.0/19 dev eth1 proto kernel scope link src 186.93.236.33 metric 1
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.NetworkManager.NetworkManager.conf: 2012-05-02T00:52:19.802934
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 wlan0 802-11-wireless disconnected /org/freedesktop/NetworkManager/Devices/3
 eth0 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/2
 eth2 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/1
 eth1 802-3-ethernet connected /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.4.0 connected enabled enabled enabled enabled disabled

Luis Alvarado (luisalvarado) wrote :
Thomas Hood (jdthood) wrote :

Is the wireless network for which you defined a wireless connection "hidden"?

Luis Alvarado (luisalvarado) wrote :

No is not hidden. In any case the problem has been fixed updating to the latest packages. Tested several times and eerything is working correctly again. Thank you.

Luis Alvarado (luisalvarado) wrote :

Fix has been commited in a previous update.

Changed in network-manager (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers