Ubuntu

"Error initialising editor" when editing properties of a mobile broadband connection

Reported by Bruno Girin on 2012-03-04
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
High
Mathieu Trudel-Lapierre
Precise
High
Mathieu Trudel-Lapierre

Bug Description

When wanting to edit the configuration of a mobile broadband connection, an error message appears:
Title: Error initialising editor
Text: nm-settings-connection.c.839 - Connection didn't have requested setting 'ppp'.
Note that this is a broadband connection that otherwise works perfectly well. See the attached screenshot for more details.

Steps to reproduce:
1. Open the network menu in the top panel,
2. Click on "Edit Connections..."
3. Select the "Mobile Broadband" tab
4. Select the first entry in the list
5. Click "Edit..."

Expected behaviour:
A dialog to update the connection settings opens.

Actual behaviour:
The error message described above is displayed.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: network-manager 0.9.2.0+git201202161854.8572ecf-0ubuntu5
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.94-0ubuntu1
Architecture: amd64
Date: Sun Mar 4 18:40:35 2012
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
IpRoute:
 default via 192.168.0.1 dev wlan0 proto static
 10.0.3.0/24 dev lxcbr0 proto kernel scope link src 10.0.3.1
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.0.0/24 dev wlan0 proto kernel scope link src 192.168.0.4 metric 2
 192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager
UpgradeStatus: Upgraded to precise on 2012-02-11 (22 days ago)
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 usb0 gsm disconnected /org/freedesktop/NetworkManager/Devices/3
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/1
 eth0 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.3.0 connected enabled enabled enabled enabled disabled

Bruno Girin (brunogirin) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

me too.

Changed in network-manager (Ubuntu):
importance: Undecided → High

The issue was identified, and will be fixed in the next upload (pending some changes in libnm-glib enums).

Changed in network-manager (Ubuntu Precise):
status: Confirmed → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)

network-manager - 0.9.3.995+git201203081848.bba834f-0ubuntu1~mtrudel2 has been uploaded to the ~ubuntu-desktop PPA; it will be build and become available in the next few hours. It would be helpful if those who are seeing this error could test this package: I've included a patch from upstream that appears to solve the issue; along with a bunch of additional changes that we want to land in Precise. See https://launchpad.net/~ubuntu-desktop/+archive/ppa

Please don't hesitate to report here with whether things work for you or not with that updated package :)

tags: added: rls-mgr-p-tracking

Forgot to fix this bug in the upload, this has already been fixed and is in precise.

Changed in network-manager (Ubuntu Precise):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers