laptop sometimes does not reset the eth0 after sleep

Bug #93576 reported by Eugenia Loli-Queru on 2007-03-19
12
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
High
Unassigned

Bug Description

My laptop has a BCM4401-B0 100Base-TX and it works ok. However, about once every 5 wake-ups from suspsend-to-ram, the network card is not "refreshing" itself. What I mean is that the ethernet can't connect, it's like the kernel does not properly reset the device and reload the driver after a wake up. Ifconfig eth0 up/down does not help, I need to restart the laptop to get eth0 back.

I can try rmmod the driver and modprobe it again if you tell me which one it is:
eugenia@inspiron:~$ lsmod
Module Size Used by
binfmt_misc 12808 1
rfcomm 40856 0
l2cap 25728 5 rfcomm
bluetooth 55908 4 rfcomm,l2cap
i915 24448 2
drm 80788 3 i915
acpi_cpufreq 10056 1
cpufreq_powersave 2688 0
cpufreq_userspace 5408 0
cpufreq_ondemand 9228 1
cpufreq_stats 7360 0
cpufreq_conservative 8200 0
freq_table 5792 3 acpi_cpufreq,cpufreq_ondemand,cpufreq_stats
sony_acpi 6284 0
pcc_acpi 13184 0
tc1100_wmi 8068 0
dev_acpi 12292 0
container 5248 0
asus_acpi 17308 0
sbs 15652 0
i2c_ec 5888 1 sbs
i2c_core 22784 1 i2c_ec
battery 10756 0
ac 6020 0
button 8720 0
video 16388 0
ipv6 268704 14
backlight 7040 1 asus_acpi
dock 10256 0
ndiswrapper 194608 0
nls_utf8 3072 2
ntfs 107764 2
nls_iso8859_1 5120 2
nls_cp437 6784 2
vfat 14080 2
fat 53916 1 vfat
sbp2 23812 0
parport_pc 36388 0
lp 12452 0
parport 36936 2 parport_pc,lp
fuse 46612 0
af_packet 23816 6
joydev 10816 0
snd_hda_intel 21784 1
snd_hda_codec 204416 1 snd_hda_intel
snd_pcm_oss 44544 0
snd_mixer_oss 17408 1 snd_pcm_oss
snd_pcm 79876 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy 4740 0
snd_seq_oss 32896 0
snd_seq_midi 9600 0
snd_rawmidi 25472 1 snd_seq_midi
snd_seq_midi_event 8448 2 snd_seq_oss,snd_seq_midi
iTCO_wdt 11812 0
iTCO_vendor_support 4868 1 iTCO_wdt
sdhci 19468 0
mmc_core 27780 1 sdhci
intel_agp 24988 1
agpgart 33480 3 drm,intel_agp
pcspkr 4224 0
serio_raw 7940 0
snd_seq 52592 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 23684 2 snd_pcm,snd_seq
snd_seq_device 9100 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 54020 12 snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
psmouse 38920 0
shpchp 34324 0
pci_hotplug 32576 1 shpchp
soundcore 8672 1 snd
snd_page_alloc 10888 2 snd_hda_intel,snd_pcm
tsdev 8768 0
evdev 11008 4
ext3 133128 1
jbd 59816 1 ext3
mbcache 9604 1 ext3
sg 36252 0
sr_mod 17060 0
cdrom 37664 1 sr_mod
sd_mod 22272 6
generic 5380 0 [permanent]
ata_generic 8708 0
ehci_hcd 34188 0
ohci1394 36528 0
ieee1394 298808 2 sbp2,ohci1394
b44 28044 0
mii 6528 1 b44
ata_piix 16132 5
libata 120220 2 ata_generic,ata_piix
scsi_mod 142348 5 sbp2,sg,sr_mod,sd_mod,libata
uhci_hcd 25228 0
usbcore 134280 4 ndiswrapper,ehci_hcd,uhci_hcd
thermal 14728 0
processor 31048 2 acpi_cpufreq,thermal
fan 5636 0
fbcon 42656 0
tileblit 3584 1 fbcon
font 9216 1 fbcon
bitblit 6912 1 fbcon
softcursor 3200 1 bitblit
vesafb 9220 0
capability 5896 0
commoncap 8192 1 capability

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. With which version of Ubuntu did you notice this issue? Thanks in advance.

Eugenia Loli-Queru (eloli) wrote :

Latest Feisty, updated daily.

Eugenia Loli-Queru (eloli) wrote :

Even after a cold boot it doesn't work and I have to manually reset it. Apparently others did not have this problem with older kernels with the same kind of laptop.

USB bluetooth adapters don't seem to have the problem. But this is a mini-PCI card inside the laptop and it seems to not get initialized correctly each time.

eppy 1 (choppy121212) wrote :

In response to "I can try rmmod the driver and modprobe it again if you tell me which one it is:" I think your network/ethernet card module is "b44".

Eugenia Loli-Queru (eloli) wrote :

thanks, that was the one.

So, I rmmod it and then modprobed it again, but no cake. Ethernet just doesn't work about once every 10 wake ups. It is obviously a race condition.

Ben Collins (ben-collins) wrote :

Please attach dmesg output from a failed resume.

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-acpi
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Eugenia Loli-Queru (eloli) wrote :

dmesg included, although I had at least 5 wake ups since the networking card went dead so you might want to check the file in the beginning (I continued to use the laptop via wifi instead of bothering to reboot you see).

Tim Gardner (timg-tpi) wrote :

Please reboot and attach (do not inline) the output of the following commands:

lspci -vv > lspci.txt
dmesg > dmesg.txt
sudo dmidecode > dmidecode.txt

I assume the b44 driver works after a reboot? It certainly is not recovering from a suspend/resume cycle.

Changed in linux-source-2.6.20:
assignee: ubuntu-kernel-acpi → timg-tpi
status: Confirmed → Needs Info
Eugenia Loli-Queru (eloli) wrote :

Yes, the driver works after a reboot. More attached files below.

Eugenia Loli-Queru (eloli) wrote :
Eugenia Loli-Queru (eloli) wrote :
Tim Gardner (timg-tpi) on 2007-03-25
Changed in linux-source-2.6.20:
assignee: timg-tpi → ubuntu-kernel-acpi
status: Needs Info → Confirmed
Eugenia Loli-Queru (eloli) wrote :

Some information on bug #99267

I was able to reproduce the same bug with completely different hardware. It seems to be either a networkmanager or acpid bug.

eppy 1 (choppy121212) wrote :

I just installed Feisty Fawn and fully updated it.

I have this same issue with the 8139too driver, so it not just the b44 module. My desktop computer doesn't support suspend, but I do use 'hibernate', and every few times, eth0 doesn't reset and I rmmod/modprobe and ifup and ifdown don't give me internet or network access.

(uname -a provides: Linux COMPUTERNAME 2.6.20-13-generic #2 SMP Sun Mar 25 00:21:25 UTC 2007 i686 GNU/Linux )

eppy 1 (choppy121212) wrote :
Eugenia Loli-Queru (eloli) wrote :

Ok, I found how to get ethernet bug. I have to kill networkmanager and networkmanager-dispatcher. So, this is a networkmanager bug, and it happens on MANY laptops with completely different ethernet cards.

eppy 1 (choppy121212) wrote :

Killing those two processes (and nm-applet, just in case) solved the problem for me too. I could then do 'sudo ifup eth0' to get my network back.

before killing:
chris@promax:~$ sudo ifup eth0
ifup: interface eth0 already configured
$ sudo ifdown eth0
There is already a pid file /var/run/dhclient.eth0.pid with pid 17362
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:08:a1:5f:14:7b
Sending on LPF/eth0/00:08:a1:5f:14:7b
Sending on Socket/fallback
DHCPRELEASE on eth0 to 192.168.1.2 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
$ sudo ifdown eth0
ifdown: interface eth0 not configured
$ sudo ifdown eth0
ifdown: interface eth0 not configured
$ sudo ifup eth0
There is already a pid file /var/run/dhclient.eth0.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

after killing:
$ sudo ifup eth0
There is already a pid file /var/run/dhclient.eth0.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:08:a1:5f:14:7b
Sending on LPF/eth0/00:08:a1:5f:14:7b
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPOFFER from 192.168.1.2
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.2
bound to 192.168.1.101 -- renewal in 33169 seconds.

Eugenia Loli-Queru (eloli) wrote :

I was able to isolate the problem, it is the NetworkManager service that creates the problem (not the nm_applet or the dispatcher). Ubuntu developers, please try to reproduce, you should ship with this bug on Feisty, because it really drags down to the floor laptop support.

Changed in linux-source-2.6.20:
assignee: ubuntu-kernel-acpi → nobody
importance: Medium → High
Ohb01 (ohb01) wrote :

I have a similar problem with a wired (Ethernet) connection in Feisty on a Desktop. I will leave the details under Bug 45696 to avoid double-posting them.

Kuropka (d2) wrote :

Similar problem here on my Samsung Q20: Wired network interfaces always does not work after waking up from suspend to RAM, Wireless network interfaces sometimes also stop working after wake up.

Olivier (olivier-lacroix) wrote :

same here. I am experiencing this problem with wifi : ipw200 module on centrino dothan platform.

after suspend and resume, NetworkManager sometimes says "no card adapter found" or something like this. As if I hadn't any network card to be managed by NM. killing NetworkManager and relaunching it solve the problem.

Could this be due to a of launch of NetworkManager service on resume before the reinsertion of the network cards modules ? just a guess.

If you need any debug output, I will be glad to help.

Regards

Alexander Sack (asac) wrote :

can you please test with latest gutsy livecds?

Changed in network-manager:
status: Confirmed → Incomplete
Eugenia Loli-Queru (eloli) wrote :

This bug was fixed months ago. Close this bug.

Alexander Sack (asac) on 2007-09-22
Changed in network-manager:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers