no dns resolution when wireless connection is enabled by ubiquity

Bug #924998 reported by Jean-Baptiste Lallement on 2012-02-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

Ubuntu Desktop 20120201

TEST CASE
0. system requires a wireless card, and no network connection established (no wired connection, no configured wireless connection)
1. Boot to a live session and start ubiquity
2. On the wireless page select the wireless network you want to connect to, click on continue and enter the passphrase.
3. Wait for the connection to come-up
4. Open a terminal and run the command:
$ host www.ubuntu.com
=> Verify that the query fails
5. from n-m applet disable then reenable wireless
6. Run the same dns query
=> Verify that it succeeds

EXPECTED RESULT
DNS resolution should work when wireless is configured

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: network-manager 0.9.2.0+git201201101813.0b30200-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
Uname: Linux 3.2.0-12-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CRDA:
 country CH:
  (2402 - 2482 @ 40), (N/A, 20)
  (5170 - 5250 @ 40), (N/A, 20)
  (5250 - 5330 @ 40), (N/A, 20), DFS
  (5490 - 5710 @ 40), (N/A, 27), DFS
CasperVersion: 1.302
Date: Wed Feb 1 17:25:38 2012
IfupdownConfig:
 auto lo
 iface lo inet loopback
IpRoute:
 default via 192.168.0.1 dev wlan0 proto static
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.0.0/24 dev wlan0 proto kernel scope link src 192.168.0.36 metric 2
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120201)
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT READONLY DBUS-PATH
 ecrehou a4b8f8dd-06d9-4bdd-98ce-04f2a26ea911 802-11-wireless 1328119608 Wed 01 Feb 2012 06:06:48 PM UTC yes no /org/freedesktop/NetworkManager/Settings/1
 Wired connection 1 2aa0911e-ae07-4d4b-b826-89206c3ebeaf 802-3-ethernet 1328117917 Wed 01 Feb 2012 05:38:37 PM UTC yes no /org/freedesktop/NetworkManager/Settings/0
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 eth0 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/0
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/1
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.3.0 connected enabled enabled enabled enabled disabled

Jean-Baptiste Lallement (jibel) wrote :
tags: added: qa-manual-testing
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/924998

tags: added: iso-testing
tags: added: rls-mgr-p-tracking
Changed in network-manager (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High

Jean-Baptiste;

I'm unable to reproduce this bug with the daily-live image 20120314. Should we consider this fixed? Would you be able to re-test?

Changed in network-manager (Ubuntu Precise):
status: Triaged → Incomplete
Jean-Baptiste Lallement (jibel) wrote :

It works with Ubuntu Desktop 20120314 - Ubiquity 2.9.28

Changed in network-manager (Ubuntu Precise):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers