network-manager does not tell plymouth it has started

Bug #924836 reported by Jonathan Riddell on 2012-02-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
High
Canonical Desktop Team
Precise
High
Canonical Desktop Team
resolvconf (Ubuntu)
High
Canonical Foundations Team
Precise
High
Canonical Foundations Team

Bug Description

On installing Kubuntu alpha 2 candidates I have an error on first boot of the installed system. Plymouth says "waiting for network setup" or similar. I think network-manager is not telling plymouth it has started. By the the time the full system does start network-manager works fine.

Jean-Baptiste Lallement (jibel) wrote :

confirmed with Ubuntu Desktop.

Changed in network-manager (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in network-manager (Ubuntu Precise):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
tags: added: qa-manual-testing rls-mgr-p-tracking
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/924836

tags: added: iso-testing

I'm not entirely sure that's NetworkManager's job, but rather one of the other upstart jobs. Is this happening on all the installs or is it specific to alternate?

Jean-Baptiste Lallement (jibel) wrote :

it is not specific to alternate and reproducible with Desktop images.

NetworkManager indeed doesn't deal with this kind of signal, nor does it need to, AFAIK.

Reassigning to ifupdown, that's my best guess for what goes wrong (need to emit static-network-up AFAICT, as required by the failsafe upstart job, which is what writes this plymouth message).

Changed in ifupdown (Ubuntu Precise):
importance: Undecided → High
status: New → Confirmed
Changed in network-manager (Ubuntu Precise):
status: Confirmed → Incomplete
Changed in ifupdown (Ubuntu Precise):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Stéphane Graber (stgraber) wrote :

Moving back to NM :)

ifupdown never does anything for interfaces that aren't listed in /etc/network/interfaces

It's Network Manager that's calling the up/post-up scripts through /etc/NetworkManager/dispatcher.d/01ifupdown

One of these, /etc/network/if-up.d/upstart emits net-device-up. I did a quick check and this script hasn't changed since at least Oneiric.

Changed in network-manager (Ubuntu Precise):
status: Incomplete → Confirmed
Changed in ifupdown (Ubuntu Precise):
status: Confirmed → Incomplete
Steve Langasek (vorlon) wrote :

> ifupdown never does anything for interfaces that aren't listed in
> /etc/network/interfaces

Yes, and it doesn't matter, because interfaces not listed in /etc/network/interfaces have no impact on the 'static-network-up' event being issued from /etc/network/if-up.d/upstart. *Only* interfaces that are statically configured via /e/n/i are waited for.

Changed in network-manager (Ubuntu Precise):
status: Confirmed → Invalid
Stéphane Graber (stgraber) wrote :

18:02 < stgraber> slangasek: oh, right, misread the script ... I'll eventually get a clear picture of all that in my head :) right. when lo is brought up, the ifupdown hook
                  should emit static-network-up as all the interfaces are ready
18:03 < stgraber> slangasek: so the question is why it didn't happen or what make the script think there was something else to bring up

Can you please give /var/log/syslog and /etc/network/interfaces on the affected system.
Ideally, I'd also need /var/log/upstart/network* from a boot with --log used on the kernel command line.

Thanks

On Wed, Feb 01, 2012 at 06:04:27PM -0000, Stéphane Graber wrote:

> Can you please give /var/log/syslog and /etc/network/interfaces on the
> affected system. Ideally, I'd also need /var/log/upstart/network* from a
> boot with --log used on the kernel command line.

A listing of /run/network from this system is probably also helpful.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Brian Murray (brian-murray) wrote :

I've seen this too:

ubuntu@ubuntu-virtual-machine:~$ ls /run/network
ifstate ifup.eth0

ubuntu@ubuntu-virtual-machine:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

Brian Murray (brian-murray) wrote :
Brian Murray (brian-murray) wrote :

This only happened to me on the first boot so I was unable to get the upstart logs.

Steve Langasek (vorlon) wrote :

This has been tracked down to a bug in the resolvconf package, causing /etc/network/if-up.d/000resolvconf to fail and taking the rest of the ifupdown hooks with it.

We can't create the initial /etc/resolv.conf symlink from the upstart job when using the live installer, because the job is never run until boot - and at the time it runs (start on mounted MOUNTPOINT=/run), the root fs is not writable. So this symlinking *must* be done in the postinst.

Targeting to beta-1 because we don't want to unsettle this for alpha-2.

affects: ifupdown (Ubuntu Precise) → resolvconf (Ubuntu Precise)
Changed in resolvconf (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-1
status: Incomplete → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package resolvconf - 1.63ubuntu7

---------------
resolvconf (1.63ubuntu7) precise; urgency=low

  [ Stéphane Graber ]
  * Revert change from 1.63ubuntu5 where /etc/resolv.conf would be linkified
    by the upstart/sysvinit job. This wasn't working as / wasn't necessarily
    writable at the time.
    Instead, make the link at package install time but make it a relative
    link which should take care of the chroot usecase where you want
    to copy /etc/resolv.conf from outside the chroot into the chroot.
    Detect old flag file (/var/lib/resolvconf/convert) and re-run the
    conversion code if it's present (to try and fix broken systems).
    Use readlink -m when checking the link's destination.
    (LP: #924836)

  [ Steve Langasek ]
  * Use readlink -m also in the postrm, to account for our relative links
 -- Stephane Graber <email address hidden> Thu, 02 Feb 2012 14:28:45 -0500

Changed in resolvconf (Ubuntu Precise):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments