Cannot connect to wireless network after mac address change

Bug #919885 reported by Ryan Shaw on 2012-01-22
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

I'm hoping the dmesg was included with this bug report.

Connecting to a wireless network with my current configuration works perfectly.

After changing my mac address, trying to connect back to the same network results in it just sitting there looking like it's connecting.

In dmesg it appears to be getting authenticated for some 'reason 2'.

I think this worked fine in 10.10, I have tried Linux Mint 12, Ubuntu 11.10 and Lubuntu 11.10 and they all have the same issue.

I execute

sudo ifconfig wlan0 down
sudo macchanger -A wlan0
sudo ifconfig wlan0 up

(same bug happens when I put a new mac address in the cloned mac address field too)

ifconfig shows it has the new mac
when I try to connect it just appears to hang with some juicy info in dmesg.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: network-manager-gnome 0.9.1.90-0ubuntu6
ProcVersionSignature: Ubuntu 3.0.0-15.25-generic 3.0.13
Uname: Linux 3.0.0-15-generic i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
CRDA:
 country FR:
  (2402 - 2482 @ 40), (N/A, 20)
  (5170 - 5250 @ 40), (N/A, 20)
  (5250 - 5330 @ 40), (N/A, 20), DFS
  (5490 - 5710 @ 40), (N/A, 27), DFS
Date: Sun Jan 22 11:02:41 2012
ExecutablePath: /usr/bin/nm-applet
Gconf:

IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Lubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
IpRoute:
 default via 192.168.0.1 dev wlan0 proto static
 192.168.0.0/24 dev wlan0 proto kernel scope link src 192.168.0.111 metric 2
Keyfiles: Error: [Errno 2] No such file or directory
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcEnviron:
 LANGUAGE=en_AU:en
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
RfKill: Error: [Errno 2] No such file or directory
SourcePackage: network-manager-applet
UpgradeStatus: No upgrade log present (probably fresh install)

Ryan Shaw (ryannathans) wrote :
Ryan Shaw (ryannathans) wrote :

On further inspection a deauth for reason 2 is because something is wrong with the encryption secret, I do not change the pass-phrase, only the spoofed mac.

I'm continuing investigation.

Ryan Shaw (ryannathans) on 2012-01-22
description: updated
Ryan Shaw (ryannathans) wrote :

On further inspection I changed the security of the network to Open. No filtering of any kind.

It hung for a minute but ended up connecting with a spoofed mac.

In dmesg there is this instead of the deauth reason 2, which is quite odd: [ 91.553210] wlan0: deauthenticating from 00:1c:df:a2:b9:28 by local choice (reason=3)

WEP connects fine, no problem at all.

WPA/TKIP has the same issue [ 593.726862] wlan0: deauthenticated from 00:1c:df:a2:b9:28 (Reason: 2)

WPA2/AES has same issue as WPA/TKIP

Ryan Shaw (ryannathans) wrote :

Happens in Fedora too. Must be network manager.

Ryan Shaw (ryannathans) wrote :

Wicd works fine for this. (mac spoofing) + confirmed via dhcp server

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
leon33 (leonleon33) wrote :

Had the same impossibility to connect with a changed mac-address.
Found that putting the card in promiscuous mode is a workaround.

I hope this can help to point out the issue. (I do not like the idea of permanent promiscuous mode).

Thomas Hood (jdthood) on 2012-10-30
affects: network-manager-applet (Ubuntu) → network-manager (Ubuntu)
Hans Streibel (hans-streibel) wrote :

Same probleme here with 12.04
The proposed workaround with the promiscuous mode does not help.

nleknh (nleknh) wrote :

"Cannot connect to wireless network after mac address change" -> same problem on Linux Mint 17.3 x86_64, but all OK on
Kali Linux 4.3.0-kali1-amd64 #1 SMP Debian 4.3.3-7kali1 (2016-01-21) x86_64 GNU/Linux

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers