Ubuntu

Please add support for more than one VPN simultaneously

Reported by Jelmer Vernooij on 2007-03-11
788
This bug affects 170 people
Affects Status Importance Assigned to Milestone
NetworkManager
Confirmed
Wishlist
network-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

  affects /ubuntu/network-manager

I often need to use more than one VPN at the same time (each using a
different address range though). It'd be nice if network-manager would
support that situation.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iQCVAwUBRfQLkQy0JeEGD2blAQItkgP/SWjDb/mIMltNpsr6CyY7tQ290sszSPQV
FSmEir+njA+Eq52nnoqwowAImJeiF2g3VAcHLcfsoaBjcPhqN8o4iT5LoAEtKLeA
+UE+qoY0zerSkn8tCgJa1U/Zaa80lROpU3pLSCKfbFPisnzybCxjGzkmwLyKRQT/
KcJBSkHDeZY=
=PKgd
-----END PGP SIGNATURE-----

TomasHnyk (sup) wrote :

I am afraid this should be forwared upstream.

TomasHnyk (sup) wrote :

This is addressed upstrem, but until it is solved there, Ubuntu can do nothing about this. Otherwise, I fully support your opinion, it should be possbile.
http://mail.gnome.org/archives/networkmanager-list/2007-May/msg00072.html

Changed in network-manager:
status: Unconfirmed → Rejected
Jelmer Vernooij (jelmer) wrote :

Why the "Rejected" ? This is an actual bug - shouldn't we rather add an "affects" entry?

TomasHnyk (sup) wrote :

Right, but there is no coresponding entry in NM bugzilla so (I think) it would be redundant to fill a new one provided there is work going on it upstrem (there is). Changed to confirmed anyway.

Changed in network-manager:
status: Rejected → Confirmed
Changed in network-manager:
importance: Undecided → Wishlist
TomasHnyk (sup) wrote :

hm ,so ti seems it is not working in NM 0.7 that is in intrepid:-(

sha8e (sha8e) wrote :

I too need such a multiple connection. I wish there is a solution to this bug in NM

Tito (f-disclosure) wrote :

Is this bug really 2 Yars old and still not solved. I just tryed the same with ubuntu 9.04 and still no result.

sha8e (sha8e) wrote :

Guys, I suggest you use GOpenVPN, you can find it here:
http://gopenvpn.sourceforge.net/

I use it to connect to many VPN's now. Whish you good luck.

Tito (f-disclosure) wrote :

sha8e thanks for for this link I will try it tonight! and let you know if this worked for my box!

sha8e (sha8e) wrote :
kaushal (kaushalshriyan) wrote :

I have followed gopenvpn http://gopenvpn.sourceforge.net/ and http://tranceparance.wordpress.com/2009/02/28/gopenvpn-installation-instructions-for-ubuntu-linux-810/

the issue is that my internal nameservers doesnot get populated in /etc/resolv.conf file while using gopenvpn application.

is there a fix or workaround for it ?

yayo (jaganz) wrote :

after two years, there is no solution about this? i use multiple vpn connections to my customers and it's not a "whishlist" (i use pptp, cisco and openvpn so gopenvpn it's not my software)... any command line workaround o others? thanks...

Robert (anon-razza) wrote :

Karmic is out... yet we still cant do (at least graphically) what Windows 98 users have been able to do which is connect to more than one VPN simultaneously.

B!n@ry (binary) wrote :

You can connect to multiple VPN connections from the terminal just do:
sudo openvpn --config connection_1.ovpn &
sudo openvpn --config connection_2.ovpn &
...
sudo openvpn --config connection_N.ovpn &

only replace connection_N.ovpn with the config file you are using.

Robert (anon-razza) wrote :

Correct we can establish using cli multiple vpn's and I have been doing that for about 2 1/2 years using a script. I would just love to see NetworkManager do this natively.

yayo (jaganz) wrote :

+1 for robert comment.
For working on customer servers, Too much people must connect to workplace vpn and after this they can connect to customer becouse the customer firewall allow only workplace ip. it's so much strange?

Changed in network-manager:
status: Unknown → Confirmed
Michael Henry (froderick) wrote :

I look forward to the day this feature becomes available. I use multiple simultaneous vpn connections on a regular basis. Using them all from within NetworkManager would be most convenient.

Changed in network-manager:
importance: Unknown → Wishlist
MaksimKa (netvin) wrote :

Want this feature too.

Koen Calliauw (koen-calliauw) wrote :

ditto

Numérigraphe (numerigraphe) wrote :

MaksimKa, Koen Calliauw, please use the button "this affects me too", not comments.

xoddam (jonathan-xoddam) wrote :

Bump. Very surprised to discover this limitation exists when it was raised as an Ubuntu bug in 2007.

bsgcic (bsgcic) wrote :

Wow, it has been over four years since this was reported and still limitation of only 1 vpn. This is a core necessity for ubuntu to be competitive in the business world. Multiple vpn connections is a given on windows platforms. Is anyone in ubuntu development working on this or even looking into how to accomplish this?

shubes (ejs-shubes) wrote :

I don't know the answer to this question. I don't expect it'd be very difficult. Just need to allow for multiple instances of openvpn to run concurrently, using separate tun interfaces. I've looked into doing this manually, which is how I run OpenVPN presently (on Lucid). It would be great if NM could do this.

Jan Nekvasil (jan-nekvasil) wrote :

Network Manager's about dialog states:

Copyright © 2004-2008 Red Hat, Inc.
Copyright © 2005-2008 Novell, Inc.

Neither Canonical nor Ubuntu community are NM's main developers, or authors of it's new features at least. As for myself, I would appreciate this functionality (which I desperately need for my daily work), but after these all years I don't expect this change coming from Ubuntu devs anymore without putting any blame on them.

It's not a simple matter, if you even only consider dealing with the multiple routes from different VPN tunnels.

Note that there's an upstream bug open for this, which means the upstream developers are aware of the issue; it's also still in the TODO list for future releases.

I'm happy to help out and provide guidance where possible if someone wants to come up with a patch, or maybe I'll get to it eventually ;)

Finally I'm using an app which is very simple to install/use and very practical in waiting a solution with the network-manager. This little apps is named gopenvpn, that you can find here : http://gopenvpn.sourceforge.net/

Dmitry Diskin (diskin) wrote :

Julien, thanks for sharing! However, it does not help with PPTP VPNs.

multiple simultaneous VPN connections is a pretty basic feature of any desktop OS including Windows so it is a MUST for Linux and not a "wish list"
Most people requesting this feature talking about the same - supporting multiple customers and I join their voice as it is my basic everyday need: Support multiple customers. Now I am creating a multiple shell scripts 1 for each connection for PPTP and using gopenvpn for OpenVPN

Martin Emrich (emme) wrote :

I do not think begging or asking here has any siginificant effect. Adding such a feature is surely more than a little bug fix, so it is not beyond the focus of the Ubuntu team or Canonical, but rather that of upstream.

By the way, VPN connectivity is not necessarily part of any desktop OS besides GNU/Linux or *BSD, for most VPNs (OpenVPN, IPSec, Cisco Anyconnect, Cisco VPN, Nortel, Contivity,...), users of closed-source systems have to download and install 3rd-party software.

bsgcic (bsgcic) wrote :

Vadim - I need to do the same thing. Could you post your shell scripts here? Would be extremely helpful.

Vadim Nevorotin (malamut) wrote :

Hmm, the first time I've added a openvpn connections to NM, I was fully confident that you can turn on several connections at a time. It's a main advantage and main property of VPN. I can't imagine the reason, why multiple VPN connections weren't the first step in VPN realization in NM. It's not a whishlist, it a hight important bug, because a lot of peoples couldn't work with NM without such basic VPN support.

Thomas Hood (jdthood) on 2012-06-23
summary: - Support for more than one VPN simultaneously
+ Please add support for more than one VPN simultaneously
PBraga (pls-braga) wrote :

I was under the impression that previous desktop versions of Linux that I had on my older laptops had this feature!
Probably it was Debian... I don't really remember, it could be Ubuntu. Also I don't remember the name of the app.
But I am pretty sure I did connect to two VPNs at same time with a fancy window manager applet.

I also need to connect to two different VPNs at the same time.
I'll have to setup things by hand on cli.

This feature is a must!
I will appreciate when it is available.
looking forward for it.
Thank you.

Christian Weiske (cweiske) wrote :

With 12.10 (network-manager 0.9.6), you can connect to multiple VPNs using the network settings:
- System settings (gnome-control-center)
- Network
- Select each VPN and set it to "on".

So Network manager is able to connect multiple VPNs, but the systray menu not.

Bart Verwilst (verwilst) wrote :

cweiske is correct, when multiple VPN's are enabled through gnome-control-center, they are all marked as on in the systray as well. When enabling a VPN through the systray, it disables the rest. Sounds like an easy thing to fix... :(

Nilesh Trivedi (nilesh-tr) wrote :

The above workaround suggested by cweiske doesn't work for me in Ubuntu 12.10 & Network Manager 0.9.6.2. Trying to enable second VPN connection disconnect the first one.

amlet0 (l-ingrilli) wrote :

are there any plans to fix this issue? It also affect ubuntu 13.04

It also affects 13.10

Colan Schwartz (colan) on 2013-11-04
tags: added: saucy
zzeroo (co) wrote :

The trick to connect via the gnome-control-centers Network tab dosn't work.

I run Ubuntu 14.04 with network-manager 0.9.8.4-0ubuntu3

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.