Ubuntu

[ipw2200] nm-applet crashed with SIGABRT in g_assertion_message()

Reported by Vince on 2011-12-24
64
This bug affects 11 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
network-manager (Ubuntu)
Medium
Mathieu Trudel-Lapierre

Bug Description

In 12.04 Alpha 1.Restarted after installing updates.Noticed a dark radio signal meter.Clicked and saw that my wlan was disconected.Clicked on my wlan to reconnect.Then network manager crashed.Still have wireless connection to my router and the net.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: network-manager-gnome 0.9.1.90-0ubuntu6
ProcVersionSignature: Ubuntu 3.2.0-6.12-generic 3.2.0-rc6
Uname: Linux 3.2.0-6-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Sat Dec 24 06:38:48 2011
DuplicateOf: https://bugs.launchpad.net/bugs/743485
ExecutablePath: /usr/bin/nm-applet
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
IpRoute:
 default via 192.168.15.1 dev eth1 proto static
 169.254.0.0/16 dev eth1 scope link metric 1000
 192.168.15.0/24 dev eth1 proto kernel scope link src 192.168.15.4 metric 2
NetworkManager.conf:
 [main]
 plugins=ifupdown,keyfile

 [ifupdown]
 managed=false
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcCmdline: nm-applet
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Signal: 6
SourcePackage: network-manager-applet
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 g_assertion_message () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: nm-applet crashed with SIGABRT in __kernel_vsyscall()
UpgradeStatus: Upgraded to precise on 2011-12-10 (14 days ago)
UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare
nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT READONLY DBUS-PATH
 MOT-1-6F 1 d44c5a39-d7d4-4109-8a35-961e8742f431 802-11-wireless 0 never yes no /org/freedesktop/NetworkManager/Settings/2
 Wired connection 1 490629c7-a813-46e7-9523-9d94f683b939 802-3-ethernet 1324730179 Sat 24 Dec 2011 06:36:19 AM CST yes no /org/freedesktop/NetworkManager/Settings/1
 MOT-1-6F 8b04a1cd-24e6-49af-8115-37138888e1f8 802-11-wireless 1324730336 Sat 24 Dec 2011 06:38:56 AM CST yes no /org/freedesktop/NetworkManager/Settings/0
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 eth0 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/0
 eth1 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/1
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.3.0 connected enabled enabled enabled enabled disabled

Vince (thehappytrucker) wrote :

StacktraceTop:
 g_assertion_message (domain=0x0, file=0xbc2aaf "nm-utils.c", line=1231, func=0xbc3800 "nm_utils_security_valid", message=<optimized out>) at /build/buildd/glib2.0-2.31.4.tested/./glib/gtestutils.c:1810
 g_assertion_message_expr (domain=0x0, file=0xbc2aaf "nm-utils.c", line=1231, func=0xbc3800 "nm_utils_security_valid", expr=0xbc2aa7 "have_ap") at /build/buildd/glib2.0-2.31.4.tested/./glib/gtestutils.c:1821
 nm_utils_security_valid (type=NMU_SEC_STATIC_WEP, wifi_caps=NM_WIFI_DEVICE_CAP_NONE, have_ap=0, adhoc=0, ap_flags=NM_802_11_AP_FLAGS_NONE, ap_wpa=NM_802_11_AP_SEC_NONE, ap_rsn=NM_802_11_AP_SEC_NONE) at nm-utils.c:1231
 security_combo_init (self=0x8112150, secrets_only=1) at nm-wireless-dialog.c:916
 internal_init (self=0x8112150, specific_connection=0x832cab0, specific_device=0x0, secrets_only=1, create=0) at nm-wireless-dialog.c:1128

Changed in network-manager-applet (Ubuntu):
importance: Undecided → Medium
summary: - nm-applet crashed with SIGABRT in __kernel_vsyscall()
+ nm-applet crashed with SIGABRT in g_assertion_message()
tags: removed: need-i386-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
visibility: private → public
Vince (thehappytrucker) wrote :

I just add a Linksys WPC600n ultra PCMCIA atapter to my Thinkpad.And after Ubuntu download and installed the driver.NM shows it and and connected. Here is how the Linksys and the Intel cards are listed.

Linksys-Broadcom BCM-4321 802.11 a/b/g/n

Intel PRO/Wireless 2915ABG [Galexico 2]Now with the Linksys driver,nm will connect to both at the same time without crashing.
The driver for the Linksys is listed as wl.
Thanks hope this helps.

Yup, this bug very much looks like it's hardware specific. I definitely can't reproduce this on my own systems, but I also don't have one that runs with the ipw2200 or ipw2100 drivers.

I'll try to get to the hardware lab tomorrow and test this more thoroughly on hardware that uses this driver.

If anyone seeing this bug has a way to try and reproduce it on the same system after either replacing the wireless chip, or trying it with a USB wifi dongle (or any other such way that would use different hardware that doesn't rely on ipw2200), that's a valid test as well.

Marking as affecting linux since this is hardware specific and NetworkManager itself doesn't really handle the devices differently. Seems like there may be an issue with how the wireless device's or AP's capabilities are being reported.

summary: - nm-applet crashed with SIGABRT in g_assertion_message()
+ [ipw2200] nm-applet crashed with SIGABRT in g_assertion_message()

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 908380

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
status: Incomplete → New
status: New → Incomplete

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Incomplete. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

tags: added: kernel-request-3.2.0-18.28
Joseph Salisbury (jsalisbury) wrote :

Marking importance as high due to the number of duplicates.

Changed in linux (Ubuntu):
importance: Undecided → Medium
importance: Medium → High
tags: added: kernel-da-key kernel-key
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Péter Trombitás (trombipeti) wrote :

Changed to confirmed in linux because it doesn't work with the latest kernel either (at least for me).

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc6-precise/

tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Sorry I can't test the new kernel. I am running Precise from a USB stick.

Regards..

On 08/03/12 20:32, Joseph Salisbury wrote:
> Would it be possible for you to test the latest upstream kernel? Refer
> to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest
> v3.3 kernel[1] (Not a kernel in the daily directory). Once you've
> tested the upstream kernel, please remove the 'needs-upstream-testing'
> tag(Only that one tag, please leave the other tags). This can be done by
> clicking on the yellow pencil icon next to the tag located at the bottom
> of the bug description and deleting the 'needs-upstream-testing' text.
>
> If this bug is fixed in the mainline kernel, please add the following
> tag 'kernel-fixed-upstream'.
>
> If the mainline kernel does not fix this bug, please add the tag:
> 'kernel-bug-exists-upstream'.
>
> If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
> Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".
>
>
> Thanks in advance.
>
> [1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc6-precise/
>
>
> ** Tags added: needs-upstream-testing
>
> ** Changed in: linux (Ubuntu)
> Status: Confirmed => Incomplete
>

Joseph Salisbury (jsalisbury) wrote :

Can other folks affected by this bug test the upstream kernel mentioned in comment #13

Also, did this issue also happen in prior Ubuntu releases, or is this new in Precise(12.04)?

Adam Collard (adam-collard) wrote :

This is new in Precise. Going to try the upstream kernel now.

Adam Collard (adam-collard) wrote :

Bug is reproducible in mainline kernel (3.3.0-030300rc6-generic).

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Péter Trombitás (trombipeti) wrote :

Hi,
So it seems that my problem I submitted another bug about is not this problem though it has been marked as a duplicate. I'm not 100% sure though.
I tried to connect to a secured wifi during install, and nm-applet crashed, but that network was remembered and set to autoconnect. Every time I tried to launch nm-applet, it crashed when it was about to ask for the password. So I opened 'network connections' from the dash, and deleted all the remembered wifi networks and added mine with data from the iwlist eth1 s command's output. No I'm connected to the network and nm-applet runs, though it crashes when I select another secured wifi to connect to. Also, it doesn't show the signal quality (it looks as if there was no signal), and it doesn't show which network I'm connected to, it just shows 'disconnect' under wifi connections from what I know that I'm connected to something. Also, I cannot select any networks to connect to (see the attached screenshot).

...And now, after selecting another network to connect to, I'm again unable to use wifi, though nm-applet runs.

Sorry for writing such a long comment, hope it helps :)
If the problem described above is not related to this bug, I will open another bug.
Thank you in advance.

Jayson Rowe (jayson.rowe) wrote :

Péter describes my scenario also, down to the letter.

Changed in linux (Ubuntu):
status: Confirmed → Triaged

Péter, Jayson, you'll need to check at least what wireless device is in use on your system. That's why it's prefered to file a separate bug report, because in case of crashes Apport will pop up and ask you to file one -- this can then be automatically marked as a duplicate. Otherwise, please let us know the bug number for your bug that was marked as a duplicate if you think it shouldn't be.

Jayson Rowe (jayson.rowe) wrote :

Hi Mathieu,
My original but was 945311 (https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/945311) and it was filed automatically with Apport, and was marked as a duplicate of this bug. Is there anything else I need to do on my end in regards to my original bug report?

Thanks for all you do!

Jayson, nothing more to do for that bug report, it indeed is most likely the same issue (sound similar from the description) though there is no crash report now since it was marked as a duplicate by Launchpad. It's most likely correct.

Now the steps needed is to figure out why this fails. I haven't actually been able to reproduce this at all because I don't have access to any hardware that has that chip; what needs to be done is probably figure out what kernel version introduces it (e.g. try older versions), then bisect to find where the ipw2200 driver stopped properly reporting capabilities.

Péter Trombitás (trombipeti) wrote :

It's ipw2200 here, too. I'll try the older kernels tomorrow or something.
Péter

2012/3/9 Mathieu Trudel-Lapierre <email address hidden>

> Jayson, nothing more to do for that bug report, it indeed is most likely
> the same issue (sound similar from the description) though there is no
> crash report now since it was marked as a duplicate by Launchpad. It's
> most likely correct.
>
> Now the steps needed is to figure out why this fails. I haven't actually
> been able to reproduce this at all because I don't have access to any
> hardware that has that chip; what needs to be done is probably figure
> out what kernel version introduces it (e.g. try older versions), then
> bisect to find where the ipw2200 driver stopped properly reporting
> capabilities.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (916589).
> https://bugs.launchpad.net/bugs/908380
>
> Title:
> [ipw2200] nm-applet crashed with SIGABRT in g_assertion_message()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/908380/+subscriptions
>

Isak Enström (isen) wrote :

#18 Péter Trombitás,

That is an excellent description of my problem as well. I've only tested 12.04 beta1 from a live USB stick, but I have never before had any troubles with wireless in Ubuntu since I started using it in 2008. The ipw2200 driver is used and the adapter is called eth1 but that's been the case since 8.04. I've installed wicd as well and managed to set up a connection without any problems.

The problem seems to be in parsing passphrase.
After I've changed passphrase on m AP (by deleting double '@@' it contained) all works as charm.

Thus my bet is that some characters in passphrase make aplet crash. Can anyone confirm it?

Maybe this bug should be also reviewed in security context?

Péter Trombitás (trombipeti) wrote :

My password contains only normal small letters, so here it's not the cause
of the problem.

2012/3/11 sieciobywatel <email address hidden>

> The problem seems to be in parsing passphrase.
> After I've changed passphrase on m AP (by deleting double '@@' it
> contained) all works as charm.
>
> Thus my bet is that some characters in passphrase make aplet crash. Can
> anyone confirm it?
>
> Maybe this bug should be also reviewed in security context?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (916589).
> https://bugs.launchpad.net/bugs/908380
>
> Title:
> [ipw2200] nm-applet crashed with SIGABRT in g_assertion_message()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/908380/+subscriptions
>

Alan Pater (alan-pater) wrote :

I tried it with an older kernel

~$ uname -a
Linux crow 3.0.0-16-generic #28-Ubuntu SMP Fri Jan 27 17:50:54 UTC 2012 i686 i686 i386 GNU/Linux

And restarted nm-applet. No wireless networks showed up, so I toggled the wireless off and on again, causing nm-applet to crash.

~$ nm-applet

LIBDBUSMENU-GLIB-WARNING **: Translation has an invalid value 'I-->D' for default text direction. Defaulting to left-to-right.
** Message: applet now removed from the notification area
** Message: using fallback from indicator to GtkStatusIcon
** Message: applet now embedded in the notification area

** Message: No keyring secrets found for HOSTAL-FELIPE/802-11-wireless-security; asking user.
**
ERROR:nm-utils.c:1262:nm_utils_security_valid: assertion failed: (have_ap)
Abortado (`core' generado)

Alan Pater (alan-pater) wrote :

I installed the previous version of network-manager and the applet does not crash anymore, but neither will it show me any available wifi networks. It works using a USB tethered connection to my Android.

The previous version was found in /var/cache/apt/archives/

~$ sudo dpkg -i network-manager_0.9.2.0+git201202161854.8572ecf-0ubuntu6_i386.deb

Alan, this bug was reported in December with a much earlier version of NetworkManager; (network-manager 0.9.2.0+git201112151936.6b31828-0ubuntu1), so it's not likely to be a problem tied to these versions of NetworkManager.

Alan Pater (alan-pater) wrote :

The problem only popped up for me after installing updates a few days ago, which is why I tried a previous version. On that note, I spoke too soon, the applet has now disappeared, though the USB network still works.

Philipp (sacridex) wrote :

Something changed now. I have latest version of Precise daily(03-12).

Now all available Wifis are shown darkgray in the applet and i cannot select one of them.
But i can still create a Wifi connection manually with the desired SSID. After a reboot, i get automatically connected.

Jools Wills (jools) wrote :

Philipp: that is how it has been for me recently. it shows my wireless but I am unable to select it. Manually creating it works. Choosing to connect to a hidden network crashes.

Download full text (4.1 KiB)

Jools, and so we have gone full circle. What you experience was what I
experienced after which I sent a bug report. This bug report was marked as
duplicate and merged with another one.

------ Original Message ------
Received: Mon, 12 Mar 2012 09:36:37 PM CET
From: Jools Wills <email address hidden>
To: <email address hidden>
Subject: [Bug 908380] Re: [ipw2200] nm-applet crashed with SIGABRT in
g_assertion_message()

Philipp: that is how it has been for me recently. it shows my wireless
but I am unable to select it. Manually creating it works. Choosing to
connect to a hidden network crashes.

--
You received this bug notification because you are subscribed to a
duplicate bug report (944361).
https://bugs.launchpad.net/bugs/908380

Title:
  [ipw2200] nm-applet crashed with SIGABRT in g_assertion_message()

Status in “linux” package in Ubuntu:
  Triaged
Status in “network-manager-applet” package in Ubuntu:
  Confirmed

Bug description:
  In 12.04 Alpha 1.Restarted after installing updates.Noticed a dark
  radio signal meter.Clicked and saw that my wlan was
  disconected.Clicked on my wlan to reconnect.Then network manager
  crashed.Still have wireless connection to my router and the net.

  ProblemType: Crash
  DistroRelease: Ubuntu 12.04
  Package: network-manager-gnome 0.9.1.90-0ubuntu6
  ProcVersionSignature: Ubuntu 3.2.0-6.12-generic 3.2.0-rc6
  Uname: Linux 3.2.0-6-generic i686
  ApportVersion: 1.90-0ubuntu1
  Architecture: i386
  Date: Sat Dec 24 06:38:48 2011
  DuplicateOf: https://bugs.launchpad.net/bugs/743485
  ExecutablePath: /usr/bin/nm-applet
  IfupdownConfig:
   auto lo
   iface lo inet loopback
  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
  IpRoute:
   default via 192.168.15.1 dev eth1 proto static
   169.254.0.0/16 dev eth1 scope link metric 1000
   192.168.15.0/24 dev eth1 proto kernel scope link src 192.168.15.4
metric 2
  NetworkManager.conf:
   [main]
   plugins=ifupdown,keyfile

   [ifupdown]
   managed=false
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
   WimaxEnabled=true
  ProcCmdline: nm-applet
  RfKill:
   0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
  Signal: 6
  SourcePackage: network-manager-applet
  StacktraceTop:
   __kernel_vsyscall ()
   raise () from /lib/i386-linux-gnu/libc.so.6
   abort () from /lib/i386-linux-gnu/libc.so.6
   g_assertion_message () from /lib/i386-linux-gnu/libglib-2.0.so.0
   g_assertion_message_expr () from /lib/i386-linux-gnu/libglib-2.0.so.0
  Title: nm-applet crashed with SIGABRT in __kernel_vsyscall()
  UpgradeStatus: Upgraded to precise on 2011-12-10 (14 days ago)
  UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare
  nmcli-con:
   NAME UUID TYPE
       TIMESTAMP TIMESTAMP-REAL AUTOCONNECT READONLY
 DBUS-PATH
   MOT-1-6F 1 d44c5a39-d7d4-4109-8a35-961e8742f431
802-11-wireless 0 never yes
 no /org/freedesktop/NetworkManager/Settings/2
   Wired connection 1 ...

Read more...

Download full text (5.0 KiB)

Another piece of information: Network Connections crashes if I try to edit
a wireless network's config that has no wireless key set yet. I get an
error message saying:
(this is in Hungarian for me, so I'm not sure what's the original:)
Error preparing the editor
"No agents were available for this request." (This is in English).
Now what does this mean?
I don't seem to be able to connect to my wifi from terminal, either (with
"sudo iwconfig eth1 essid SMC key s:<mypassword>). This can mean though
that I'm using the worng command.

2012/3/12 Peter Spreij <email address hidden>

> Jools, and so we have gone full circle. What you experience was what I
> experienced after which I sent a bug report. This bug report was marked as
> duplicate and merged with another one.
>
> ------ Original Message ------
> Received: Mon, 12 Mar 2012 09:36:37 PM CET
> From: Jools Wills <email address hidden>
> To: <email address hidden>
> Subject: [Bug 908380] Re: [ipw2200] nm-applet crashed with SIGABRT in
> g_assertion_message()
>
> Philipp: that is how it has been for me recently. it shows my wireless
> but I am unable to select it. Manually creating it works. Choosing to
> connect to a hidden network crashes.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (944361).
> https://bugs.launchpad.net/bugs/908380
>
> Title:
> [ipw2200] nm-applet crashed with SIGABRT in g_assertion_message()
>
> Status in “linux” package in Ubuntu:
> Triaged
> Status in “network-manager-applet” package in Ubuntu:
> Confirmed
>
> Bug description:
> In 12.04 Alpha 1.Restarted after installing updates.Noticed a dark
> radio signal meter.Clicked and saw that my wlan was
> disconected.Clicked on my wlan to reconnect.Then network manager
> crashed.Still have wireless connection to my router and the net.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: network-manager-gnome 0.9.1.90-0ubuntu6
> ProcVersionSignature: Ubuntu 3.2.0-6.12-generic 3.2.0-rc6
> Uname: Linux 3.2.0-6-generic i686
> ApportVersion: 1.90-0ubuntu1
> Architecture: i386
> Date: Sat Dec 24 06:38:48 2011
> DuplicateOf: https://bugs.launchpad.net/bugs/743485
> ExecutablePath: /usr/bin/nm-applet
> IfupdownConfig:
> auto lo
> iface lo inet loopback
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
> IpRoute:
> default via 192.168.15.1 dev eth1 proto static
> 169.254.0.0/16 dev eth1 scope link metric 1000
> 192.168.15.0/24 dev eth1 proto kernel scope link src 192.168.15.4
> metric 2
> NetworkManager.conf:
> [main]
> plugins=ifupdown,keyfile
>
> [ifupdown]
> managed=false
> NetworkManager.state:
> [main]
> NetworkingEnabled=true
> WirelessEnabled=true
> WWANEnabled=true
> WimaxEnabled=true
> ProcCmdline: nm-applet
> RfKill:
> 0: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> Signal: 6
> SourcePackage: network-manager-applet
> StacktraceTop:
> __kernel_vsyscall ()
> raise () from /lib/i386-linux-gnu/libc.so.6
> abort () from /lib/i386-linux-gnu/libc.so.6
> g_assertion_message () from /lib/i386-linux-gnu/libglib-2.0.so.0
> g_assertion_message_expr () from /...

Read more...

Peter Spreij (spreij) wrote :
Download full text (5.7 KiB)

Peter, first completely (including the password) configure your hidden
wifi network connection via 'Edit Connections' in networkmanager.
Once you have done this you can connect via the commandline with: sudo
iwconfig eth1 essid 'your hidden networkname' . This assumes that the
wifi interface is called 'eth1'. If this is not the case substitute
'eth1' with the interface name you found with typing iwconfig in the
terminal.

On 12/03/12 21:46, Péter Trombitás wrote:
> Another piece of information: Network Connections crashes if I try to edit
> a wireless network's config that has no wireless key set yet. I get an
> error message saying:
> (this is in Hungarian for me, so I'm not sure what's the original:)
> Error preparing the editor
> "No agents were available for this request." (This is in English).
> Now what does this mean?
> I don't seem to be able to connect to my wifi from terminal, either (with
> "sudo iwconfig eth1 essid SMC key s:<mypassword>). This can mean though
> that I'm using the worng command.
>
> 2012/3/12 Peter Spreij<email address hidden>
>
>> Jools, and so we have gone full circle. What you experience was what I
>> experienced after which I sent a bug report. This bug report was marked as
>> duplicate and merged with another one.
>>
>> ------ Original Message ------
>> Received: Mon, 12 Mar 2012 09:36:37 PM CET
>> From: Jools Wills<email address hidden>
>> To: <email address hidden>
>> Subject: [Bug 908380] Re: [ipw2200] nm-applet crashed with SIGABRT in
>> g_assertion_message()
>>
>> Philipp: that is how it has been for me recently. it shows my wireless
>> but I am unable to select it. Manually creating it works. Choosing to
>> connect to a hidden network crashes.
>>
>> --
>> You received this bug notification because you are subscribed to a
>> duplicate bug report (944361).
>> https://bugs.launchpad.net/bugs/908380
>>
>> Title:
>> [ipw2200] nm-applet crashed with SIGABRT in g_assertion_message()
>>
>> Status in “linux” package in Ubuntu:
>> Triaged
>> Status in “network-manager-applet” package in Ubuntu:
>> Confirmed
>>
>> Bug description:
>> In 12.04 Alpha 1.Restarted after installing updates.Noticed a dark
>> radio signal meter.Clicked and saw that my wlan was
>> disconected.Clicked on my wlan to reconnect.Then network manager
>> crashed.Still have wireless connection to my router and the net.
>>
>> ProblemType: Crash
>> DistroRelease: Ubuntu 12.04
>> Package: network-manager-gnome 0.9.1.90-0ubuntu6
>> ProcVersionSignature: Ubuntu 3.2.0-6.12-generic 3.2.0-rc6
>> Uname: Linux 3.2.0-6-generic i686
>> ApportVersion: 1.90-0ubuntu1
>> Architecture: i386
>> Date: Sat Dec 24 06:38:48 2011
>> DuplicateOf: https://bugs.launchpad.net/bugs/743485
>> ExecutablePath: /usr/bin/nm-applet
>> IfupdownConfig:
>> auto lo
>> iface lo inet loopback
>> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
>> IpRoute:
>> default via 192.168.15.1 dev eth1 proto static
>> 169.254.0.0/16 dev eth1 scope link metric 1000
>> 192.168.15.0/24 dev eth1 proto kernel scope link src 192.168.15.4
>> metric 2
>> NetworkManager.conf:
>> [main]
>> plugins=ifupdown,keyfile
>>...

Read more...

tags: removed: kernel-key
Péter Trombitás (trombipeti) wrote :

Peter: Thank you the tip.
My problem still exists though, and I'm not sure if I should report another
bug.

2012/3/13 Joseph Salisbury <email address hidden>

> ** Tags removed: kernel-key
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (916589).
> https://bugs.launchpad.net/bugs/908380
>
> Title:
> [ipw2200] nm-applet crashed with SIGABRT in g_assertion_message()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/908380/+subscriptions
>

Download full text (4.5 KiB)

Peter,
Sorry to hear that it did not work for you. I would file another bug if I were
you.
That is the only way to have experts look at the perticular problem and solve
it before Precise hits the marked.

------ Original Message ------
Received: Tue, 13 Mar 2012 05:31:37 PM CET
From: Péter Trombitás <email address hidden>
To: <email address hidden>
Subject: Re: [Bug 908380] Re: [ipw2200] nm-applet crashed with SIGABRT in
g_assertion_message()

Peter: Thank you the tip.
My problem still exists though, and I'm not sure if I should report another
bug.

2012/3/13 Joseph Salisbury <email address hidden>

> ** Tags removed: kernel-key
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (916589).
> https://bugs.launchpad.net/bugs/908380
>
> Title:
> [ipw2200] nm-applet crashed with SIGABRT in g_assertion_message()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/908380/+subscriptions
>

--
You received this bug notification because you are subscribed to a
duplicate bug report (944361).
https://bugs.launchpad.net/bugs/908380

Title:
  [ipw2200] nm-applet crashed with SIGABRT in g_assertion_message()

Status in “linux” package in Ubuntu:
  Triaged
Status in “network-manager-applet” package in Ubuntu:
  Confirmed

Bug description:
  In 12.04 Alpha 1.Restarted after installing updates.Noticed a dark
  radio signal meter.Clicked and saw that my wlan was
  disconected.Clicked on my wlan to reconnect.Then network manager
  crashed.Still have wireless connection to my router and the net.

  ProblemType: Crash
  DistroRelease: Ubuntu 12.04
  Package: network-manager-gnome 0.9.1.90-0ubuntu6
  ProcVersionSignature: Ubuntu 3.2.0-6.12-generic 3.2.0-rc6
  Uname: Linux 3.2.0-6-generic i686
  ApportVersion: 1.90-0ubuntu1
  Architecture: i386
  Date: Sat Dec 24 06:38:48 2011
  DuplicateOf: https://bugs.launchpad.net/bugs/743485
  ExecutablePath: /usr/bin/nm-applet
  IfupdownConfig:
   auto lo
   iface lo inet loopback
  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
  IpRoute:
   default via 192.168.15.1 dev eth1 proto static
   169.254.0.0/16 dev eth1 scope link metric 1000
   192.168.15.0/24 dev eth1 proto kernel scope link src 192.168.15.4
metric 2
  NetworkManager.conf:
   [main]
   plugins=ifupdown,keyfile

   [ifupdown]
   managed=false
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
   WimaxEnabled=true
  ProcCmdline: nm-applet
  RfKill:
   0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
  Signal: 6
  SourcePackage: network-manager-applet
  StacktraceTop:
   __kernel_vsyscall ()
   raise () from /lib/i386-linux-gnu/libc.so.6
   abort () from /lib/i386-linux-gnu/libc.so.6
   g_assertion_message () from /lib/i386-linux-gnu/libglib-2.0.so.0
   g_assertion_message_expr () from /lib/i386-linux-gnu/libglib-2.0.so.0
  Title: nm-applet crashed with SIGABRT in __kernel_vsyscall()
  UpgradeStatus: Upgraded to precise on 2011-12-10 (14 days ago)
  UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare
  nmcli-con:
   NAME ...

Read more...

There's a bit of work that can be done at the NetworkManager level to avoid crashing when this kind of issue happen, so I've filed the task for this now; and there's a package I just uploaded to the ~ubuntu-desktop PPA: network-manager 0.9.3.995+git201203081848.bba834f-0ubuntu1~mtrudel2; which fixes the crashes (but we still need the capabilities fixed at the driver level for encrypted networks to show properly. See https://launchpad.net/~ubuntu-desktop/+archive/ppa ; the packages should be built and ready in a few hours.

Any help with testing this fix and the new package will be very welcome :)

Changed in network-manager-applet (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
affects: network-manager-applet (Ubuntu) → network-manager (Ubuntu)
Alan Pater (alan-pater) wrote :

Gracias Mathieu

I installed your update, it is not crashing and I get a prompt telling me that the avaialble wifi network needs a password, but it does not offer a prompt to enter a password. If I try to edit the connection, I get a message that the editor failed to initialize, No agents were available for this request.

PS: the network-manager-applet package is not installed nor avaialable from apt. Might this be the problem?

Well, the package for nm-applet is called network-manager-gnome so you may want to check the version for that one. Perhaps the update wasn't ready yet as it was uploaded later than nrtwork-manager.

Alan Pater (alan-pater) wrote :

Sucess!

Enabling the ~ubuntu-desktop PPA, installing network-manager-gnome (and network-manager) from there and restarting allowed me to edit the connection and enter the WEP password. Enough of a workaround for me...

Please confirm the version for network-manager and network-manager-gnome, and also attach a screenshot of that notification if possible. Also, have you rebooted after updating?

Launchpad Janitor (janitor) wrote :
Download full text (3.7 KiB)

This bug was fixed in the package network-manager - 0.9.3.995+git201203081848.bba834f-0ubuntu1

---------------
network-manager (0.9.3.995+git201203081848.bba834f-0ubuntu1) precise; urgency=low

  * upstream snapshot 2012-03-08 18:48:46 (GMT) (LP: #950313)
    + bba834f8428934608b58eb96aa2b81e413430346
    - Added VLAN support.
    - Added bonding support.
    - Added Firewalld support.
    - Added support for IP connectivity checking.
    - Updated translations for Ukrainian, Slovenian, Hungarian, Malayalam,
      Polish and Brazilian Portugese.
    - Miscellaneous bugfixes.
  * debian/patches/nm-change-dnsmasq-parameters.diff: refreshed, dropped the
    disabling of --strict-order, since that change made it upstream.
  * debian/patches/avoid-periodic-disk-wakeups.patch: dropped, this was fixed
    slightly differently upstream, keeping periodic updates of the timestamps
    in memory but avoiding to flush the changes to disk, see commit 0be930c.
  * debian/patches/manage-privacy-extensions.patch: dropped, applied upstream;
    the only part that wasn't applied is to default to privacy extensions being
    enabled...
  * debian/patches/enable-ipv6-privacy.patch: since we dropped the previous
    patch, update the defaults for PROP_IP6_PRIVACY to make sure IPv6 privacy
    extensions are enabled by default, to retain the same behavior we already
    had.
  * debian/patches/git_libnm-glib_ensure_device_state_aef4340.patch: dropped,
    applied upstream.
  * debian/patches/dnsmasq-dont-read-hosts.patch: dropped, applied upstream.
  * debian/patches/dnsmasq-dnssec-passthrough.patch: refreshed.
  * debian/patches/git_nm_device_set_device_type_private.patch: make sure
    nm_device_set_device_type() stays private.
  * debian/libnm-glib4.symbols: add new symbols:
    + nm_device_bond_get_carrier@Base
    + nm_device_bond_get_hw_address@Base
    + nm_device_bond_get_type@Base
    + nm_device_bond_new@Base
    + nm_device_olpc_mesh_get_active_channel@Base
    + nm_device_olpc_mesh_get_companion@Base
    + nm_device_olpc_mesh_get_hw_address@Base
    + nm_device_olpc_mesh_get_type@Base
    + nm_device_olpc_mesh_new@Base
    + nm_device_vlan_get_carrier@Base
    + nm_device_vlan_get_hw_address@Base
    + nm_device_vlan_get_type@Base
    + nm_device_vlan_get_vlan_id@Base
    + nm_device_vlan_new@Base
  * debian/libnm-util2.symbols: add new symbols:
    + nm_connection_get_setting_vlan@Base
    + nm_setting_bond_get_option_default@Base
    + nm_setting_bond_get_valid_options@Base
    + nm_setting_ip6_config_get_ip6_privacy@Base (renamed from
      nm_setting_ip6_config_get_enable_ip6_privacy@Base)
    + nm_setting_ip6_config_privacy_get_type@Base
    + nm_setting_vlan_*
    + nm_vlan_flags_get_type@Base
    + nm_vlan_priority_map_get_type@Base
  * debian/network-manager.install: install the debug-helper.py script as a way
    for our users to change wpasupplicant, NetworkManager and ModemManager log
    levels easily; as /usr/lib/NetworkManager/debug-helper.py.
  * debian/control: add python to Suggests because the debug-helper.py script
    does require it, but leave it as just a Suggests because the script is
    simply there to make people's life easie...

Read more...

Changed in network-manager (Ubuntu):
status: In Progress → Fix Released
Ruokoton (uborealis) wrote :

network-manager-gnome:
  Installed: 0.9.2.0+git.20120126t000800.5151959-0ubuntu4
  Candidate: 0.9.2.0+git.20120126t000800.5151959-0ubuntu4
  Version table:
 *** 0.9.2.0+git.20120126t000800.5151959-0ubuntu4 0
        500 http://fi.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

After installing the fix, crashes when selecting predefined wlan are gone, but the panel icon still shows disconnected all the time. Also, all the predefined wlan access points show full signal strength (falsely) in the top panel's menu. Should I make separate bugs for those?

Ruokoton (uborealis) wrote :

Ignore #44 - thought I had installed the fix, but that was not the case.

Alan Pater (alan-pater) wrote :

~$ dpkg -l | grep network-manager

ii network-manager 0.9.3.995+git201203081848.bba834f-0ubuntu1~mtrudel2 network management framework (daemon and userspace tools)
ii network-manager-gnome 0.9.3.995+git.20120313t141231.c89224f-0ubuntu1~mtrudel1 network management framework (GNOME frontend)

~$ dpkg -l | grep libnm

ii libnm-glib-vpn1 0.9.2.0+git201202161854.8572ecf-0ubuntu7 network management framework (GLib VPN shared library)
ii libnm-glib4 0.9.3.995+git201203081848.bba834f-0ubuntu1~mtrudel2 network management framework (GLib shared library)
ii libnm-gtk-common 0.9.2.0+git.20120126t000800.5151959-0ubuntu4 network management framework (common files for wifi and mobile)
ii libnm-gtk0 0.9.2.0+git.20120126t000800.5151959-0ubuntu4 network management framework (GNOME dialogs for wifi and mobile)
ii libnm-util2 0.9.3.995+git201203081848.bba834f-0ubuntu1~mtrudel2 network management framework (shared library)

The attached screenshoot comes up when network manager needs a password but is unable to bring up the prompt. Notice that the Connect button is greyed out.

Alan, make sure you upgrade properly. Right now you have packages installed with different versions. The fixes to NetworkManager to *avoid crashing* with ipw2200 have landed in Precise already; so running a full upgrade will likely fix this.

This doesn't mean that everything is fixed however; WPA-secured networks will still be unavailable for connection, because there is no way to tell whether the device supports it if the driver reports it doesn't. This needs to be fixed at the kernel level.

Isak Enström (isen) wrote :

#47:
For me, Wicd manages to connect to WPA secured networks, so either it "guesses" that the device supports it or it gets the info in another way.

Jools Wills (jools) wrote :

since this device does support wpa, isn't a quick workaround to override what is returned until it is fixed in the kernel ? otherwise. Considering precise release date, this needs to be fixed else networkmanager is useless for anyone with one of these cards.

Jools Wills (jools) wrote :

I have unfortunately little faith after a major issue I reported before natty release, which the fix was relatively simple, was never done, and is still broken and will remain so until natty is out of support, and then closed, yet be broken for all users who ever tried natty :/

that's completely unrelated of course, but a point of annoyance for me as I have to modify a ubuntu distribution I provide for a specific device to work around the issue, but it has left me with "bad vibes" about bugs in ubuntu - #762806 if you are interested.

Jools Wills (jools) wrote :

I realise that fixing it in nm is the wrong way of course. sorry for my previous message if it sounded unappreciative. Thanks for the work with this issue so far.

Download full text (3.8 KiB)

It should be fixed this week in NM, pending a freeze exception : the fix is
already upstream.
Le 20 mars 2012 07:11, "Jools Wills" <email address hidden> a écrit :

> I realise that fixing it in nm is the wrong way of course. sorry for my
> previous message if it sounded unappreciative. Thanks for the work with
> this issue so far.
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/908380
>
> Title:
> [ipw2200] nm-applet crashed with SIGABRT in g_assertion_message()
>
> Status in “linux” package in Ubuntu:
> Triaged
> Status in “network-manager” package in Ubuntu:
> Fix Released
>
> Bug description:
> In 12.04 Alpha 1.Restarted after installing updates.Noticed a dark
> radio signal meter.Clicked and saw that my wlan was
> disconected.Clicked on my wlan to reconnect.Then network manager
> crashed.Still have wireless connection to my router and the net.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: network-manager-gnome 0.9.1.90-0ubuntu6
> ProcVersionSignature: Ubuntu 3.2.0-6.12-generic 3.2.0-rc6
> Uname: Linux 3.2.0-6-generic i686
> ApportVersion: 1.90-0ubuntu1
> Architecture: i386
> Date: Sat Dec 24 06:38:48 2011
> DuplicateOf: https://bugs.launchpad.net/bugs/743485
> ExecutablePath: /usr/bin/nm-applet
> IfupdownConfig:
> auto lo
> iface lo inet loopback
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
> IpRoute:
> default via 192.168.15.1 dev eth1 proto static
> 169.254.0.0/16 dev eth1 scope link metric 1000
> 192.168.15.0/24 dev eth1 proto kernel scope link src 192.168.15.4
> metric 2
> NetworkManager.conf:
> [main]
> plugins=ifupdown,keyfile
>
> [ifupdown]
> managed=false
> NetworkManager.state:
> [main]
> NetworkingEnabled=true
> WirelessEnabled=true
> WWANEnabled=true
> WimaxEnabled=true
> ProcCmdline: nm-applet
> RfKill:
> 0: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> Signal: 6
> SourcePackage: network-manager-applet
> StacktraceTop:
> __kernel_vsyscall ()
> raise () from /lib/i386-linux-gnu/libc.so.6
> abort () from /lib/i386-linux-gnu/libc.so.6
> g_assertion_message () from /lib/i386-linux-gnu/libglib-2.0.so.0
> g_assertion_message_expr () from /lib/i386-linux-gnu/libglib-2.0.so.0
> Title: nm-applet crashed with SIGABRT in __kernel_vsyscall()
> UpgradeStatus: Upgraded to precise on 2011-12-10 (14 days ago)
> UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare
> nmcli-con:
> NAME UUID TYPE
> TIMESTAMP TIMESTAMP-REAL AUTOCONNECT
> READONLY DBUS-PATH
> MOT-1-6F 1 d44c5a39-d7d4-4109-8a35-961e8742f431
> 802-11-wireless 0 never yes
> no /org/freedesktop/NetworkManager/Settings/2
> Wired connection 1 490629c7-a813-46e7-9523-9d94f683b939
> 802-3-ethernet 1324730179 Sat 24 Dec 2011 06:36:19 AM CST yes
> no /org/freedesktop/NetworkManager/Settings/1
> MOT-1-6F 8b04a1cd-24e6-49af-8115-37138888e1f8
> 802-11...

Read more...

Jools Wills (jools) wrote :

excellent news - do you have any reference/commit id for the fix ? saves me git bisecting to try and locate at what point it broke, which I was considering doing this week.

Jools Wills (jools) wrote :

aah, a fix in nm rather than a kernel fix. I'll give it a try thanks.

Jools Wills (jools) wrote :

I built network-manager/network-manager-gnome packages with those patches in, and I am still unable to connect to my wpa network (my wireless network is disabled in the menu).

All that these patches do is to avoid crashing because of the ipw2200 driver not listing capabilities. Since the capabilities are listed as not supporting WPA (or anything, for that matter), the networks are disabled in the menu.

You may be able to connect anyway by using the "connect to hidden" functionality until this is fixed in the kernel.

Jools Wills (jools) wrote :

Sorry a misunderstanding then. When I posted in #49 I was referring earlier to the kernel not returning correct information about the hardware - then you referenced some patches and I assumed you meant they were a workaround (hence the comment about not having to git bisect). Ill debug it in the kernel then. The patches did seem somewhat unrelated (wpa ad-hoc stuff).

It's a related issue. The fact that this is missing from the kernel module triggers a crash in nm-applet. We've fixed this since it's obviously better to avoid crashing for no reason :)

Lars Storm (lars+ubuntu) wrote :

Small update, after installing the lastest upgrades per 2012-04-03 - straight after a clean install, this problem hit my netbook test install. I was able to fix it by installing the network-manager-gnome package.

Ubuntu 12.04 LTS (Precise Pangolin) Beta 2 - Desktop - AMD64
Samsung n210
Intel Atom N450 1.66 GHz
1GB DDR2

Jools Wills (jools) wrote :

note for those with the problem of not being able to connect to a wpa network on ipw2200 - I have put some packages on my a ppa - https://launchpad.net/~jools/+archive/ipw2200 that use wext instead of the nl80211 interface working around the problem. Would be nice if network manager could have a quick fix for this (checking for the ipw2200 hardware and then using wext instead). as it's clear no fix will make it into the kernel for precise

also see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/973241

Isak Enström (isen) wrote :

Thank you soo much Jools! Now I don't have to use Wicd anymore, it's working great!

Thanks Jools. Works now.

Just posting to say thanks very much for the ppa! My wireless can now recognise WPA again.

tags: added: kernel-key
To post a comment you must log in.