Ubuntu

NM | Edit Connections | Wired | Edit | IPv4 Settings | Method | "Shared to other computers" -> repeatedly connects and disconnects

Reported by Jo-Erlend Schinstad on 2011-10-03
180
This bug affects 32 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Medium
Unassigned

Bug Description

I have been using my laptop to share a wireless network with my desktop using a wired connection eth0. This has worked well in Natty, but in Oneiric, this no longer works properly. I'll provide the steps I followed:

1) clean install of Oneiric 64bit from October 2nd. (I've used several others too with the same results)
2) set up wireless. No problems.
3) select the wired interface in nm-connection-editor, edit and Method: shared with other computers in the IPv4 page.

What happens is that the network is configured and works, but only for a few seconds. Then the network goes into a loop of connect/disconnect. I can use the shared connection on the desktop to a certain degree, but it becomes extremely slow and things like IRC cannot be used since the connection is dropped every two seconds or so.

If I boot a Natty live session, this works perfectly using the exact same settings. I will attach my syslog.

Confirming; this is caused by IPv6 also triggering a separate start of sharing, which ends up failing. Sharing for IPv6 is not supported so this is just failing for now.

I'm marking this Triaged/Medium, will try to get this fixed as an update.

Changed in network-manager (Ubuntu):
status: New → Triaged
importance: Undecided → Medium

Are you sure? Because I did set IPv6 to ignore, and that did not fix the problem. If your diagnosis were correct, then that should've caused the problem to go away, shouldn't it?

My testing showed having IPv6 set to Ignore was working perfectly. If it doesn't work for you, maybe there's something else having an impact. Could you please attach the full NetworkManager log after reproducing the issue (with ipv6 ignore of course)?

The only gotcha for this is that you need to make sure dnsmasq is killed off before you start re-testing, because it *does* get started by NM... The issue is caused by the fact that it gets started twice with the same settings, the second time always fails, which triggers the connection to be marked as failed.

Setting the bug to incomplete now, if you find that it fixes the issue (note that we now ship network-manager-gnome 0.9.1.90-0ubuntu6 which defaults to ipv6 disable for new ad-hoc networks; although you will still need to apply the change manually to those already created), please set it to Fix Released or Invalid... If not and you can attach more information, then please set your bug back to New. :)

Changed in network-manager (Ubuntu):
status: Triaged → Incomplete
JazZ (misterj-home) wrote :

I have exactly the same problem. But this problem appears just today, whereas I have used my computer with no problems since less than one week.

During the install of ubuntu 11.10 (beta 2 daily one day before the release), an arror occured during the installation of my two computers. Its saids that the lan installation have not be done correctly. But the two computers (PC and laptop) worked well after that.

The PC concerned by this bug is nine and I have not tested other version of ubuntu for comparing.

There are lot of latencies during each requests and ssh connection are very difficult.

I have made the IPV6 to ignore and kilked dnsmasq with no issue.

JazZ (misterj-home) wrote :

I don't know why, but after having switched off the computer (by removing the wired cable from the electricity, not only by shuting down), the lan work well now. Something is got in memory even if the computer is switched off but not deconnected from the electricity. There is perhaps a relation with windows, because this bug appears just after restarting from windows.

lophie (lophesuicire) wrote :

Yes I confirm the bug exists even today with all updates. Sharing the network worked well for at least the last 3 releases of ubuntu. Basically I choose "Shared" in the dhcp server, Now the connection keeps connecting and disconnecting rapidly. That's all.

arr (alan-drop-share) wrote :

Same problem.
while connecting and disconnecting, nm-applet spits:
** (nm-applet:18917): WARNING **: _nm_object_get_property: Error getting 'Devices' for /org/freedesktop/NetworkManager/ActiveConnection/141: (19) Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist
** (nm-applet:18917): WARNING **: _nm_object_get_property: Error getting 'Connection' for /org/freedesktop/NetworkManager/ActiveConnection/141: (19) Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist
** (nm-applet:18917): DEBUG: old state indicates that this was not a disconnect 120
** (nm-applet:18917): DEBUG: going for offline with icon: notification-network-ethernet-disconnected

my network adapters:
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
04:06.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 09)

Disabling ipv6 in nm-applet does not solve any problem.

Florian Boucault (fboucault) wrote :

I just hit the bug but I don't know remember when my Oneiric was installed nor when the wired connection was created.
Setting IPv6 to ignore and sudo killall dnsmasq fixed the issue.

Alejandro Mery (amery) wrote :

killall dnsmasq + disabling ipv6 in nm-applet + reconnecting the wire solves the issue for me too

Changed in network-manager (Ubuntu):
status: Incomplete → Opinion
status: Opinion → Incomplete
Dave Gilbert (ubuntu-treblig) wrote :

It's affecting multiple people -> confirm
I've just had the same thing also, so also confirm (this includes setting IPv6 to ignore in the nm).

Changed in network-manager (Ubuntu):
status: Incomplete → Confirmed
Andrew Hocker (andrew-hocker) wrote :

I'm having the same issue. When I try the workaround, my bridged connection (via eth0) receives a 169.254.xx.xx address. Verified DHCP and wireless is not the issue on my network using alternate laptop which has Vista on it.

Luis Alvarado (luisalvarado) wrote :

Confirmed still happening. I have 4 NICs. 2 Wireless cards (Ralink and Broadcom) and 2 Wired cards (Intel and Realtek). In the beginning the problem was with ALL NICs that I use to share a connection. After a couple of days the problem was solved for the Wireless cards in some update. At least the problem was solved for them but the problem is still present when I try to use a wired connection as shared. If I try to share with it it starts the endless loop of connecting and disconnecting.

Does not matter which of the 2 cards I use to share (Neither Intel or Realtek will work if I start a share method with them). I have to literally stop them and remove the sharing connection.

Felix (apoapo) wrote :

Confirmed for gnome-shell in oneiric. Killing dnsmasq makes it work. Will it be fixed for precise?

shamun (shamun-toha) wrote :
Thomas Hood (jdthood) on 2012-07-03
summary: - [regression] sharing a network with other computers no longer works in
- oneiric
+ NM | Wired | Edit IPv4 Settings | Method | "Share with other computers"
+ a network does not work
summary: - NM | Wired | Edit IPv4 Settings | Method | "Share with other computers"
- a network does not work
+ NM | Wired | Edit | IPv4 Settings | Method | "Shared to other computers"
+ does not work
Thomas Hood (jdthood) on 2012-07-03
summary: - NM | Wired | Edit | IPv4 Settings | Method | "Shared to other computers"
- does not work
+ NM | Edit Connections | Wired | Edit | IPv4 Settings | Method | "Shared
+ to other computers" does not work
Thomas Hood (jdthood) on 2012-07-05
summary: NM | Edit Connections | Wired | Edit | IPv4 Settings | Method | "Shared
- to other computers" does not work
+ to other computers" -> repeatedly connects and disconnects
tags: added: precise
Marius B. Kotsbak (mariusko) wrote :

Jo-Erlend: do you still see this in Ubuntu Quantal? Could you please after this fails run in a terminal: "apport-collect 865001" so that we get all the system information attached.

Changed in network-manager (Ubuntu):
status: Confirmed → Incomplete
JazZ (misterj-home) wrote :

For me, the bug seems to have desapeard with the last Ubuntu. When I restart from windows, no problem occurs.

Launchpad Janitor (janitor) wrote :

[Expired for network-manager (Ubuntu) because there has been no activity for 60 days.]

Changed in network-manager (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments