Wireless hotspots do not remain connected with network-manager 0.9

Bug #830178 reported by Roland (Rolandixor) Taylor on 2011-08-20
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

This is supposed to be fixed in GNOME 3.2 (11.10) but it apparently is not. When you create an ad-hoc network, the system keeps reconnecting to it, but does not actually remain connected. (UPDATE: This only happens if reconnect automatically is chosen).

In the latest updates (with nm 0.9) the hotspot is created, but after about 30 seconds it disconnects. I will attach the output from nm-applet later.

I tested this on KDE as well, and it has the same problem. Seems the network is not getting an I.P address, and so it disconnects shortly after. I'm also sure it does not (and did not) happen on 11.04, as we have another system in the house using 11.04 and no problems there.

Nm-applet output: http://pastebin.com/LAEB9H1u

Changed in network-manager (Ubuntu):
status: New → Confirmed
description: updated
description: updated
summary: - Cannot create a wireless hotspot (ad-hoc network)
+ Wireless hotspots do not remain connected with network-manager 0.9

Has anyone looked at this bug? I think it is pretty serious and it should not be ignored.

Not being ignored (I maintain NM on Ubuntu for Canonical). No promises because I will need to do some testing (and then there would be the time it takes if it needs a fix), but I'll look at it tomorrow.

Changed in network-manager (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in network-manager (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High

Somehow this bug didn't get closed with the upload; regardless, the problem should be fixed by upgrading to network-manager-gnome 0.9.1.90-0ubuntu6 which should now be available in the archive.

Changed in network-manager (Ubuntu):
status: In Progress → Fix Released

Can you give me some detail on what was changed? I think I upgraded, but I don't seem to have recieved a fix :(. I think there might be something I need to do somewhere (some configuration problem or some old library or something?) to fix it on my system.

Please, I know you said it was fixed, but I still have the problem, and it is in fact worse than before because the networks do not even stay connected for a second. I would really love to know what to do to fix it on my system, or if I need to provide more information as it might be a farther reaching bug(?).

Changed in network-manager (Ubuntu):
status: Fix Released → Confirmed
Gary M (garym) on 2011-10-10
tags: added: oneiric regression-release

Please make sure you have network-manager-applet 0.9.1.90-0ubuntu6 installed; and if your ad-hoc network was created prior to this upload, you'll want to either change its settings to make sure IPv6 is set to Ignore; or delete it and re-create it with nm-applet (once it's upgraded).

Sorry for the trouble - I was still having problems for a while, but it seems after a complete reinstall, restarting the system, logging out and back in again (twice) and deleting all wireless networks, and finally creating a new one...

That the problem as has disappeared... except the problem seems to be with the "Hotspot" network created by the GNOME System Settings. It is created as using ipv6 automatically.

Changed in network-manager (Ubuntu):
status: Confirmed → Fix Released
Demonboy (jamie-followtheboat) wrote :

Can you explain to a simpleton like me HOW you update the applet? I do not understand what to do with the zipped file.

Demonboy (jamie-followtheboat) wrote :

Scrap that last comment. I HAVE 0.9.1.90 installed already and I still cannot connect to an ad hoc network (and I have set IPv6 to IGNORE). What next?

Ditto. I also have the updated 0.9.1.90-0ubuntu6 nm-applet installed on 11.10, IPv6 ignore, and am still having the same problem with ad-hoc networks instantly dropping the moment they are created. I've tried all the variants of security settings for the ad-hoc networks, nothing makes any difference. Thoughts?

Hey everyone.

I've managed to create ad hoc network. I use ubuntu 11.10 64bit, with nework-manager 0.9.1.90-0ubuntu5.1.
Here's my lspci -nnv | grep Network result
03:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
I use WPA & WPA2 Personal security and set password to 1234567890.

Hope this help.

If you're still having problems with this, please file new, separate bugs (after confirming that ipv6 is indeed set to ignore for that particular connection) and provide at the very least /var/log/syslog (though that should get attached automatically if you use 'ubuntu-bug network-manager'). This is likely now hitting some devices which don't properly support ad-hoc.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers