network-manager should not set offline mode when it manages no device

Bug #82335 reported by Mahmoud Kassem on 2007-01-30
334
This bug affects 6 people
Affects Status Importance Assigned to Milestone
knetworkmanager (Ubuntu)
Undecided
Unassigned
Nominated for Feisty by Przemek K.
Nominated for Gutsy by dav2dev
network-manager (Ubuntu)
High
Scott James Remnant (Canonical)
Nominated for Feisty by Przemek K.
Nominated for Gutsy by dav2dev

Bug Description

Binary package hint: epiphany-browser

Epiphany always starts with "Work Offline" checked

Version information:
Ubuntu Feisty

Sebastien Bacher (seb128) wrote :

Thank you for your bug. Do you use network-manager?

Changed in epiphany-browser:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info

yes, the network-manager package is installed.

are you online according to network-manager?

No, disconnected (no network device detected)

Might be a network-manager bug then. Why do you have it installed if you don't use it? Do you have any message printed on the command line if you start epiphany from there?

Mahmoud Kassem (mmkassem) wrote :

No, there are not any messages printed when opened from the terminal.
when I kill NetworkManager both gaim (bug #80985) and Epiphany start working online

I am not sure what ended up with network-manager installed, this Ubuntu installation is since 5.10 (upgraded every release) but most probably a dependency.

When I try to remove it, it says that ubuntu-desktop will also be removed. (I have both ubuntu-desktop and kubuntu-desktop installed)

Sebastien Bacher (seb128) wrote :

Looks like a network-manager problem

Changed in epiphany-browser:
assignee: desktop-bugs → nobody
importance: Undecided → High
status: Needs Info → Unconfirmed
Miguel Rodríguez (migrax) wrote :

I think I know what happens.

According to README.Debian in network-manager
"(...) Only devices that are *not* listed in /etc/network/interfaces or which have
been configured "auto" and "dhcp" (with no other options) are managed by NM. (...)"

So if all network devices are configured in the interfaces file, or if all extra devices are disconnected, network-manager reports that there is no connection.

I think network-manager should be patched to *monitor* static devices configured in the interfaces file, but refrain to mess with their configuration.

I don't know how easy/difficult this would be.

Scott Zawalski (cowbud) wrote :

Network manager should either somehow check to see if the user has an internet connection (Ping a server lookup some address) or it should allow the user to check mark something saying I AM CONNECTED.

Applications like gaim and evolution do not work properly due to this because they are set to monitor network manager's connection status.

To observe this behaviour set up a static IP.

Miguel Rodríguez (migrax) wrote :

I don't think is it necessary for NM to check that a static network connection is well configured. Checking if the link is up should be enough. I guess it is the administrator/user responsibility to assure that a static connection is properly configured.

To sum up, with a static connection NM should report:
* network connection if the link is up
* unconnected if it is down.

Scott Zawalski (cowbud) on 2007-02-06
Changed in network-manager:
status: Unconfirmed → Confirmed
description: updated
C de-Avillez (hggdh2) wrote :

Please see https://bugzilla.novell.com/show_bug.cgi?id=175896

This was reported last year, and a just-entered comment states NM will (at least) fully support PPP -- which is an advance. Currently, even if PPP is driven by nm-applet (or knetworkmanager), NM will still not find the PPP up, and report the whole system as offline.

On this bug: lets suppose, for the sake of argument, that I have a wired and a wireless interface, and the wired is set to hotplug (so that if nothing is plugged, it is not used).

Now, NM should still fully support a hot-pluggable interface, and recognise it when it is driven on. Not supporting it seems sort of silly.

digger vermont (digver) wrote :

<rant>
I think a lot of us have NM installed, whether or not we need or want it installed because ubuntu-desktop depends on it. This problem becomes more and more annoying as more programs check dbus for the network status as set by NM.
</rant>

A quick solution would be to have a script in /etc/network/if-up.d and if-down.d use dbus-send to set the network status. Unfortunately I haven't been able to figure out how to do it correctly.

I believe NM in Debian and Ubuntu is set to run the scripts in the /etc/network/if-updown directories. Since NM seems to be unaware of anything but itself, can it (NM) be configured or patched to NOT set the network status and instead use if-updown scripts send the message to dbus?

Onkar Shinde (onkarshinde) wrote :

This bug affects the network detection by gaim and liferea also. I am using a DSL router and my NIC is configured statically.
But network-manager can not detect connection.
1. Due to this gaim waits infinitely for connection unless I disable all accounts and enable them again.
2. Liferea always starts in offline more.

Adam McMaster (adammc) wrote :

About Gaim, you don't need to disable and re-enable all accounts, you can simply set the status to "Available" (e.g. by right-clicking on the notification area icon) and it'll connect.

Onkar Shinde (onkarshinde) wrote :

@Adam,

I followed your advice and it works. But it is still annoying. I have to manually set status to available for gaim to be able to connect.
What is more annoying is that I have disabled network-manager in my session properties and still the problem exists.

Luka Renko (lure) wrote :

We have similar report from KDE users as well: bug 86680. Kubuntu started to use n-m network status recently for KMail and several users complain that due to static connections, n-m claims network as offline (as it does not see the interface at all).

For test, I have changed debian/patches/05-debian_backend.patch and commented out blacklisting of devices with static code:
+ /* If the interface has no options other than just "inet dhcp"
+ * it's probably ok to fiddle with it.
+ */
+ for (curr_d = curr_device->info; curr_d; curr_d = curr_d->next) {
+ if (strcmp (curr_d->key, "inet")
+ || strcmp (curr_d->data, "dhcp" ))
+ blacklist = TRUE;
+ }

It looks it help for this particular bug, but further testing is required for potential side-effects of this change. I think we need to discuss this with Debian authors, as this patch is from Debian.

Luka Renko (lure) wrote :

Side-effect it that n-m will reissue dhcp call and potentially override static address. :-(

@Onkar,

Disabling network manager in your gnome session will not work as that is just the 'notification area' for the network-manager service. To disable network-manager, either uninstall it (which will break ubuntu-desktop package) or do this:

Stop network manager

sudo /etc/dbus-1/event.d/26NetworkManagerDispatcher stop
sudo /etc/dbus-1/event.d/25NetworkManager stop

Create two files with only the word 'exit' in them. These files are:

/etc/default/NetworkManager
/etc/default/NetworkManagerDispatcher

Hope that helps..

C de-Avillez (hggdh2) wrote :

Daniel -- yes, this will help people that have only static IPs. Since nm does not deal with it at all, we are all better off not to run it in this case.

But it does not help much when we have:

1. both static and auto (for example, a static wired, and an auto wireless)

For scenario (1) I can think of a network that requires one to use a specific IP; if this is good use or bad use -- it does not matter: It can be done, and it IS done.

2. both hotplug and auto (for example, a hotpluggable wired, and an auto wireless).

For scenario (2) I can give you my personal current experience with nm: for nm to correctly manage both my laptop wired and wireless interfaces (I have given up hope on PPP, BTW), I have to set both to auto.

Now, nm will recognise all of them fine. And it will try to bring BOTH up, and will set DHCP on BOTH of them. End result: one of them will come up, and the other will cause the logs to flood with DHCP failure messages, completely useless. This bothers me no end...

3. PPP in any form, model, or type.

For scenario (3)... well, nothing can be done with nm (except add a PPP stanza to the /etc/network/interfaces, so that we can still start it off nm).

nm is a good idea, but not yet all done. To have all programs depend on finding if a network is connected from nm is, right now, slightly absurd: (with the risk of boring repetition) how can we BASE network-awareness on something that CANNOT see all of the network interfaces?

The raw truth is we are depending on network-awareness on something that does not see all of the network. I simply cannot see the wisdom on this.

While I was still using SuSE, this had bothered me so much that I completely took out nm (as Daniel suggests). But this is obviously not a solution, methinks.

Onkar Shinde (onkarshinde) wrote :

Just for the record, this bug affects connectivity in gossip-telepathy also.

Just wanted to say I can confirm this. Still happening on my Herd5 Feisty install on a crappy old HP Omnibook 6100.
Possible (untested) solution is to go to System-->Preferences-->Sessions and remove Network Manager from the startup items. This will avoid breaking the ubuntu-desktop package by the removal of network-manager-gnome and will also leave the program available on the computer. Think I'll go and test it now :P

Jeff Fortin Tam (kiddo) wrote :

Gabriel, this will not work, because what starts with your gnome session is only the notification area icon that allows you to control NM. The NM daemon is still running system-wide in the background.

I suffer from this problem also because I use a staticly configured pppoe device. My eth0 is thus bound to 'dsl-provider' and unavailable for networkmanager, causing the session to start in offline mode

johanjpk (johan-stevon) wrote :

Same problem here I think. When I'm at work I use eth0 using dhcp no problem at all. When I'm at home I use eht1 which is my wireless device also using dhcp. Evolution and gaim say that they offline. Gaim I have to go offline/online to get it working. Evolution just going online.

Sitsofe Wheeler (sitsofe) wrote :

I'm seeing this too. The wonders of launchpad's dup detection lead me straight here by way of another bug when I tried to file a bug against evolution always being offline. I'm using a static IP on a wireless connection.

Jeff Fortin Tam (kiddo) wrote :

Just sharing a workaround for those of you who want to keep the same IP all the time but still use network-manager (I like network-manager). This is a workaround and not a solution to the problem:

telling your router/DHCP server (if you have one) to "reserve" an IP address based on the MAC address of your hardware network interface card. You will be using DHCP but your IP will not change, thus, in certain cases, eliminating the need for a static IP.

Matthew East (mdke) wrote :

Jeff - as I understand it, that doesn't help those of us who are seeing this bug because network-manager doesn't detect their perfectly standard interface, right?

Andrew Conkling (andrewski) wrote :

Jeff, also doesn't work for those of us that don't have a router that can do that kind of configuration. Don't I wish....

Jeff Fortin Tam (kiddo) wrote :

Yeah, that's why I call it a "workaround" "in some cases" and not a solution :) not everyone has this kind of functionality available, but those who do (and did not know that it existed) can use that as a temporary measure until this bug is fixed.

This is also a problem, as network manager doesn't handle WPA2 phase 2 properly and I need to use wpa-supplicant in order to access the wlan at my university. Tthe "if link is up, don't report offline" would work in this case.

Maybe networkmanager should receive all network connections as in ifconfig -a and set offline if and only if only loopback is up.

Martin Pitt (pitti) wrote :

I was just asked to look into this issue, taking.

Changed in network-manager:
assignee: nobody → pitti
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

I do think that this can and should be solved in a generic way, not using distro-specific tools. n-m should just check all existing network interfaces and consider those which are in 'up' state as active. It should also query the routing, check for the default route with highest metric and consider the device which has that one the 'default' device.

Martin Pitt (pitti) wrote :

Reassigning to Tollef, as per discussion with Scott.

Changed in network-manager:
assignee: pitti → tfheen
C de-Avillez (hggdh2) wrote :

Please see bug # 90267 for a possible interaction with ntpd.

Curtis Hovey (sinzui) wrote :

The issue is a little more complex, but it can still be said the NM is misbehaving. NM/gnome-network-manager failed to establish a connection to my home wifi after my upgrade to feisty. I switch to manual configuration for wifi only (leaving NM in charge of the lan that was not connected). Epiphany and Gaim both start in offline-mode and require some tinckering to get them to stay in online-mode.

Tollef Fog Heen (tfheen) wrote :

Not a knetworkmanager bug; knetworkmanager is just the frontend to network-manager

Changed in knetworkmanager:
status: Unconfirmed → Rejected
Tollef Fog Heen (tfheen) wrote :

 network-manager (0.6.4-6ubuntu3) feisty; urgency=low
 .
   * Manage some static devices we can understand. This should avoid the
     problem people are having with NM marking the machine as offline when
     it's just on static instead. LP #82335.

Changed in network-manager:
status: In Progress → Fix Released
Matthew East (mdke) wrote :

Tollef - this bug isn't only about static devices. If as your changelog suggests, this won't fix the problem with the interfaces considered as auto dhcp in /etc/network/interfaces, I suspect we should reopen this bug.

I understand this isn't fixed for everyone yet, but I just had to comment and say how happy I am that this finally works properly for me. I was a little worried that feisty was going to be released without this fixed, good to see some action..

Matthew East (mdke) wrote :

As requested on irc, I'm reopening the bug and attaching my /etc/network/interfaces

Changed in network-manager:
status: Fix Released → Unconfirmed
Matthew East (mdke) wrote :

As confirmed over irc, this bug is indeed fixed with Tollef's latest upload for my dhcp configured device too!

Changed in network-manager:
status: Unconfirmed → Fix Released
Richard Rickwood (rickwookie) wrote :

FWIW I can also confirm that this is fixed for my startic IP wired connection. NM now shows an active connection without me having to configure the adapter to use DHCP. Thanks!

Richard Rickwood (rickwookie) wrote :

Ok maybe it's not entirely fixed!

I set my staic address to 192.168.1.4, and NM seemed to happily show me as connected, which I was. However trying to connect to my machine from any other on the network (even just a ping) and there was no response. So I tried to ping myself and found that the requests were comming from 192.168.1.29 .
Checked my network setting again and it definately shows static at 192.168.1.4. Tried from another PC to talk to mine on 192.168.1.29 and it works. It looks like a DHCP assigned address but checking the DHCP client list from my router's setting page and there are none! Also I think the router's DHCP pool starts from 192.168.1.35.

What's going on?!

Richard Rickwood (rickwookie) wrote :

Ignore the last comment (sort of, it could still be looked at).

After restarting my IP address is now correctly set to 192.168.1.4.

pedro mg (pedro-mg) wrote :

i have an Asus P5v-VM DH motherboard with eth and wifi. My network hangs in an inscosistent way. I tryied it with wired and wifi only modes. Even removed NM to autostart in the Session. I can't even access the router webpage when the network comes down. Tried severall combinations in /etc/network/interfaces, but the connection drops with all combinations. Sometimes 10 minutes. Sometimes 1 hour. NM can make it active some times again. Not always. Where does NM store info and changes ? In interfaces file ?

Ross Burton (ross) wrote :

I use usbnet to connect to my PDA. Before NM 0.6.4-6ubuntu3 the usb0 device was ignored:

auto usb0
iface usb0 inet static
        address 192.168.0.200
        netmask 255.255.255.0

However now when I plug in my PDA, NM disables the interface. If I click on the applet I can select the usbnet device, but that then proceeds to drop the wifi connection to the outside world. Considering I had just done the usbnet connection so that I could get to the outside world from my PDA, that is useless.

How can I get NM to ignore this usb0 device?

C de-Avillez (hggdh2) wrote :

a sideway result of this fix is that Dialup/Connect to ppp via modem no longer works for me. My modem is a v620, and it is inserted in as /dev/ttyUSBx -- which gnome-ppp does not recognise. It was working before.

I've a system w/ 5 NICs, 4 of which are to be configured up, with no addresses.

/etc/network/interfaces
auto lo eth0 eth1 eth2 eth3 eth4
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0
iface eth0 inet static
address 10.9.8.228
netmask 255.255.255.192
gateway 10.9.8.254
iface eth1 inet manual
 up echo
iface eth2 inet manual
 up echo
iface eth3 inet manual
 up echo
iface eth4 inet manual
 up echo

At boot, when NetworkManager gets a hold of things, no interfaces are properly configured, and eth2 is the "better connection" (syslog attached). Here's ifconfig

eth0 Link encap:Ethernet HWaddr 00:18:8B:7D:3A:97
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:87 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:10244 (10.0 KiB) TX bytes:998 (998.0 b)
          Interrupt:17

eth1 Link encap:Ethernet HWaddr 00:15:17:15:AD:00
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:0 (0.0 b) TX bytes:492 (492.0 b)
          Base address:0xdcc0 Memory:e7e80000-e7ea0000

eth2 Link encap:Ethernet HWaddr 00:15:17:15:AD:01
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:155 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:9920 (9.6 KiB) TX bytes:316 (316.0 b)
          Base address:0xdce0 Memory:e7ec0000-e7ee0000

eth3 Link encap:Ethernet HWaddr 00:15:17:15:AD:02
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
          Base address:0xccc0 Memory:e7c80000-e7ca0000

eth4 Link encap:Ethernet HWaddr 00:15:17:15:AD:03
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
          Base address:0xcce0 Memory:e7cc0000-e7ce0000

Getting even more curious, after doing 'sudo /etc/init.d/networking restart' , the network configuration is as I would expect.

This is BROKEN.

Running kubuntu feisty, fully updated as of 20070328.

On a related note... I've managed to have my system behave nicely by adding the line "exit 0" to /etc/dbus-1/event.d/25NetworkManager just after the first block of comments.

This appears to prevent DBUS from telling NetworkManager to attack my system.

Gabriel Acevedo H. (gacevedo) wrote :

Hello,

 I have a problem with Fesity beta too. Everytime I start my computer it has no access to the Internet. I must do /etc/init.d/networking restart

That's annoying. I haven't this issue with 6.10 so I assume it's a nm related thing.

I have two interfaces (eth0, eth1). eth0 is connected to a Cable modem, so it's dhcp configured.
eth1 is connected to my local network, so it has an static configuration.

Any help with this will be appreciated.

 Thanks in advance.

Baishampayan Ghose (b.ghose) wrote :

I can confirm the bug. In my case, I have to do a /etc/init.d/networking restart to get the network to work after a reboot and even then GAIM doesn't connect automatically. This is indeed, a major bug in Feisty.

Jeffrey Baker (jwbaker) wrote :

I'm not an Ubuntu developer, but it seems to me that this bug is serious enough to block the 7.04 release. Networking only works on the most trivial configurations, and it will stop working on systems where Dapper and Edgy worked perfectly. In other words, it's a serious regression.

Larry Hartman (larryhartman50) wrote :

My network manager comes up ok; however, it only comes online after applets for KWeather, Korn, Kopete, and Akregator initialize. When I log in a get a flood of advisory messages on my screen telling me that I am not connected. My only wish for a fix is to have NM start first, and the others afterward.

Scott Dier (sdier) on 2007-03-30
Changed in network-manager:
status: Fix Released → Unconfirmed
James Purser (purserj) wrote :

Umm, how come this has been move to unconfirmed? Agreed that the fix hasn't worked, however the bug itself seems to have been conclusively proven.

As a courtesy to the package maintainer I leave him to choose the state
of the bug as he sees fit, I just want to ensure it gets back on his
radar by taking it away from fix released.

If the package maintainer would rather have a new bug written, let me
(Or BenAllen) know.

Thanks,

James Purser wrote:
> Umm, how come this has been move to unconfirmed? Agreed that the fix
> hasn't worked, however the bug itself seems to have been conclusively
> proven.
>

--
Scott Dier <email address hidden>

Andrew Conkling (andrewski) wrote :

Let's pick the more likely state of the bug and the maintainer can still change it. :)

Changed in network-manager:
status: Unconfirmed → Confirmed
James Purser (purserj) wrote :

Just dropping another note to say that after the latest round of updates on feisty, I am still getting the same behaviour.

I am still having to manually kill NetworkManager and rerun /etc/init.d/networking for my settings to be recognised.

[sigh]

pedro mg (pedro-mg) wrote :

My ASUS motherboard has 2 built-in network devices: eth and wlan. Wlan is built "under" USB.
The eth keeps coming down, so i connect via wlan0 (that comes down from times to times). All under Network Manager. I gave up not using it. It seems worst. I just have lo entrance in /etc/network/interfaces. The thing is, if epiphany (i use it 90% of the time) and gaim report no network, i open firefox and i do have network. When networking gets stable, Feisty will rock! ;)

MrAuer (mr-auer) wrote :

Bug is still there for me, tested on two machines with latest Feisty yesterday, fresh Beta install and then updated to latest packages. Both machines have 2 ethernet cards, other one is static LAN and other DHCP internet. On both machines, when booting up the DHCP connection is down, and when using Network manager to change configuration, always just one interface at a time works. Either LAN or DHCP, if you enable both at the same time, both interfaces lose their ip and connectivity. Network manager is certainly doing something odd there.

Olaf Leidinger (leidola) wrote :

Tested today on two machines, one with a LAN card, the other with a WLAN-card configured in network/interfaces to use dhcp, network doesn't come up after boot.

an "ifdown eth0 ; ifup eth0" in /etc/rc.local helps as a workaround, but networkmanager keeps complaining that there is no network connection.

Toltech (robert-toltech) wrote :

On a machine which has run various distributions (sarge, dapper), we had no problems with network. Using feisty and network manager, a minute after booting, the machine looses its ip number. This is before a gnome session is even started. Running dhclient solves the problem.

Lennart Hansen (lahansen) wrote :

Updated NM today, and it now shows my network as off line in the systray.

However it has an IP, and apps are working e.g NM is not blocking networking.

I'll upload my daemon.log which shows NM indeed works, and a screenshot of my tray icon shows the network is down.

Lennart Hansen (lahansen) wrote :

lhansen@lhansen-laptop:~$ aptitude show network-manager
Package: network-manager
State: installed
Automatically installed: no
Version: 0.6.4-6ubuntu5

Amazing Iceman (iceman-arenas) wrote :

I have the same problems you have, but I would like to add an observation:

- Using a Static IP will cause the applet to say Not Connected (as everyone has experienced already)
- Even when Using DHCP, NetworkManager Applet works randomly, sometimes it even says there are no network devices.
- ifconfig reports that my eth0 interface has been properly configured via DHCP.
- I can ping to any IP address successfully.
- Cannot ping to a hostname.

Could it be that the dns-client service (or whatever it's called) is not being re-initialized properly?

Rebooting the system will make it work again.

I hope this information helps.

octavianh (octavianh) wrote :

Not sure if this is a regression for NetworkManager but as of last update my icon in the notification area says "offline" but my static settings are working fine and I really do have a working internet connection. I believe this was fixed several times before.

Amazing Iceman (iceman-arenas) wrote :

I reinstalled NetworkManager and the applet, restarted the PC, and now the network works properly, but the applet says No Network Connection. I'm not touching it again or I'll endup loosing connectivity and having to reboot again.

One thing I did notice is that the wireless card on my system board has not been recognized.
I have an ASUS P5AD2-E Premium motherboard. It should be a:

Marvell Technology Group Ltd.
88W8310 and 88W8000G (Libertas)
802.11g WLAN

Anyone has an idea how to get it to work?

James Purser (purserj) wrote :

I've just done the latest round of updates and it appears to be applying the static IP settings correctly.

Tormod Volden (tormodvolden) wrote :

James, I think your (and many other's) comments belong to bug #92299, right? Although these two bugs may have a common origin,

Matthew East (mdke) wrote :

Latest upgrade has broken this again for me ("no network devices have been found"). Tollef - have your fixes been dropped?

Amazing Iceman (iceman-arenas) wrote :

I didn't have this problem until sometime yesterday. I remember receiving about 3 kernel updates and a lot of stuff.
It was after one of the updates that I started to notice the problem.

This problem has returned with the last update for me as well. However, for some reason - Evolution/etc is not being marked as 'offline'. I have the same issue as Matthew East: 'No network devices have been found'.

Sorry.. a few more details:

I'm running with one static eth0. This interface is not being reconfigured by network-manager. My internet connectivity doesn't seem affected.

Amazing Iceman (iceman-arenas) wrote :

In my case, after I applied the new update from about 3 hours ago, the NetworkManager Applet shows no interfaces, and always says "Not Connected".
The NetworkManager application shows the interfaces, and if I try to disable and enable any of the two interfaces (eth1 and eth0), I would loose DNS client functionality (IP based communication still works). My only choice after this happens has been to reboot. If someone could tell me what's the service acting as the DNS client on Feisty, and how to restart it, I could look deeper into the problem.

Tom Bigwood (veediot) wrote :

I can't connect to Gaim at all when using a static IP address now. I have a wireless interface and a wired interface. The wireless is and should be managed by NetworkManager. The wired interface is managed by /etc/network/interfaces so that I can use a static IP address at work. While at work, I cannot connect to Gaim, even by selecting 'Available'. Evolution has intermittent problems, yet Liferea works fine. Killing NetworkManager and restarting /etc/init.d/networking does not solve the problem.

Tom Bigwood (veediot) wrote :

Scratch that. My issue was a weird router issue.

Please try the source package at the following URL, it should solve this problem:

    http://people.ubuntu.com/~scott/packages/

If you've never built a package from source before, grab those three files into an empty directory, and use the following commands:

    $ sudo apt-get build-dep network-manager
    $ sudo apt-get install fakeroot
    $ dpkg-source -x network-manager_0.6.4-6ubuntu7.dsc
    $ cd network-manager-0.6.4
    $ dpkg-buildpackage -rfakeroot -b -uc -us
    $ cd ..
    $ sudo dpkg -i *.deb

Then restart your computer.

C de-Avillez (hggdh2) wrote :

working for wired interface. Will test wireless now.

C de-Avillez (hggdh2) wrote :

Correctly shows connected icon for both wired/wireless, at least here.

Brian Harkness (maestro-bwh) wrote :

Funny, I did that whole thing. Everything looked fascinating as it rolled on by in the terminal. Learned a bit on how to make a debian package from a source,

but it all ended up doing the same thing with (K)network manager showing no connection, even though I have a (static) wireless one. This isn't a bid deal mind you... it is just silly that I went from having a nice little wireless bar graph since I started using Feisty when it first came out to now after it is in Beta, I have something that looks like a mouse pad with a mouse sitting on it.. and a red X of course. It should just be fixed in the next few updates, so if there is a connection, regardless if it is static, wired, or wireless, it shows that like it did before.

I use Kubuntu, but I am under the assumption that knetwork manager is simply a front end for network manager. I reinstalled knetwork manager anyway after all of this just to see. Nope.

Went to Kwifimanager... as I have a desktop and don't need to roam around. I just need to see that I am connected when I boot.

I just uninstalled my network manager I dont see any need of it.

Tom Bigwood wrote:
> I can't connect to Gaim at all when using a static IP address now. I
> have a wireless interface and a wired interface. The wireless is and
> should be managed by NetworkManager. The wired interface is managed by
> /etc/network/interfaces so that I can use a static IP address at work.
> While at work, I cannot connect to Gaim, even by selecting 'Available'.
> Evolution has intermittent problems, yet Liferea works fine. Killing
> NetworkManager and restarting /etc/init.d/networking does not solve the
> problem.
>
>

Amazing Iceman (iceman-arenas) wrote :

This and other problems must annoy many of us, but that's why I downloaded the Beta version:
To help solve of these problems, and make Ubuntu a better O.S..
And while you're at it, you get to learn a lot about the way it works internally.
Uninstalling something because it doesn't work, doesn't really help to reach any of these goals.

When you have a problem with other O.S., usually you'll have to wait for the "fix", who knows how long.
If you wanted fixed immediately, you'll have to pay their programmers to fix it (really!!!).

Here it's different:
- You submit a bug, and if it's really caused by the O.S., the problem could get fixed within a few hours.
- If the problem is caused by a bad configuration, you'll get free advise on how to solve it.

Now I'm being helped, but maybe tomorrow I'll get to help someone else.

I'm going to try the solution above, and I'll report back as soon as I get to test it.

Patience People!!!

bloozman (bloozman) wrote :

I uninstalled it because 1. it doesnt work 2. I didnt need it it was
part of the default installation. If I need that application then I will
install it and try to fix it

Amazing Iceman wrote:
> This and other problems must annoy many of us, but that's why I downloaded the Beta version:
> To help solve of these problems, and make Ubuntu a better O.S..
> And while you're at it, you get to learn a lot about the way it works internally.
> Uninstalling something because it doesn't work, doesn't really help to reach any of these goals.
>
> When you have a problem with other O.S., usually you'll have to wait for the "fix", who knows how long.
> If you wanted fixed immediately, you'll have to pay their programmers to fix it (really!!!).
>
> Here it's different:
> - You submit a bug, and if it's really caused by the O.S., the problem could get fixed within a few hours.
> - If the problem is caused by a bad configuration, you'll get free advise on how to solve it.
>
> Now I'm being helped, but maybe tomorrow I'll get to help someone else.
>
> I'm going to try the solution above, and I'll report back as soon as I
> get to test it.
>
> Patience People!!!
>
>

Have uploaded the fixed packages for this.

The same change for Kubuntu is currently in the works

Changed in network-manager:
assignee: tfheen → keybuk
status: Confirmed → Fix Released
MartinE (martin-engbers-gmx) wrote :

Although supposedly duplicates of this one, neither bug #97520 nor bug #97557 are fixed on my feisty system, running Gnome and network-manager 0.6.4-6ubuntu7. It seemed to work after upgrading to 0.6.4-6ubuntu7, but after the next restart, it was just the way it was before.

Amazing Iceman (iceman-arenas) wrote :

Thank you for the latest update. It seems to have helped this time to some extent.

 I'm currently using a Static IP on eth0.
If I switch to Roaming Mode on eth0, it will get it's DCHP configuration properly, there would be network connectivity, but only via the IP address; no more DNS resolution.
My system has 2 NICs. I'm not using eth1 (configured to use dhcp, but it's not connected to the network, so it gets assigned 169.254.7.83 by the system).

If eth1 is connected and I disable Roaming Mode on eth0 (to use static IP again), IP traffic tries to use eth1 (which got that bogus IP), resulting in a Destination Host Unreachable error.

If I disable eth1, then IP routing works properly, but still, no more DNS client resolution.

Courious to notice that even after disabling eth0 in network-admin, I can still ping my router, ifconfig still shows it as being in use.
route -n still shows a local route for eth0, but the default route switches to eth1.

The only way to get DNS Client resolution would be to reboot (unless there's a service I could restart)

I would like to suggest that network-admin gets an APPLY button, instead of just acting everytime an interface is checked or unchecked. There should also be a way to select which interface should define the default route.

Also the network-manager applet should monitor all interfaces, including those with static IPs, so it's able to report when physical Link is lost, and also report configuration information for each interface. And instead of Radio selection, it would be more consistent to use check selection to enable/disable a connection.

Otherwise, its current random behavior is not appealing at all.

I'm still thankful for the help provided here.

x (xk2c-deactivatedaccount) wrote :

i am using nm with dhcp configured in /e/n/i

Version: 0.6.4-6ubuntu7

solved the "offline" problem for me

sittisal (sittisal) wrote :

Hi, i'm using Gnome-PPP and wvdial to connect to internet with my Nokia mobile (because the PPP utility of Gnome Network doesn't support personalized modem init strings), and Network Manager tells to other applications (Gaim, Liferea, Epiphany) that i'm not online. So i think that this bug affects also Dial-up PPP connections.

I think that in Gutsy whe should focalize on network configuration, expecially on:
1) PPPoE GUI
2) Ability tu use Network Manager with WPA AND Static ip (or personalized dns) and not WPA OR Static ip
3) PPP dialup GUI, with the ability to detect modems, use personalized init strings, use personalized dns.

In this state, Network Manager break things and Gnome Network Utility missing functionality.

Same issue here...I'm getting it in Debian Unstable though :S

Was working fine until recently.. Now my interface, previously recognised by NetworkManager (and configured, working fine) doesn't appear in the applet ("No network devices have been found").

Things I've done recently which might have caused it:
- reconfigured using network-admin, changing from DHCP to Static (and back again, shortly after)
- apt-get upgraded (more likely, I guess!)

bloozman (bloozman) wrote :

it seems to be a gtk font issue or at least a gtk issue involving
redrawing. it just fluctuates back and forth between 2 different sizes
of window. my quick cure is I keep browse open and it stops. but there
should be a fix for this.

Pete Martin wrote:
> Same issue here...I'm getting it in Debian Unstable though :S
>
> Was working fine until recently.. Now my interface, previously
> recognised by NetworkManager (and configured, working fine) doesn't
> appear in the applet ("No network devices have been found").
>
> Things I've done recently which might have caused it:
> - reconfigured using network-admin, changing from DHCP to Static (and back again, shortly after)
> - apt-get upgraded (more likely, I guess!)
>
>

bloozman (bloozman) wrote :

that was the wrong bug i responded to

Pete Martin wrote:
> Same issue here...I'm getting it in Debian Unstable though :S
>
> Was working fine until recently.. Now my interface, previously
> recognised by NetworkManager (and configured, working fine) doesn't
> appear in the applet ("No network devices have been found").
>
> Things I've done recently which might have caused it:
> - reconfigured using network-admin, changing from DHCP to Static (and back again, shortly after)
> - apt-get upgraded (more likely, I guess!)
>
>

dav2dev (gin18) wrote :

sittisal wrote:
>Hi, i'm using Gnome-PPP and wvdial to connect to internet with my Nokia mobile (because the PPP utility of >Gnome Network doesn't support personalized modem init strings), and Network Manager tells to other >applications (Gaim, Liferea, Epiphany) that i'm not online. So i think that this bug affects also Dial-up PPP connections.
-----------------

Exactly the same here with gutsy. If i kill nm then the programs open online.

Tessa Lau (tlau) wrote :

I'm still seeing this problem on a recent upgrade from Hardy -> Ibex. Single NIC, configured for a static IP using /etc/network/interfaces. Network manager starts up and its tooltip says "No network connection"; it shows the icon with the red and white X in it. Pidgin/Epiphany/Firefox all start in offline mode.

James (boddingt) wrote :

I have been getting this with Feisty, Hardy and Intrepid. The nic is not recognised at install time. It is an old isa ne2000. I add the module name and options to /etc/modules then configure /etc/network/interfaces to use dhcp. When the machine boots it has network connectivity. Like Tessa reported I have a problem with programs saying they are in offline mode even though the network is working.

/etc/network/interfaces
auto eth0
iface eth0 inet dhcp

I uninstall network manager and no more problems.

Ali Moreno (r3c4ll) wrote :

If I want use bridges (for example to use virtlib) i must disable network manager or i can use it for(whit) that?

Alberto Jovito (thedemon007) wrote :

I have a wifi 3dsp card and use 3dsp Wifi radar instead network manager in ubuntu 10.10 and have the same problem

Vanessa Lee (vanessax) wrote :

For Evolution, it could help if Evolution checks if the network is actually down or up instead of just relying on Network Manager.

Also Evolution should have an override to always assume network is up (don't check with NM at all).

To post a comment you must log in.