Network interface not configured

Bug #803985 reported by William Lusche on 2011-06-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Fresh install of Ubuntu 10.04 build, cannot connect to 2wire 2701 gateway using Firefox "http://192.168.1.254" or "http://homeportal/setup" .
How do I connect to internet with Ubuntu through this gateway ??

I have reset the 2701 Gateway via hardware reset switch and soft reset using "http://192.168.1.254"on Windows.
Windows to Gateway 2701 is working fine and I can access the 2wire homeportal with http URL's above with no issues, but once I boot with Ubuntu `0.04, I cannot connect at all.
Ubuntu terminal commands show network card, but not able to reach network error message.

I love Ubuntu at work, now trying to convert my family from Windows to Ubuntu at Home !!!

Michael Basse said on 2011-06-26: #1
please post the output of "ifconfig"
William Lusche said on 2011-06-29: #2

Hi Michael,
Here is some Ubuntu Network commands with some info for debugging this Ubuntu to 2Wire Gateway issue:
bill@ubuntu:~$ ifconfig
lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:76 errors:0 dropped:0 overruns:0 frame:0
          TX packets:76 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5840 (5.8 KB) TX bytes:5840 (5.8 KB)
bill@ubuntu:~$
bill@ubuntu:~$ iwconfig
lo no wireless extensions.
bill@ubuntu:~$
bill@ubuntu:~$ ping 192.168.1.254
connect: Network is unreachable
bill@ubuntu:~$
bill@ubuntu:~$ lspci
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8500 GT] (rev a1)
03:00.0 Ethernet controller: Atheros Communications AR8151 v1.0 Gigabit Ethernet (rev c0)
bill@ubuntu:~$
bill@ubuntu:~$ dmesg | grep -i "net"
[ 0.000000] Transmeta GenuineTMx86
[ 0.004133] Initializing cgroup subsys net_cls
[ 0.160839] NET: Registered protocol family 16
[ 0.186874] NetLabel: Initializing
[ 0.186875] NetLabel: domain hash size = 128
[ 0.186877] NetLabel: protocols = UNLABELED CIPSOv4
[ 0.186885] NetLabel: unlabeled traffic allowed by default
[ 0.234365] NET: Registered protocol family 2
[ 0.235182] NET: Registered protocol family 1
[ 0.248140] audit: initializing netlink socket (disabled)
[ 0.305575] NET: Registered protocol family 10
[ 0.306138] NET: Registered protocol family 17
[ 7.579615] type=1505 audit(1309319910.768:3): operation="profile_load" pid=670 name="/usr/lib/NetworkManager/nm-dhcp-client.action"
[ 8.365914] type=1505 audit(1309319911.556:7): operation="profile_replace" pid=930 name="/usr/lib/NetworkManager/nm-dhcp-client.action"
bill@ubuntu:~$
bill@ubuntu:~$ dmesg | grep -i "eth"
bill@ubuntu:~$
bill@ubuntu:~$ ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
bill@ubuntu:~$
bill@ubuntu:~$ dmesg | grep -i "eth"

Thanks, Bill

affects: gnome-nettool (Ubuntu) → ubuntu
Gary M (garym) on 2011-07-01
tags: added: lucid
RedSingularity (redsingularity) wrote :

Assigning package.

affects: ubuntu → network-manager (Ubuntu)
William Lusche (blusche) wrote :
Download full text (6.3 KiB)

Here is additional info from Ubuntu on this necork connection issue:

bill@ubuntu:~$ ping 192.168.1.254
connect: Network is unreachable
bill@ubuntu:~$ ping 192.168.0.1
connect: Network is unreachable
bill@ubuntu:~$ lspci
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8500 GT] (rev a1)
03:00.0 Ethernet controller: Atheros Communications AR8151 v1.0 Gigabit Ethernet (rev c0)
bill@ubuntu:~$ ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
bill@ubuntu:~$ dmesg | grep -i "net"
[ 0.000000] Transmeta GenuineTMx86
[ 0.004133] Initializing cgroup subsys net_cls
[ 0.160839] NET: Registered protocol family 16
[ 0.186885] NetLabel: Initializing
[ 0.186887] NetLabel: domain hash size = 128
[ 0.186888] NetLabel: protocols = UNLABELED CIPSOv4
[ 0.186896] NetLabel: unlabeled traffic allowed by default
[ 0.234369] NET: Registered protocol family 2
[ 0.235188] NET: Registered protocol family 1
[ 0.248148] audit: initializing netlink socket (disabled)
[ 0.305577] NET: Registered protocol family 10
[ 0.306140] NET: Registered protocol family 17
[ 0.307169] misc network_throughput: hash matches
[ 7.608793] type=1505 audit(1309802959.800:3): operation="profile_load" pid=698 name="/usr/lib/NetworkManager/nm-dhcp-client.action"
[ 8.445922] type=1505 audit(1309802960.636:7): operation="profile_replace" pid=950 name="/usr/lib/NetworkManager/nm-dhcp-client.action"
bill@ubuntu:~$ ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
bill@ubuntu:~$ sudo lshw -c
[sudo] password for bill:
Hardware Lister (lshw) - B.02.14
usage: lshw [-format] [-options ...]
       lshw -version

 -version print program version (B.02.14)

format can be
 -html output hardware tree as HTML
 -xml output hardware tree as XML
 -short ...

Read more...

Thomas Hood (jdthood) wrote :

Perhaps you need to click on the network indicator and enable networking?

Have you solved this problem in the meantime?

summary: - Fresh install of Ubuntu 10.04 build, cannot connect to 2wire 2701
- gateway using Firefox "http://192.168.1.254" or
- "http://homeportal/setup".
+ Network interface not configured
Thomas Hood (jdthood) on 2012-06-30
Changed in network-manager (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for network-manager (Ubuntu) because there has been no activity for 60 days.]

Changed in network-manager (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers