NetworkManager crashed with SIGSEGV in g_type_instance_get_private()

Bug #797868 reported by Andreas Moog on 2011-06-15
658
This bug affects 128 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
High
Mathieu Trudel-Lapierre
Oneiric
High
Mathieu Trudel-Lapierre

Bug Description

Binary package hint: network-manager

I switched a wired connection from dhcp to manual configuration and NM crashed.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: network-manager 0.8.9997+git.20110614t173923.b4a72d1-0ubuntu1
Uname: Linux 3.0.0-999-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CRDA: Error: [Errno 2] No such file or directory
Date: Wed Jun 15 20:22:19 2011
ExecutablePath: /usr/sbin/NetworkManager
Gconf:

InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Release amd64 (20110426.1)
IpRoute:
 default via 192.168.178.1 dev eth0 proto static
 169.254.0.0/16 dev eth0 scope link metric 1000
 192.168.178.0/24 dev eth0 proto kernel scope link src 192.168.178.58 metric 1
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.

 eth1 no wireless extensions.
Keyfiles: Error: [Errno 2] No such file or directory
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
PciNetwork:

ProcCmdline: NetworkManager
ProcEnviron: PATH=(custom, no user)
RfKill:

SegvAnalysis:
 Segfault happened at: 0x7fc27e5725c1 <g_type_instance_get_private+33>: cmpq $0x0,(%rdi)
 PC (0x7fc27e5725c1) ok
 source "$0x0" ok
 destination "(%rdi)" (0xaaaaaaaaaaaaaaaa) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: network-manager
StacktraceTop:
 g_type_instance_get_private () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 nm_agent_manager_save_secrets ()
 ?? ()
 ?? ()
 ?? ()
Title: NetworkManager crashed with SIGSEGV in g_type_instance_get_private()
UpgradeStatus: Upgraded to oneiric on 2011-06-11 (3 days ago)
UserGroups:

Andreas Moog (ampelbein) wrote :

StacktraceTop:
 g_type_instance_get_private (instance=0xaaaaaaaaaaaaaaaa, private_type=34397696) at /build/buildd/glib2.0-2.29.8/./gobject/gtype.c:4494
 nm_agent_manager_save_secrets (self=0xaaaaaaaaaaaaaaaa, connection=0x0, filter_by_uid=1, uid_filter=1000) at nm-agent-manager.c:1155
 update_auth_cb (self=<value optimized out>, context=0x20f3470, sender_uid=1000, error=0x0, data=0x7fc274006b60) at nm-settings-connection.c:1116
 pk_auth_cb (chain=0x20d8040, chain_error=<value optimized out>, context=0x20f3470, user_data=<value optimized out>) at nm-settings-connection.c:875
 nm_auth_chain_check_done (call=0x20bcbe0) at nm-manager-auth.c:243

Changed in network-manager (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Changed in network-manager (Ubuntu):
status: New → Confirmed

We got plenty of duplicates already, and the last duplicate is against 0.8.9997+git.20110721t045648.36db194-0ubuntu1 which seems to indicate there's still an issue in the latest upload of NM... perhaps this is actually a bug in nm-applet though.

Assigning to myself, this should get fixed asap.

visibility: private → public
Changed in network-manager (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Bhoemen Wood (wood-bhoemen) wrote :

I just had this problem while changing IPV4 to Shared to other computers on the latest daily build

tags: added: iso-testing
Changed in network-manager (Ubuntu Oneiric):
status: Confirmed → Triaged
Jamie Pocas (pocas-jamie) wrote :

I was able to segfault in the same function by simple renaming my ethernet connection from "Wired connection 1" to "Local Area Network".

Paul Hoell (hoellp) wrote :

And i was doing nothing and got exactly the same crash report.

NM was NOT really crashing though...

tags: added: bugpattern-needed
Patrick T. (p1703) wrote :

I did only rename my "Wired Connection 1" (Ethernet) to the german word "Kabelnetzwerk" - some seconds after that, Network Manager crashed, shortly after displaying (OSD) that I am connected.

I got this error when I renamed my ethernet connection from "Wired Connection 1" to "Ethernet - Auto"

Tokamek (tokamek) wrote :

I got this error when I renamed by ethernet connection from "Wired Connection 1" to "Wired Connection".

I came across this error when trying to connect to my dorm's Ethernet, and then switching to wireless when I couldn't get it to work.

Abdelaziz Yakout (yooozy) wrote :

I got it while renaming my connection

Kate Stewart (kate.stewart) wrote :

Bumping up the importance on this one based on number of folks affected and duplicate bugs.

Changed in network-manager (Ubuntu Oneiric):
importance: Medium → High
tags: added: rls-mgr-o-tracking

Well, I can certainly acknowledge the issue exists, because I was able to get one crash; but I can't seem to make it crash again in a debugger. There's a possible patch but so far it's difficult to verify it correctly fixes the issue, because it's so hard to reproduce.

tags: removed: bugpattern-needed
tags: added: bugpattern-written

I've had big difficulties with my network after yesterdays updates. The network icon disappear and I'm not able to connect to any networks. They also don't appear in ifconfig. I did a clean install from oneiric 64bit from September 20th and now I'm able to connect, but there are still problems. I'm notified continuously that the network has been setup and then taken down. Other than that, it seems to be working.

I am using the laptop to share a wireless connection with another computer using a wired connection.

Jo-Erlend; please file a separate bug. What you're describing doesn't sound like the same issue at all, and instead looks like it might be related to bug 855171. Please see that bug report and use the workaround/fix in its description; and if this doesn't completely fix your issue, file a new bug report (and comment here with the bug number).

Changed in network-manager (Ubuntu Oneiric):
status: Triaged → In Progress
Shyam (reddy-shyam) wrote :

Thanks Mathieu. I had the same issue as pointed by Jo-Erlend. I believe it resulted because of whats mentioned in bug 855171. Will post back if its resolved.

Shyam (reddy-shyam) wrote :

Hi Mathieu, I confirm the fix mentioned on bug report 855171 indeed resolves the issue. Thanks again for pointing in right direction.

This was fixed in the last NM upload, but despite triple-checking I seem to have made a mistake:

This bug was fixed in the package network-manager - 0.9.1.90-0ubuntu1

---------------
network-manager (0.9.1.90-0ubuntu1) oneiric; urgency=low

  * New upstream release. (LP: #855592)
    - core: print textual desc for reason codes on device deactivation too
    - supplicant: Don't leak secrets, even if they're probably invalid
    - core: storing timestamps also for VPN connections (rh #725353)
    - wifi: remove some dead code
    - ppp: pass novj through to pppd
    - monitor: Use nl_socket_alloc() instead of nl_socket_alloc_cb()
    - core: Fix check for failure in translating link name to ifindex
    - netlink: fix flags use in nm_netlink_route_add
    - core: Fix leaks if address parsing fails while setting mac
    - core: fix leaked address structure after parsing mac address
    - ip6: various leak fixes and sanity checks
    - keyfile: fix two bugs for updating/writting a keyfile
    - sharing: fix handling of rule negation (debian #638995)
    - cli: print 'Permissions' property of NMSettingConnection setting
    - cli: add missing GSM bands for GSM setting
    - cli: add 'nmcli con delete' command for removing configured connections
    - cli: nm_access_point_get_bssid instead of nm_access_point_get_hw_address
    - dnsmasq: use '@interface' for link-local DNS servers in dnsmasq config
    - settings: preserve agent secrets the right way
  * debian/patches/libnl3-support-0fe8c80.patch: dropped, included upstream.
  * debian/libnm-util2.symbols: add new secrets symbols:
    - nm_connection_clear_secrets_with_flags
    - nm_settings_clear_secrets_with_flags
  * debian/patches/ipv6-dont-block-ipv4.patch: refreshed, rework to follow
    upstream review and recommendations.
  * debian/patches/lp767868_refcount_default_wired_512a0f8.patch: correct ref
    counting of the default wired connection when it's re-saved once changed
    from the original default values. (LP: #767868)
  * debian/patches/secrets_delete_conn_leak_e39449c.patch: cherry-pick upstream
    fix of a leak of the connection object when secrets are deleted for a
    connection.
 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 22 Sep 2011 12:08:51 -0400

Changed in network-manager (Ubuntu Oneiric):
status: In Progress → Fix Released
Robert D. Martin (ets3rodamar) wrote :

I just discovered that the error message in question here appeared when I changed the name of a not yet well functioning (the mainboard) ethernet connection, but the message did not appear when I changed the name of the actually well functioning/defined and in use ethernet connection (a PCI adapter ethernet connection).

Is that perhaps a significant differentiation?

To post a comment you must log in.