[testcases] Networking / NM Laptop Test section needs a revision

Bug #731737 reported by Mark Nighswonger on 2011-03-09
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: network-manager

It appears that the Networking section for Laptop Testing, http://testcases.qa.ubuntu.com/Plans/LaptopTesting , is outdated and needs to be rewritten by someone who knows what needs to be tested and how. The current test would fail every time as written. There is no longer a computer icon, so that may be an indication of how old this version was testing for. This is the section that will fail:
Verify Release of Device
Case ID: hcn-002
    In the terminal, run sudo ifdown [interface] where [interface] is the interface name, above.
  * In the terminal, run ifconfig and verify that only the loopback device ("lo") is listed.*
There is always at least four devices listed. Apparently a knowledgeable person can tell that the device is up or down but that is not what this question asks for. Someone tell me what we want and I will be glad to rewrite it. If we are looking for a device that is up or down, we need to write that in plain english so anyone can do this. I tried to address this as a question but was recommended that I file a bug.

1)lsb_release -rd
Description: Ubuntu Natty (development branch)
Release: 11.04

2)apt-cache policy pkgname
N: Unable to locate package pkgname
Don't know where in the software center this information is.

3) I expected to test this application and give good, useful, feedback.

4) I could not perform a useful test because of outdated testing procedures.

Mark Nighswonger (marknigh) wrote :

Verify Release of Device

Case ID: hwn-002

    Right-click the NetworkManager (bars) icon. (Someone updated this part)

    Uncheck the box Enable Wireless.

    In the terminal, run ifconfig and verify that only the loopback device ("lo") is listed. (This is still the same!)

Is this just my laptop or are others failing this as well?

Mark,

Thanks for the input! I'll mark this Triaged/Low, although it's important to have the tests and documentation clear and precise, it doesn't actually affect functionality ;)

I can't review the test cases for the Networking section of that page just *yet*, but I expect to have time to do so before the Natty release, so I'll also assign this to myself to work on as soon as I have a minute for it.

In the meantime, if you're interested in testing NetworkManager and how well it works for your system, you might want to try following the use cases here: http://testcases.qa.ubuntu.com/Applications/NetworkManager

I know those might also be slightly outdated even if they were written for Maverick, given the fairly important UI changes we've done for Natty. Don't hesitate to report the issues you find here (or file new bugs for issues in functionality).

Thanks in advance!

Changed in network-manager (Ubuntu):
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
summary: - Network-Manager Laptop Test is outdated and useless as is.
+ [testcases] Networking / NM Laptop Test section is outdated

While you're at it, please review the cabled network test cases hcn-001, hcn-002, and hcn-003 at http://testcases.qa.ubuntu.com/Hardware/Network/Cabled

Unassigning from myself because these will need an overhaul anyway, but it's not on my todo list for now (seeing as there is a lot of work left even just for the development and maintenance for NM). However, you are very welcome to update the testcases appropriately.

Changed in network-manager (Ubuntu):
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody

Hi Mathieu,
I will get with Sergio Zanchetta on this. All the laptop testing has been
moved into, http://laptop.qa.ubuntu.com/ , the laptop testing tracker. All
the information still needs to be updated.
Will the functions of Network Manager change drastically? Do you have an
estimate of completion of the developmental changes? I will probably do some
interim updating because I don't think the test is usable in it's current
state.
I will get back to you after I hear from Sergio.
Thanks,
Mark

On Thu, Jun 30, 2011 at 7:27 AM, Mathieu Trudel-Lapierre <mathieu.tl@
gmail.com> wrote:

> Unassigning from myself because these will need an overhaul anyway, but
> it's not on my todo list for now (seeing as there is a lot of work left
> even just for the development and maintenance for NM). However, you are
> very welcome to update the testcases appropriately.
>
> ** Changed in: network-manager (Ubuntu)
> Assignee: Mathieu Trudel-Lapierre (mathieu-tl) => (unassigned)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/731737
>
> Title:
> [testcases] Networking / NM Laptop Test section is outdated
>
> Status in “network-manager” package in Ubuntu:
> Triaged
>
> Bug description:
> Binary package hint: network-manager
>
> It appears that the Networking section for Laptop Testing,
> http://testcases.qa.ubuntu.com/Plans/LaptopTesting , is outdated and needs
> to be rewritten by someone who knows what needs to be tested and how. The
> current test would fail every time as written. There is no longer a computer
> icon, so that may be an indication of how old this version was testing for.
> This is the section that will fail:
> Verify Release of Device
> Case ID: hcn-002
> In the terminal, run sudo ifdown [interface] where [interface] is the
> interface name, above.
> * In the terminal, run ifconfig and verify that only the loopback device
> ("lo") is listed.*
> There is always at least four devices listed. Apparently a knowledgeable
> person can tell that the device is up or down but that is not what this
> question asks for. Someone tell me what we want and I will be glad to
> rewrite it. If we are looking for a device that is up or down, we need to
> write that in plain english so anyone can do this. I tried to address this
> as a question but was recommended that I file a bug.
>
> 1)lsb_release -rd
> Description: Ubuntu Natty (development branch)
> Release: 11.04
>
> 2)apt-cache policy pkgname
> N: Unable to locate package pkgname
> Don't know where in the software center this information is.
>
> 3) I expected to test this application and give good, useful,
> feedback.
>
> 4) I could not perform a useful test because of outdated testing
> procedures.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/731737/+subscriptions
>

On Thu, Jun 30, 2011 at 11:06 AM, Mark Nighswonger
<email address hidden> wrote:
> Hi Mathieu,
> Will the functions of Network Manager change drastically? Do you have an
> estimate of completion of the developmental changes? I will probably do some
> interim updating because I don't think the test is usable in it's current
> state.
Hi,

AFAIK, all the features have already landed for NetworkManager in Oneiric.

Mathieu Trudel-Lapierre <email address hidden>
Freenode: cyphermox, Jabber: <email address hidden>
4096R/EE018C93 1967 8F7D 03A1 8F38 732E FF82 C126 33E1 EE01 8C93

Mark Nighswonger (marknigh) wrote :

Okay great!
Thanks,
Mark

On Thu, Jun 30, 2011 at 1:03 PM, Mathieu Trudel-Lapierre <mathieu.tl@
gmail.com> wrote:

> On Thu, Jun 30, 2011 at 11:06 AM, Mark Nighswonger
> <email address hidden> wrote:
> > Hi Mathieu,
> > Will the functions of Network Manager change drastically? Do you have an
> > estimate of completion of the developmental changes? I will probably do
> some
> > interim updating because I don't think the test is usable in it's current
> > state.
> Hi,
>
> AFAIK, all the features have already landed for NetworkManager in
> Oneiric.
>
> Mathieu Trudel-Lapierre <email address hidden>
> Freenode: cyphermox, Jabber: <email address hidden>
> 4096R/EE018C93 1967 8F7D 03A1 8F38 732E FF82 C126 33E1 EE01 8C93
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/731737
>
> Title:
> [testcases] Networking / NM Laptop Test section is outdated
>
> Status in “network-manager” package in Ubuntu:
> Triaged
>
> Bug description:
> Binary package hint: network-manager
>
> It appears that the Networking section for Laptop Testing,
> http://testcases.qa.ubuntu.com/Plans/LaptopTesting , is outdated and needs
> to be rewritten by someone who knows what needs to be tested and how. The
> current test would fail every time as written. There is no longer a computer
> icon, so that may be an indication of how old this version was testing for.
> This is the section that will fail:
> Verify Release of Device
> Case ID: hcn-002
> In the terminal, run sudo ifdown [interface] where [interface] is the
> interface name, above.
> * In the terminal, run ifconfig and verify that only the loopback device
> ("lo") is listed.*
> There is always at least four devices listed. Apparently a knowledgeable
> person can tell that the device is up or down but that is not what this
> question asks for. Someone tell me what we want and I will be glad to
> rewrite it. If we are looking for a device that is up or down, we need to
> write that in plain english so anyone can do this. I tried to address this
> as a question but was recommended that I file a bug.
>
> 1)lsb_release -rd
> Description: Ubuntu Natty (development branch)
> Release: 11.04
>
> 2)apt-cache policy pkgname
> N: Unable to locate package pkgname
> Don't know where in the software center this information is.
>
> 3) I expected to test this application and give good, useful,
> feedback.
>
> 4) I could not perform a useful test because of outdated testing
> procedures.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/731737/+subscriptions
>

Changed in network-manager (Ubuntu):
status: Triaged → In Progress
summary: - [testcases] Networking / NM Laptop Test section is outdated
+ [testcases] Networking / NM Laptop Test section needs a revision
Glen Ditchfield (gjditchfield) wrote :

When I ran through the Laptop Wireless Network test cases
(http://testcases.qa.ubuntu.com/Hardware/Network/Wireless) I ran into a problem with the test cases themselves: my laptop passed the tests, even though wireless networking on it is useless -- see bug 847215.

The problem is that five pings don't exercise the network hard enough to turn up this bug. I suggest adding a step that runs "wget --output-document=/dev/null" to fetch some document, to both the wireless and cabled network tests.

Mark Nighswonger (marknigh) wrote :

If I knew how to close this out, I would. The test pages are completed for the time being. Mr Ditchfield has a bug filed elsewhere.
Unless instructed to do so, I don't have any need to make changes at the present time.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/731737

tags: added: laptop-testing
Thomas Hood (jdthood) on 2012-07-20
Changed in network-manager (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers