network-manager blocks my keyboard

Bug #68364 reported by Alessandro on 2006-10-26
4
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

Laptop Model: HP NX6125 PY416ET
System: Ubuntu Edgy RC 64-bit updated 26/10/2006

Sometime my internet connection goes down because of the provider. When i was with dapper i was usually to switch off / switch on eth0 to re-connect my laptop using nm-applet (right-click on the applet - active interface)

If i do it with edgy my keyboard stops to work...i can no loger use it and i've to switch off brutal my laptop using holding its swicht-on button.

I tested this behavior three time before i posted it.

Is it a bug of network-manager?

Kevin Goldstein (parktownprawn) wrote :

I have a similar problem with network manager.

When I plug in my wireless card the computer completely freezes and an I have to do a hard reboot.

my wireless card uses the prism 2/2.5/3 chipset (it is a linksys wpc11 ver 3)

this happens using both the orinoco and hostap drives for my card.

(to get the hostap driver working i have to blacklist the orinoco_cs module )

also even after removing network manager, gnome becomes very sluggish. Applications take ages to load.

...news...

Today to overcome the problem i tried to remove the cable when i lost my connection. It doesn't work because nm-applet continued the network-retrieve. So i tried this command:

sudo ifdown eth0

i received this message:

alessandro@ubuntu:~/Desktop$ sudo ifdown eth0
Password:
There is already a pid file /var/run/dhclient.eth0.pid with pid 5798864
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:0f:b0:71:7b:25
Sending on LPF/eth0/00:0f:b0:71:7b:25
Sending on Socket/fallback
DHCPRELEASE on eth0 to 192.168.1.1 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.

So i killed nm-applet and re-connected the cable. It woked because using

sudo dhclient eth0

i had a new ip-address.

After that i tried to restart nm-applet but it didn't work

I think that this bug is the same as #60825 (see my config and report there), since I have also noticed problems with gnome applications after a network-manager induced keyboard freeze --- actually, their loading stops after a while...

John Vivirito (gnomefreak) wrote :

Thank you for your bug report. Can you please grab the latest gutsy livecd and see if this has been fixed in gutsy.

Changed in network-manager:
status: New → Incomplete
John Vivirito (gnomefreak) wrote :

to grab the latest Gutsy Desktop cd please visit
http://cdimage.ubuntu.com/daily/current/

Alexander Sack (asac) wrote :

If you still see this issue with latest gutsy network-manager, please reopen this bug.
 - Alexander

Changed in network-manager:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers