network-manager applet doesn't manage devices when connman is installed

Bug #659460 reported by Akos Kemives on 2010-10-12
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
connman (Ubuntu)
Medium
Mathieu Trudel-Lapierre
network-manager (Ubuntu)
Low
Mathieu Trudel-Lapierre

Bug Description

Binary package hint: network-manager

If both connman and network-manager are installed, at booting connman gets acces to dbus, but network-manager doesn't.
These packages should be marked as conflicts in the package management system.
This bug affects both connman and network-manager.

1)Description: Ubuntu 10.10
   Release: 10.10

2)network-manager: 0.8.1+git.20100810t184654.ab580f4-0ubuntu2
   connman: 0.55-0ubuntu3

3)I installed the indicator-network package to try out the indicator integration, it installed the package connman too as a dependency.

4)I was not able to manage my network connections via network-manager, however i didn't get any notification about that it isn't possible if both packages are installed.

Related branches

Right, I saw this as well on my netbook, connman just "takes over". Both network-manager and connman should probably add Conflicts/Replaces fields in debian/control to make sure they aren't installed together.

Changed in network-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Mathieu Trudel (mathieu-tl)
Changed in connman (Ubuntu):
status: New → Confirmed
importance: Undecided → Low

I think it's not. Sergey Klimov doesn't mention that there is no internet connection while both applications are installed, however in my case this was the main problem.

renormalist (ss5) wrote :

Confirmed problem and solution: Uninstalling connman made network-manager work again.
And I also think it's not a duplicate of bug #647655.

Mitch Hannah (mitchlhannah) wrote :

Same problem here. Started on first restart after installing KDE 4. Removing connman and KDE fixed it. You don't have the problem until you restart. I used KDE for several days and logged in and out numerous times both in Gnome and KDE. When I restarted the problem started.

Kalle Valo (kvalo) on 2011-02-08
Changed in connman (Ubuntu):
status: Confirmed → Triaged
importance: Low → Medium
Changed in connman (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package connman - 0.69-0ubuntu1

---------------
connman (0.69-0ubuntu1) natty; urgency=low

  * New upstream release.
    - dhcpd.conf domain-name not transmitted to /etc/resolv.conf (LP: #604581)
    - provide NM compatiblity code for applications which request network
      status (LP: #586033)
  * debian/control: explicitly Conflict with network-manager. (LP: #659460)
  * debian/rules: enable udev and the builtin dhclient during build.
  * debian/patches/04-wifi-add-a-disconnected-timer.patch: refreshed.
  * debian/patches/09-disable-wifi-legacy.patch: dropped.
  * debian/control: drop dhcp3-client Build-Depends, it's no longer required.
  * debian/patches/10-fix-dhcp-renewal-disconnect.patch: avoid disconnections
    caused by calling dhcp_bound() when DHCP renewal results in no IP change.
    (LP: #713146)
  * debian/control: Recommend indicator-network for UI. (LP: #704867)
  * debian/manpages/connmand.8: update to add BUGS section and fix AUTHORS
    (LP: #587779)
  * debian/control: Remove binary Depends on dhcp3-client for connman.
 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 15 Feb 2011 23:43:45 -0600

Changed in connman (Ubuntu):
status: Triaged → Fix Released
finndo (finndo77) wrote :

This happened to me yesterday with a fresh install of Xubuntu 10.10 AFTER completely patching (all updates applied) and adding WiCD Network Manager 1.7.0+ds1-5 (wicd-gtk) using the Ubuntu Software Center to complete the install. It was not resolved when uninstalled using the Ubuntu Software Center.

manually typing [sudo apt-get purge cannman] and rebooting resolved the issue.

Please continue to look into this issue.

connman has nothing to do with wicd; please file a new bug report for your issue if you think there is something additional that should be done to help.

I'll fix this by adding the equivalent Conflicts: connman to network-manager, but network-manager-gnome doesn't need to conflict with connman, their purpose if very different.

summary: - network-manager-gnome applet doesn't manage devices when connman is
- installed
+ network-manager applet doesn't manage devices when connman is installed
Changed in network-manager (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.9.2.0+git201202161854.8572ecf-0ubuntu4

---------------
network-manager (0.9.2.0+git201202161854.8572ecf-0ubuntu4) precise; urgency=low

  [ Gabor Kelemen ]
  * debian/network-manager.upstart: Make NM aware of the locale. (LP: #875017)

  [ Mathieu Trudel-Lapierre ]
  * debian/patches/lp936712_dnsmasq_ip6_ns_ordering.patch: order IPv6
    nameservers before IPv4 ones in dnsmasq config: dnsmasq is able to properly
    deal with broken IPv6 nameservers (or routers). (LP: #936712)
  * debian/control: add Conflicts: connman to network-manager. (LP: #659460)
  * debian/patches/manage-privacy-extensions.patch: set the default for using
    IPv6 Privacy extensions to TRUE; this is just correcting an oversight from
    adapting the upstream patch. (LP: #176125)
 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 21 Feb 2012 19:40:35 -0500

Changed in network-manager (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers