[edgy] network-manager sees usb wifi (rt73usb) as wired net

Bug #62535 reported by Robert Nasiadek on 2006-09-27
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
linux (Ubuntu)
linux-source-2.6.22 (Ubuntu)
network-manager (Ubuntu)

Bug Description

I have a ralink-based card supported by rt73usb module, and network-manager reports it as Wired Network (Unknown USB Vendor Specific Interface).


On Wed, Sep 27, 2006 at 12:12:22AM -0000, Robert Nasiadek wrote:
> I have a ralink-based card supported by rt73usb module, and network-
> manager reports it as Wired Network (Unknown USB Vendor Specific
> Interface).

Could you attach the output of 'ls -l /sys/class/net/eth1' where "eth1"
should be replaced by the ifname of your netcard? Also, the contents of
/proc/net/wireless would be helpful.


Robert Nasiadek (robzon) wrote :

Actually, the driver for the card creates two network interfaces wlan0 and wmaster0. From the command line I use wlan0 to connect to networks, and wmaster0 seems kinda weird - I'd suppose it's an interface for setting up APs, but iwconfig doesn't even show mode for the interface (wlan0 is managed).
This is what I get:

wmaster0 IEEE 802.11g Frequency:2.412 GHz
          RTS thr:off Fragment thr=2346 B

wlan0 IEEE 802.11g ESSID:""
          Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
          RTS thr:off Fragment thr=2346 B
          Encryption key:off

So I guess wmaster0 is insignificant, but just so you know...
And the other weird thing is there is no entry for my wlan0 card in the /proc/net/wireless file.
The ath0 interface listed in the file is a different card (atheros) which works well with nm.
Ok enough talking :-)
Here goes wlan0.log...

Robert Nasiadek (robzon) wrote :
Robert Nasiadek (robzon) wrote :
Soren Hansen (soren) wrote :

This is actually a hal issue. Reassigning accordingly.

Changed in network-manager:
status: Unconfirmed → Rejected
Robert Nasiadek (robzon) wrote :

Any tips on how to get more into it? What could be wrong, where to look for the error? I'd like to play around with this as I _really_ need this to work with nm. I'm just totally lost and I'd appreciate any advice with this. Even a quick and dirty temporary hack will do. Pretty please.....


Scott Robinson (scott-ubuntu) wrote :

apt-get source hald

Take a look and find out why your card is being assigned incorrectly? If you don't know C/C++, though, it'll be hard.

Robert Nasiadek (robzon) wrote :

I know both, but I know nothing about how hald works, where to look for part of the code that may cause the problem, etc.
I'll try to get familiar with the code, but it requires a lot of time.

By the way, I've checked a different driver (the one from ralink site) and it's listed in the /proc/net/wireless file and has the wireless info in sysfs, but NetworkManager doesn't see it at all.
Any ideas on that one?

$ cat /proc/net/wireless
Inter-| sta-| Quality | Discarded packets | Missed | WE
 face | tus | link level noise | nwid crypt frag retry misc | beacon | 20
rausb0: 0000 0. 0 113 0 0 0 0 0 0


Robert Nasiadek (robzon) wrote :

I think this may be actually a bug in ralink driver. I've checked with PCMCIA ralink-based card and get the same results - NetworkManager thinks it's a wired interface, and there's no entry in /proc/net/wireless. An atheros-based card works pretty well.


Scott Robinson (scott-ubuntu) wrote :

Try taking a look (and attaching to this bug) the results from an "lshahl". However, if the wireless card isn't registering as wireless, then it will be very difficult for NM to do anything about it.

Depends on your response, I will re-assign this bug to linux-meta as the issue sounds like a driver issue.

Kyle McMartin (kyle) wrote :

Full output of "sudo iwconfig" please.

This bug is present in Feisty too.

iwconfig says:

rausb0 RT73 WLAN ESSID:off/any
          Mode:Auto Channel=1 Bit Rate:54 Mb/s
          RTS thr:off Fragment thr:off
          Encryption key:off

I confirm the presence of this bug in Feisty.

rnmartinez (rnmartinez) wrote :

I also am experiencing this bug in Feisty. I followed an excellent guide on the ubuntu forums and compiled the rt73 driver from ratech, and still no luck. The only setting I was able to change (from the ones that I needed) was the channel. Also, when I tried sudo iwlist rausb0 scanning I received an error message saying this interface does not support scanning.

Panko (espindarga) wrote :


I'm having the same problem with a TP-Link TL-WN321G usb wifi using rt73 driver from ralink, and searched the net for information... and have no results...

I'm not a progammer, so I can't see where's the problem on hal, as you've said before...
But I'm thinking in possibility to use the "hal-device-manager" in Feisty to change the specifications of that device... so, ¿It's possible?

If someone can get specifications of a similar device that works correctly, possibly I can try to change in "hal-device-manager" for my device and see if it works...

P.D.: Sorry if my english is not correct... I'm spanish and only have basic knowns of that language...

nagy.pite (nagy.pite) wrote :

Same problem (Edimax EW-7318Ug), no solution.
Maybe Gutsy?..

John Vivirito (gnomefreak) wrote :

network-manager is now undergoing a massive QA effort
Please test Gutsy desktop cd (livecd) to see if your bug is still present.
to grab the latest Gutsy Desktop cd please visit

Noam (noam-halevy) wrote :

Same problem on Gutsy, using Edimax EW-7318Ug.
I am able to connect using iwpriv configuration commands for settng the SSID, encription, etc, but network manager see
the card as wired.

rodiq (rodiq) wrote :

Same problem on Gutsy, using Edimax EW-7318UG.
I am also able to connect by setting configuration in the /etc/Wireless/RT73STA/rt73sta.dat, but the network manager sees the card as wired.

Any workaround?

Caroline Ford (secretlondon) wrote :

Is this still a problem in hardy?

This is a problem with the driver I expect, not hal. Reallocating to the kernel.

Caroline Ford (secretlondon) wrote :

hal ->linux

SysStream (mysiddiq) wrote :

Yes this bug is still visible in hardy. Hal issue?

I can't confirm this bug in my Ubuntu Hardy 8.04.1 with the kernel 2.6.24-19.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.


2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Ralph Janke (txwikinger) wrote :

Unfortunately this bug report is being closed because we received no response to the last inquiry for information. However, the Intrepid Ibex 8.10 Beta release was most recently announced - http://www.ubuntu.com/testing/intrepid/beta . If you are able to confirm this is still an issue with this most recent release please feel free to reopen this report. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks.

Changed in linux:
importance: Undecided → Medium
status: Incomplete → Won't Fix
importance: Medium → Low
Changed in hal:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers